Framegrabber SDK를 사용하여 CXP 라인 스캔 카메라 및 프레임 그래버 구성하기#
요구 사항 및 가능한 토폴로지에 대한 정보는 General Information을 참조하십시오.
Framegrabber SDK 설치#
관리자 권한 필요
Framegrabber SDK를 설치하려면 컴퓨터에 관리자 권한이 필요합니다.
Basler racer 2 카메라와 함께 사용할 Framegrabber SDK를 설치하려면:
- Framegrabber SDK 버전 5.11.2 이상을 다운로드합니다.
- 설치 프로그램을 실행하고 설치를 진행합니다.
- Select Components 대화 상자에서 Full installation을 선택하고 구성 요소 목록에서 GenTL Producer가 선택되었는지 확인합니다.

자세한 설치 지침은 Basler 제품 문서의 Installing the Framegrabber SDK 주제를 참조하십시오.
microDisplay X 첫 걸음#
-
이미지를 처음 확인하려면 microDisplay X를 엽니다.
-
Basler racer 2 카메라를 사용한 이미지 획득을 단순화하는 몇 가지 기본 설정을 구성합니다:
- 다음 항목에서 도구 > Settings > Acquisition으로 설정하고 Number of Buffers (으)로
100(을)를 설정합니다. 이를 통해 획득한 이미지를 탐색할 수 있으며, 이는 카메라 캘리브레이션에 매우 유용합니다. -
다음 값 중 하나로 Acquisition Timeout (을)를 높은 값(예:
1000 s)으로 설정합니다. 이는 트리거 설정에 필수적이며 타임아웃 발생을 방지합니다.
-
Tools > Settings > Discovery에서 Autoconnect discovered cameras 확인란을 선택합니다.

- 다음 항목에서 도구 > Settings > Acquisition으로 설정하고 Number of Buffers (으)로
-
microDisplay X에서 앱릿을 로드합니다. 설정에 필요한 앱릿을 확인하려면 Possible Topologies를 참조하십시오.

-
앱릿 이름을 더블 클릭합니다. 이제 프레임 그래버 FPGA가 앱릿으로 구성됩니다.
-
Autoconnect discovered cameras를 선택했으므로 카메라가 연결되어 있어야 합니다.

-
Applet Layout 창에서 DMA 0 또는 Cam 0을 클릭하여 카메라와 프레임 그래버 또는 인터페이스 카드의 파라미터 간에 전환할 수 있습니다. 하나 이상의 프레임 그래버 또는 인터페이스 카드에 여러 카메라를 연결한 경우 여기서 카메라와 DMA 채널을 선택할 수 있습니다.
- 원하는 대로 카메라와 프레임 그래버 또는 인터페이스 카드를 구성합니다.
-
중요한 프레임 그래버 또는 인터페이스 카드 파라미터는 카메라 설정과 일치해야 합니다. 해당 파라미터는 다음과 같습니다.
- CoaXPress > Pixel Format
- ROI > Width
- ROI > Height의 경우 원하는 이미지 높이를 정의합니다. 이 파라미터 값은 출력 이미지의 카메라 라인 수를 정의합니다.

-
이미지 획득을 시작하려면 Acquisition Channel (으)로 Viewing 창으로 이동하여 다음을 클릭합니다.
Play button. -
microDisplay X는 프레임 그래버 ROI 설정을 지원합니다. 라인 스캔 카메라의 경우 Ignore를 클릭합니다.

카메라와 프레임 그래버 또는 인터페이스 카드가 free run mode로 설정되어 있는 동안 카메라 이미지가 표시됩니다.

CoaXPress Line Trigger 사용#
CoaXPress 라인 트리거를 사용하려면 카메라를 CoaXPress Trigger Mode로 설정하고 다음과 같이 카메라와 프레임 그래버 또는 인터페이스 카드를 구성합니다.
파라미터를 구성하기 전에 이미지 Acquisition을 중지하십시오.
파라미터 설정을 구성하기 전에 반드시 이미지 Acquisition을 중지해야 합니다. 그렇지 않으면 일부 파라미터를 편집할 수 없습니다.
- Applet Layout 창에서 Cam 0을 선택합니다.
-
Acquisition Control 아래의 Parameter Selection 창에서 다음 파라미터를 설정합니다.
Trigger Mode=OnTrigger Source=Cxp Trigger 0

기본적으로 프레임 그래버는 200 µs 주기의 내부 제너레이터를 사용합니다. 소스를 변경하거나 샤프트 엔코더를(을) 사용하려면 DMA 0 (으)로 Applet Layout 창을 선택하고 하드웨어 설정에 맞는 Line Trigger / ExSync 파라미터를 구성하십시오. 
파라미터에 대한 자세한 설명은 imaFlex CXP-12 Quad, imaWorx CXP-12 Quad 및 CXP-12 Interface Cards의 애플릿 문서를 참조하십시오.
Exposure Mode Trigger Width 및 Trigger Controlled#
외부 신호로 노출 시간을 제어하려면 다음 두 가지 Exposure Mode를 사용할 수 있습니다. Trigger Width 및 Trigger Controlled.
- 사용
Trigger Width트리거 신호를 카메라의 I/O에 직접 연결하는 경우. - 사용
Trigger ControlledCXP 트리거 패킷이 사용되고 트리거가 카메라를 통해 들어오는 경우.
Exposure Mode Trigger Width#
Exposure Mode Trigger Width을(를) 사용하려면 카메라에서 다음 파라미터를 설정해야 합니다.
- 이 Exposure Mode로 전환하려면 카메라 파라미터를
Exposure Mode=Trigger Width. - 트리거를 구성하려면 다음 파라미터를 설정합니다.
Trigger Selector=Line StartTrigger Mode=OnTrigger Source트리거를 연결한 I/O(예: )로 설정합니다.Line1.- 신호가 반전된 경우 선택적으로
Trigger Activation=Falling Edge.
Exposure Mode에서 Trigger Width, 카메라가 CXP를 통하지 않고 I/O의 트리거 신호를 직접 사용합니다. 따라서 Exposure Mode를 선택하는 경우 프레임 그래버에 대한 트리거 파라미터를 구성할 필요가 없습니다. Trigger Width.

Exposure Mode Trigger Controlled#
Exposure Mode Trigger Controlled을(를) 사용하려면 카메라에서 다음 파라미터를 설정해야 합니다.
- 이 Exposure Mode로 전환하려면 카메라 파라미터를
Exposure Mode=Trigger Controlled. -
트리거를 구성하려면 다음 파라미터를 설정하십시오. 이를 통해 CoaXPress 트리거에 의해 노출이 시작되고 종료됩니다.
Trigger Selector=Exposure StartTrigger Mode=OnTrigger Source=Cxp Trigger 0.

Trigger Selector=Exposure EndTrigger Mode=OnTrigger Source=Cxp Trigger 1.

이제 생성할 프레임 그래버를 구성해야 합니다. Cxp Trigger 0 및 Cxp Trigger 1 트리거 패킷. 다음 세 가지 옵션이 있습니다.
- 기본적으로 내부 생성기가 사용됩니다.

- 다음을 변경하는 경우
LineTriggerMode매개변수:Async Gated Trigger, I/O 신호를 사용하여 노출 시간을 제어할 수 있습니다.
- 또는 I/O 신호를 직접 우회하여
CXP Link Trigger 0및CXP Link Trigger 1노출의 시작과 종료를 제어합니다.
이미지 검사#
microDisplay X는 획득한 이미지를 검사하는 여러 가지 방법을 제공합니다. 다음 항목은 카메라를 보정할 때 유용합니다.
- Line Histogram 뷰
- Line Profile 뷰
- 획득한 이미지 시퀀스 넘겨보기
- 픽셀 값 가져오기 또는 각 픽셀 확대하기
- 현재 이미지 또는 이미지 시퀀스 저장
자세한 내용은 Basler Product Documentation의 Examining Images 항목을 참조하십시오.
SDK 코드 복사#
구성을 SDK 프로그램에 복사하려면 임의의 파라미터의 Details를 선택하고 SDK 코드를 복사하십시오.

또는 microDisplay X에서 구성 파일을 저장하고 SDK 프로그램에서 로드할 수 있습니다. 자세한 내용은 Basler Product Documentation의 Saving Applet Configuration 항목을 참조하십시오.
GenTL을 사용하려면 동일한 파라미터 구성을 따르십시오. GenTL Producer는 %GENICAM_GENTL64_PATH% 디렉터리에서 찾을 수 있습니다.