카메라 캘리브레이션#
초점 거리, 렌즈 왜곡, 카메라 간의 상대적 위치 등 카메라를 측정기로 사용하기 위한 카메라 파라미터는 정확하게 파악되어야 합니다. 이러한 파라미터는 보정을 통해 결정되며, 이후 모든 이미지 처리의 기반이 되는 이미지 정류에 사용됩니다. Stereo ace 카메라는 카메라 보정을 바탕으로 이미지를 자동으로 정류합니다.
Stereo ace 카메라는 생산 중에 보정됩니다. 카메라도 떨어뜨리는 등의 강한 기계적 충격에 노출된 경우 재보정이 필요할 수 있습니다. 카메라가 갑자기 3D 데이터를 더 이상 출력하지 않는 경우 재보정이 필요하다는 것을 알 수 있습니다.
Self-Calibration#
Stereo ace 카메라에는 백그라운드에서 저주파로 실행되는 자체 보정(Self-Calibration) 모드가 있습니다. 이 모드에서 카메라는 두 정류된 이미지의 라인 정렬 상태를 모니터링합니다. 카메라를 떨어뜨리는 등의 기계적 충격은 정렬 틀어짐을 유발할 수 있습니다. 상당한 정렬 틀어짐이 감지되면 자동으로 수정됩니다.
자체 보정을 활성화하려면 다음을 설정하십시오. BslSelfCalibration 파라메터 On.
다음의 값은 BslSelfCalibrationUpdateCounter 자동 수정이 수행될 때마다 파라미터가 증가합니다. 카메라를 수동으로 재보정한 후에는 다음 값으로 재설정됩니다. 0.
Stereo ace 카메라에 기계적 충격이 없는 등의 일반적인 조건에서는 자체 보정이 발생하지 않아야 합니다. 자체 보정 기능을 사용하면 정렬 틀어짐이 감지되더라도 자동으로 수정되므로 Stereo ace 카메라가 정상적으로 계속 작동할 수 있습니다. 그러나 다음과 같은 경우 Basler에서는 카메라를 수동으로 재보정할 것을 권장합니다. BslSelfCalibrationUpdateCounter 가 아니며 0.
Manual Calibration#
캘리브레이션 그리드를 카메라 앞에 들고 있으면서 그리드의 모든 검은색 사각형이 두 카메라 이미지에 완전히 표시되고 가려지지 않았는지 확인하세요. 올바르게 감지된 사각형에는 녹색 체크 표시가 나타납니다. 올바른 보정을 보장하려면 모든 검은색 사각형이 올바르게 감지되어야 합니다. 일부 사각형이 잠깐만 보이거나 전혀 감지되지 않는 경우, 조명 조건이 좋지 않거나 그리드가 손상되었기 때문일 수 있습니다. 캘리브레이션 그리드의 과노출된 부분에 있는 사각형은 빨간색으로 강조 표시됩니다. 이 경우 조명 조건이나 노출 설정을 조정해야 합니다. 캘리브레이션 그리드 주위의 두꺼운 녹색 테두리는 두 카메라 이미지에서 그리드가 올바르게 감지되었음을 나타냅니다.
수동 보정은 Stereo Calibration Tool을 사용하여 수행할 수 있습니다. pylon 3D Viewer에서 Tools > Stereo Calibration Tool을 차례로 클릭하여 도구를 시작합니다. 이 도구에는 보정의 개별 단계를 위한 다양한 탭이 있습니다. 이에 대한 자세한 내용은 다음과 같습니다:
- Initial settings
- Adjust Focus
- Verify Calibration
- Calibrate
- Monocalibration
- Calculate
- Save
초기 설정#
보정 절차를 시작하려면 카메라와 캘리브레이션 그리드를 선택해야 합니다.
- pylon 3D Viewer의 Tools 메뉴에서 Stereo Calibration Tool을 클릭하여 도구를 시작합니다.
- Stereo Calibration Tool의 File 메뉴에서 Connect Camera를 클릭합니다.
Select Camera 대화 상자가 열립니다. 사용 가능한 카메라가 여기에 자동으로 나열됩니다. - 원하는 카메라를 선택합니다.
- Calibration Grid 드롭다운 목록에서 원하는 캘리브레이션 그리드를 선택합니다.
- OK를 클릭합니다.

Verify Calibration#
이제 현재 보정을 확인할 수 있습니다. 일반적인 보정 오차는 0.2픽셀 미만입니다. 카메라에 표시된 오차가 이 범위 내에 있다면 보정 절차를 종료할 수 있습니다. 보정 오차가 더 큰 경우 최적의 카메라 성능을 보장하기 위해 보정 절차를 계속 진행해야 합니다.
검증을 수행하려면 두 카메라에 동시에 보이도록 그리드를 카메라 앞에 들고 계십시오. 그리드가 감지되는 즉시 캘리브레이션 오차가 자동으로 계산되고 결과가 화면에 표시됩니다.
캘리브레이션을 계속 진행하려면 Calibrate를 클릭하십시오.

정보
의미 있는 캘리브레이션 오차를 계산하려면 그리드를 카메라에 최대한 가깝게 들어야 합니다. 그리드가 카메라 이미지의 작은 부분만 차지하는 경우 캘리브레이션 오차는 그리드가 전체 이미지를 차지할 때보다 항상 낮게 나타납니다. 이러한 이유로 현재 그리드 위치에서의 캘리브레이션 오차 외에도 검증 중 최소 및 최대 캘리브레이션 오차가 함께 표시됩니다.
Calibrate#
캘리브레이션을 시작하기 전에 적절한 Exposure Time을 지정하십시오. 양호한 캘리브레이션 결과를 얻으려면 이미지가 잘 노출되어야 하고 모션 블러를 방지해야 합니다. 따라서 씬이 잘 노출되도록 허용하면서 Exposure Time을 가능한 한 짧게 설정해야 합니다.
전체 캘리브레이션은 각 카메라를 개별적으로 캘리브레이션(모노 캘리브레이션)하고 카메라 간의 관계를 확인하기 위해 스테레오 캘리브레이션을 수행하는 과정으로 구성됩니다. 대부분의 경우 각 카메라의 고유 캘리브레이션(Intrinsic Calibration)은 그대로 유지됩니다. 따라서 재캘리브레이션 중에는 기본적으로 모노 캘리브레이션이 건너뛰어지지만, Monocalibration 버튼을 클릭하여 수행할 수 있습니다.
스테레오 캘리브레이션 중에는 두 카메라가 서로 캘리브레이션되어 상대적인 회전 및 평행 이동을 찾게 됩니다.
먼저 그리드를 카메라에 최대한 가깝게 들고 매우 흔들리지 않게 유지해야 합니다. 두 이미지에 완전히 보여야 하며 카메라는 그리드를 수직으로 바라봐야 합니다. 그리드가 카메라의 시선 방향과 수직이 아닌 경우, 그리드 모서리의 예상 위치를 가리키는 작은 초록색 화살표가 이를 나타냅니다.

그리드가 흔들리지 않도록 매우 정지된 상태로 유지해야 합니다. 모션 블러가 발생하면 그리드가 감지되지 않습니다. 이미지에 그려진 모든 그리드 셀은 캘리브레이션 그리드로 덮여야 합니다. 이는 덮인 셀을 초록색으로 채워 시각화됩니다.
모든 그리드 셀이 덮이면 해당 셀들이 사라지고 단일 원거리 셀이 시각화됩니다. 이제 작은 셀이 덮이도록 그리드를 카메라에서 가능한 한 멀리 들고 있어야 합니다. 그리드가 여전히 카메라와 너무 가까우면 화살표가 이를 나타냅니다. 원거리 포즈에서 그리드가 성공적으로 감지되면 셀이 초록색으로 채워지고 결과를 계산할 수 있습니다.
스테레오 캘리브레이션 결과 만족스럽지 않은 캘리브레이션 오차가 발생하는 경우, 먼저 모노 캘리브레이션을 수행한 후 스테레오 캘리브레이션을 다시 반복해야 합니다.
Monocalibration#
모노 캘리브레이션은 각 카메라의 고유 캘리브레이션입니다. 고유 캘리브레이션은 일반적으로 유지되므로, 스테레오 캘리브레이션 결과가 만족스럽지 않은 경우에만 모노 캘리브레이션을 수행하면 됩니다.
모노 캘리브레이션을 위해 그리드를 특정 포즈로 카메라 앞에 들어야 합니다. 그리드 모서리의 화살표가 초록색 영역을 가리키며 모든 그리드 모서리를 초록색 영역 내에 배치해야 함을 나타냅니다. 초록색 영역을 민감 영역(Sensitive Area)이라고 합니다. Size of Sensitive Area 슬라이더를 사용하여 크기를 조절함으로써 캘리브레이션을 쉽게 할 수 있습니다. 단, 크기를 너무 많이 늘리면 캘리브레이션 정확도가 약간 떨어질 수 있으니 주의하십시오.

모노 캘리브레이션 프로세스에는 각 카메라에 대해 다섯 가지 포즈가 포함됩니다. 그리드의 모서리나 측면이 민감 영역 위에 배치되면 프로세스는 필요한 다음 포즈를 자동으로 표시합니다. 왼쪽 카메라에 대한 프로세스가 완료되면 오른쪽 카메라에 대해서도 동일한 절차가 반복됩니다.
Calculate#
Calculate 버튼을 클릭하면 프로세스가 완료되고 최종 결과가 표시됩니다. 표시된 결과는 모든 캘리브레이션 포인트의 평균 재투영 오차(Mean Reprojection Error)입니다. 이는 픽셀 단위로 주어지며 대개 0.2 미만의 값입니다.

Save#
지금 Save를 클릭하여 캘리브레이션을 적용하고 Stereo ace 장치에 저장하십시오.