기타 작업(microDisplay X)#
사용자 환경 설정#
- microDisplay X의 GUI 표시(애플릿 표시 및 매개변수 값의 dec/hex/bin 표시)
- 획득 매개변수(버퍼 수, 획득 타임아웃, 최대 DMA 버퍼 크기)
- 카메라 검색 및 카메라 제어 동작
microDisplay X 작업 환경 설정을 지정하려면:
- microDisplay X의 Tools 메뉴에서 Settings를 선택합니다.
-
열리는 대화 상자에서 변경하려는 설정을 조정합니다.
- Applet 표시: 클릭 GUI, 그리고 다음 아래에 Applet 레이아웃 / 보기 모드, 프로그램 창의 Applet 레이아웃 창에 Applet이 표시되는 방식을 결정합니다. Applet의 리소스(포트)를 프로세스별(Process Mode) 또는 리소스 유형별(Resource Mode) 중 어떤 방식으로 나열할지 선택하십시오:
- process mode에서는 하나의 프로세스(하나의 Acquisition 채널)에 속한 리소스(포트)가 Applet 레이아웃 창에 Acquisition Process 엔티티로 나열됩니다.
- resource mode의 DMAs 아래에는 활성화된 모든 DMA 포트(microDisplay X에 로드된 Applet의 포트)가 나열됩니다. Camera Ports 아래에는 관련 Frame grabber에 연결된 모든 카메라가 나열됩니다.
- 기본 정수 표시 모드: 프로그램 창에서 매개변수 및 픽셀 값을 표시하기 위해 십진수, 십육진수, 이진수 옵션을 사용할 수 있습니다.
-
Acquisition parameters: Acquisition 매개변수를 설정하려면 Acquisition을 클릭하고 환경 설정을 정의하십시오:

-
Discovery settings: 검색 매개변수를 설정하려면 Discovery를 클릭하고 환경 설정을 정의하십시오:

- Applet 표시: 클릭 GUI, 그리고 다음 아래에 Applet 레이아웃 / 보기 모드, 프로그램 창의 Applet 레이아웃 창에 Applet이 표시되는 방식을 결정합니다. Applet의 리소스(포트)를 프로세스별(Process Mode) 또는 리소스 유형별(Resource Mode) 중 어떤 방식으로 나열할지 선택하십시오:
Applet 구성 저장하기#
애플릿을 구성한 후(microDisplay X 또는 Framegrabber API를 통해) 구성을 저장할 수 있습니다.
애플릿 구성을 저장하면 다음번에 모든 매개변수가 이미 설정된 상태로 애플릿을 로드할 수 있습니다(프레임 그래버, microDisplay X 및/또는 소프트웨어에서).
정보
애플릿 구성을 저장할 때와 사용할 때 동일한 Framegrabber SDK 버전을 사용해야 합니다. 예를 들어 Framegrabber SDK 버전 5.9.0을 사용하여 애플릿을 구성하고 이 구성을 저장한 경우, 버전 5.9.0 환경에서만 구성을 로드해야 합니다.
다음 섹션에서는 MCF 파일 작업에 필요한 모든 정보를 제공합니다.
MCF 및 MFS 파일#
MCF 파일#
Applet 구성을 저장하면 구성 데이터가 파일로 저장됩니다. 구성 파일의 확장자는 *.mcf입니다. (MCF = microEnable Configuration File)
MCF 파일은 텍스트 형식으로 저장되므로, microDisplay X나 API를 통해서뿐만 아니라 이 파일을 직접 수정하여 개별 매개변수의 설정을 변경할 수 있습니다.

MCF 파일에는 다음 내용이 포함됩니다.
- 속한 애플릿의 이름.
- 지정한 모든 매개변수 설정(유일한 예외: 필드 값).
- 필요한 경우 MFS 파일에 대한 링크(애플릿 구성 중에 정의한 필드 값이 포함됨).
별도의 XML 파일에서의 카메라 구성
MCF 파일에는 카메라 구성이 포함되어 있지 않습니다. 카메라 구성을 별도의 *.xml 파일에 저장할 수 있습니다. MCF 파일에는 애플릿 구성만 포함됩니다.
MFS 파일#
applet의 설정에는 LUT 등의 필드 파라미터가 포함될 수 있습니다. 이러한 필드 파라미터는 MCF 파일에 직접 저장되지 않고, 확장자가 *.mfs인 별도의 파일에 저장됩니다. (MFS = microEnable Field Storage)
MFS 파일을 직접 처리할 필요는 전혀 없습니다.
- applet 구성에 필드 파라미터가 포함된 경우, applet 구성을 저장할 때 MCF 파일과 함께 MFS 파일이 자동으로 생성됩니다.
- applet 구성을 로드할 때는 MCF 파일만 로드하면 됩니다. MFS 파일의 내용(필드 파라미터)은 MCF 파일과 함께 자동으로 로드되기 때문입니다.
정보
각 프레임 그래버 모델별로 일련의 applet을 무료로 사용할 수 있습니다. 이러한 applet을 Acquisition Applets라고 합니다. 모든 Acquisition Applets의 파일 확장자는 *.dll입니다. Acquisition Applets는 applet 세트 단위로 제공됩니다(프레임 그래버 모델당 1개 세트). applet 세트는 Framegrabber SDK와 함께 설치하거나 개별 applet 세트 설치 프로그램을 통해 설치할 수 있습니다(Basler 웹사이트 다운로드 섹션에서 이용 가능). 설치 후 Acquisition Applets는 Framegrabber SDK 설치 디렉토리의 하위 디렉토리인 Dll에 위치합니다. (예: C:\Program Files\Basler\FramegrabberSDK5.x.x\Dll.) Acquisition Applets는 프로그래밍 가능 및 비프로그래밍 가능 프레임 그래버(즉, A Series 및 V Series Frame Grabbers)에서 실행됩니다.
모든 Acquisition Applets에는 필드 파라미터가 포함되어 있습니다. 따라서 Acquisition Applet의 구성을 저장할 때마다 *.mcf 파일과 *.mfs 파일의 두 가지 파일이 생성됩니다. 그러나 *.mfs 파일은 저장/로드할 때 항상 자동으로 생성/로드되므로 별도로 처리할 필요가 없습니다.
다음 배열(필드 파라미터)은 모든 Acquisition Applets 또는 일부 Acquisition Applets에 포함됩니다.
- LUTs
- KneeLUTs
- PoCXPStatePort_x (marathon CXP 보드 전용)
- PoCXPCurrentPort_x (marathon CXP 보드 전용)
- PoCXPVoltagePort_x (marathon CXP 보드 전용)
정보
모든 필드 데이터를 별도의 파일에 저장하면 applet 구성 파일인 MCF를 간결하게 유지할 수 있으며 하위 호환성을 보장할 수 있습니다.
mDisplay X에서의 저장 및 로드#
microDisplay X에서 파일로 Applet 구성 저장하기#
microDisplay X에서 현재 로드된 applet의 구성을 파일로 저장할 수 있습니다.
-
File 메뉴에서 Save Configuration을 선택합니다.

-
applet 구성 파일(*.mcf)을 저장할 디렉토리를 선택합니다.
- *.mcf 파일의 이름을 지정합니다.
- Save를 클릭합니다.
*.mcf 파일이 생성되어 2단계에서 지정한 디렉토리에 저장됩니다. applet 구성에 필드 값이 포함된 경우, applet 구성의 모든 필드 파라미터 값이 포함된 추가 *.mfs 파일이 생성됩니다. MFS 파일은 applet에 필드 파라미터가 포함되어 있는 경우 자동으로 생성됩니다.
microDisplay X에서 파일로부터 Applet 구성 로드하기#
-
microDisplay X에서 구성된 applet을 사용할 프레임 그래버를 선택합니다.

-
File 메뉴에서 Open Configuration을 선택합니다.

-
열리는 대화 상자에서 applet 구성이 포함된 디렉토리로 이동합니다.
- 사용할 *.mcf 파일을 선택하고 Open을 클릭합니다.
구성된 applet이 microDisplay X에 로드되며 프레임 그래버에서 활성화됩니다. applet 구성에 필드 파라미터가 포함된 경우, 해당 *.mfs 파일에서 필드 값이 자동으로 로드됩니다. *.mfs 파일을 별도로 로드할 필요가 없습니다.
Framegrabber API를 통한 저장 및 로드#
Framegrabber API를 통한 파일로의 Applet 구성 저장#
applet 구성 파일을 저장하기 위해 Framegrabber API(라이브러리 fglib5.lib, 헤더 파일 basler_fg.h):
int Fg_saveConfig (Fg_Struct *Fg, const char *Filename)
Parameters:
Fg: 시스템 내의 프레임 그래버(보드 인덱스)입니다. 활성 구성(활성 앱렛 및 해당 파라미터화)을 저장할 프레임 그래버를 여기에서 지정하십시오.Filename: 구성 파일의 이름과 경로를 여기에서 지정하십시오. 파일 확장자는 항상 *.mcf입니다.
앱렛 구성에 필드 값이 포함된 경우, 앱렛 구성의 모든 필드 파라미터 값이 포함된 추가 *.mfs 파일이 생성됩니다. MFS 파일은 앱렛에 필드 파라미터가 포함된 경우 자동으로 생성됩니다.
Framegrabber API를 통한 파일로부터의 Applet 구성 로드#
파일에서 앱렛 구성을 로드하기 위해 다양한 함수를 사용할 수 있습니다(라이브러리 fglib5.lib, 헤더 파일 basler_fg.h):
Frame Grabber 초기화#
*.mcf 파일을 통해 보드를 직접 초기화할 수 있습니다. MCF 파일에는 앱렛 이름이 포함되어 있으므로, MCF 파일에 지정된 앱렛으로 프레임 그래버가 초기화되며 *.mcf 파일에 저장된 앱렛 구성(파라미터화)이 프레임 그래버에 이미 설정됩니다.
앱렛 구성에 필드 파라미터가 포함되어 있고 해당 *.mfs 파일이 *.mcf 파일과 동일한 디렉토리에 저장되어 있는 경우, 이 함수를 호출할 때 필드 파라미터가 자동으로 로드됩니다.
Fg_Struct* Fg_InitConfig (const char * Config_Name, unsigned int BoardIndex)
Parameters:
Config_Name: 구성 파일의 이름과 경로를 여기에서 지정하십시오. 파일 확장자는 항상 *.mcf입니다.BoardIndex: *.mcf 파일로 초기화할 프레임 그래버를 (보드 인덱스를 통해) 여기에서 지정하십시오. 호출 후Fg_InitConfig, 프레임 그래버가 *.mcf 파일에 명시된 앱렛과 동일한 파일에 지정된 앱렛 구성으로 초기화됩니다.
Applet 구성 로드#
이미 앱렛으로 프레임 그래버를 초기화한 후에도 앱렛의 구성을 로드할 수 있습니다.
이 기능을 사용하기 위한 전제 조건:
- 프레임 그래버가 이미 다음 함수를 통해 초기화되었거나
FG_Init또는 마스터로 다음을 통해 초기화됨FG_InitEx. - *.mcf 파일에 저장된 앱렛 구성은 프레임 그래버가 초기화된 앱렛에 적용됩니다. (확실하지 않은 경우 *.mcf 파일을 확인하십시오. 앱렛 이름은 *.mcf 파일의 첫 줄에 언급되어 있습니다.)
앱렛 구성에 필드 파라미터가 포함되어 있고, 해당 *.mfs 파일이 *.mcf 파일과 동일한 디렉토리에 저장되어 있는 경우, 이 함수를 호출할 때 필드 파라미터가 자동으로 로드됩니다.
프레임 그래버 초기화 후 앱렛 구성을 로드하기 위한 함수:
int Fg_loadConfig (Fg_Struct *Fg, const char *Filename)
Parameters:
Fg: *.mcf 파일에 포함된 앱렛 구성으로 파라미터화할 프레임 그래버를 (보드 인덱스를 통해) 여기에서 지정하십시오.Filename: 구성 파일의 이름과 경로를 여기에서 지정하십시오. 파일 확장자는 항상 *.mcf입니다.
정보
함수를 통해 프레임 그래버를 사용한 후에는 프레임 그래버 리소스를 해제하는 것을 잊지 마십시오.
int Fg_FreeGrabber (Fg_Struct *Fg)
이 함수는 이전에 다음을 통해 이 프레임 그래버에 대해 할당된 프레임 버퍼도 해제합니다. Fg_AllocMem().