콘텐츠로 바로 가기
STAGING SERVER
DEVELOPMENT SERVER

blaze Viewer 개요#

이 항목에서는 blaze Viewer의 사용자 인터페이스에 대한 개요를 설명합니다.

다음 스크린샷은 blaze Viewer의 다양한 요소를 보여줍니다.

blaze Viewer 사용자 인터페이스

File 메뉴#

File 메뉴에서는 다음과 같은 명령을 제공합니다:

  • Save Depth and Image Data: 심도 및 이미지 데이터와 카메라 설정을 파일로 저장합니다. 다양한 포맷을 사용할 수 있습니다. 자세한 내용은 Saving Depth and Image Data 항목을 참조하세요.
  • Exit: blaze Viewer를 닫습니다.

보기 메뉴#

View 메뉴를 사용하여 표시할 창을 선택하거나 선택 해제할 수 있습니다.

Camera 메뉴#

Camera 메뉴에서는 다음과 같은 명령을 제공합니다:

  • Rescan: 다른 카메라가 열려 있는지 확인합니다.
  • Open: 카메라를 엽니다. 즉, 사용할 수 있는 상태로 만듭니다.
  • Close: 카메라를 닫습니다.
  • Continuous Shot: 카메라가 이미지를 연속적으로 캡처하도록 합니다.
  • Stop: 이미지 캡처를 중지합니다.
  • Save Features: 카메라 기능의 현재 설정을 .pfs 파일로 저장하며, 이 파일은 표준 텍스트 편집기에서 열 수 있습니다. 기능 설정을 저장하려면 먼저 이미지 취득을 중지해야 합니다.
  • Load Features: 이전에 저장된 카메라 기능 설정이 포함된 .pfs 파일을 로드합니다.

Tools 메뉴#

Tools 메뉴를 통해 pylon IP Configurator 및 Camera Calibration Tool에 액세스할 수 있습니다.

Window 메뉴#

Window 메뉴를 사용하여 이미지 창을 열고 닫으며 이미지 창 영역에 정렬할 수 있습니다.

도움말 메뉴#

Help 메뉴를 통해 다양한 문서 및 도움말 기능에 액세스할 수 있습니다.

  • blaze Viewer Help: 이 항목을 엽니다.
  • Basler Product Documentation: blaze 카메라 문서를 엽니다.
  • Check for Firmware/Software Updates: 펌웨어 및 소프트웨어 업데이트를 확인할 수 있는 웹사이트로 이동합니다.
  • Update Camera Firmware: 브라우저에서 Software Update Tool을 엽니다.
  • Download DiagnosticInfo.tar.gz: Diagnostic Information 기능을 사용한 경우 진단 정보가 포함된 파일을 다운로드합니다.
  • blaze Samples: blaze 프로그래밍 샘플이 포함된 폴더를 엽니다.
  • blaze Programmer's Guide: blaze Programmer's Guide를 엽니다.
  • Release Notes: 릴리스 노트를 엽니다.
  • About blaze Viewer: blaze Viewer의 버전 정보가 포함된 대화 상자를 엽니다.

창(Panes)#

기능#

Features 창에는 카메라 선택기에서 선택한 카메라에서 사용할 수 있는 모든 기능이 표시됩니다. 또한 전문성 수준을 선택할 수 있는 User Level 드롭다운 목록이 포함되어 있습니다. 사용 가능한 옵션은 Beginner, Expert, Guru입니다. Beginner 수준에서는 Features 창에 가장 기본적인 카메라 설정만 표시됩니다. Expert 수준에서는 Features 창에 가장 일반적으로 사용되는 카메라 설정이 표시됩니다. Guru 수준에서는 Features 창에 가장 고급 기능을 포함한 모든 카메라 기능이 표시됩니다.

가장 자주 사용하는 기능을 Favorites 범주에 추가할 수 있습니다. 이를 통해 빠르게 액세스할 수 있으며 기능 트리에서 일일이 찾아야 하는 번거로움을 피할 수 있습니다. 즐겨찾기에 기능을 추가해도 기능 트리의 원래 범주에서 제거되지 않습니다. 즐겨찾기는 blaze Viewer를 닫아도 그대로 유지됩니다.

Features 창에서는 업데이트된 파라미터 값을 위해 정기적으로 카메라를 자동으로 폴링할지 여부도 선택할 수 있습니다. 또는 Refresh 버튼을 클릭하여 기능 목록을 수동으로 새로 고칠 수 있습니다.

새로 고침 버튼

Pixel Information#

Pixel Information 창에는 이미지 창 중 하나에서 선택한 픽셀에 대한 정보가 표시됩니다. Pixel Information 창에 대한 자세한 내용은 Using the Pixel Information Pane을 참조하십시오.

문서#

Documentation 창에는 Features 창에서 현재 선택한 기능에 대한 정보가 표시됩니다. 위의 예에서는 Operating Mode 파라미터가 선택되어 있습니다. 이 창에는 자체 응용 프로그램 코드를 작성할 때 유용할 수 있는 코드 조각도 포함되어 있습니다.

Message Log#

Message Log 창에는 카메라 열기 및 닫기 또는 이미지 취득 시작 등 blaze Viewer로 수행한 작업에 대한 정보가 표시됩니다. 메시지 수준에는 Information, Warning, Critical의 다양한 수준이 있습니다.

Image Window Area#

이 창에는 대상 장면의 다양한 2D 및 3D 보기를 보여주는 4개의 창이 포함되어 있습니다.

모든 창에는 창을 닫고 blaze Viewer 창에서 도킹을 해제하기 위한 버튼이 있습니다. 창의 도킹이 해제되면 바탕 화면에서 자유롭게 이동할 수 있습니다. 다시 도킹하려면 다음 단계를 따르십시오.

  1. 점선 사각형이 나타날 때까지 창을 창 안의 원하는 위치로 드래그합니다.
  2. 창을 놓습니다.