카메라 캘리브레이션#
카메라를 측정 기기로 사용하려면 focal length, 렌즈 왜곡, 카메라 간의 관계 등 카메라 파라미터를 정확히 파악해야 합니다. 이러한 파라미터는 보정을 통해 결정되며, 이후 모든 이미지 처리의 기반이 되는 이미지 정류(rectification)에 사용됩니다. Stereo ace 카메라는 카메라 보정을 바탕으로 이미지를 자동으로 정류합니다.
Stereo ace 카메라는 생산 과정에서 보정됩니다. 떨어뜨리는 등의 강한 기계적 충격에 노출된 경우 재보정이 필요할 수 있습니다. 카메라가 갑자기 3D 데이터를 전송하지 않는 경우 재보정이 필요하다는 것을 알 수 있습니다.
Self-Calibration#
Stereo ace 카메라는 백그라운드에서 낮은 빈도로 실행되는 self-calibration 모드를 갖추고 있습니다. 이 모드에서 카메라는 정류된 두 이미지에서 선의 정렬 상태를 관찰합니다. 떨어뜨리는 등의 기계적 충격은 정렬 틀어짐을 유발할 수 있습니다. 상당한 정렬 틀어짐이 감지되면 자동으로 보정됩니다.
self-calibration을 활성화하려면 다음을 설정하십시오. BslSelfCalibration 매개변수: On.
다음의 값은 BslSelfCalibrationUpdateCounter 파라미터는 자동 보정이 수행될 때마다 증가합니다. 카메라를 수동으로 재보정한 후에는 다음으로 재설정됩니다. 0.
Stereo ace 카메라에 기계적 충격이 없는 등 일반적인 조건에서는 self-calibration이 실행되지 않아야 합니다. self-calibration 기능을 통해 Stereo ace 카메라는 정렬 틀어짐이 감지되더라도 자동으로 보정되어 정상적으로 작동할 수 있습니다. 하지만 Basler에서는 다음과 같은 경우 카메라를 수동으로 재보정할 것을 권장합니다. BslSelfCalibrationUpdateCounter 가 아닙니다 0.
Manual Calibration#
수동 보정 중에는 다양한 포즈에서 calibration grid가 감지되어야 합니다. 보정 그리드를 잡을 때 양쪽 카메라 이미지에서 그리드의 모든 검은색 사각형이 완전히 보이며 가려지지 않도록 하십시오. 올바르게 감지된 사각형에는 녹색 확인 표시가 나타납니다. 올바른 보정을 위해 모든 검은색 사각형이 올바르게 감지되어야 합니다. 일부 사각형이 전혀 감지되지 않거나 잠깐만 감지되는 경우, 조명 조건이 좋지 않거나 그리드가 손상되었기 때문일 수 있습니다. 보정 그리드의 과노출된 부분에 있는 사각형은 빨간색으로 강조 표시됩니다. 이 경우 조명 조건 또는 노출 설정을 조정해야 합니다. 보정 그리드 주위의 두꺼운 녹색 테두리는 양쪽 카메라 이미지에서 올바르게 감지되었음을 나타냅니다.
보정 그리드가 양쪽 카메라 이미지에서 완전히 보이며 가려지지 않도록 카메라 앞에 잡습니다. 올바르게 감지된 사각형에는 녹색 확인 표시가 나타납니다. 올바른 보정을 위해 모든 검은색 사각형이 올바르게 감지되어야 합니다. 일부 사각형이 잠깐만 보이거나 전혀 감지되지 않는 경우, 조명 조건이 좋지 않거나 그리드가 손상되었기 때문일 수 있습니다. 보정 그리드의 과노출된 부분에 있는 사각형은 빨간색으로 강조 표시됩니다. 이 경우 조명 조건 또는 노출 설정을 조정해야 합니다. 보정 그리드 주위의 두꺼운 녹색 테두리는 양쪽 카메라 이미지에서 올바르게 감지되었음을 나타냅니다.
수동 보정은 Stereo Calibration Tool을 사용하여 수행할 수 있습니다. pylon 3D Viewer에서 Tools > Stereo Calibration Tool을 클릭하여 툴을 실행합니다. 이 툴에는 보정의 각 단계를 위한 다양한 탭이 있습니다. 이에 대한 자세한 내용은 다음과 같습니다.
- Initial settings
- Adjust Focus
- Verify Calibration
- Calibrate
- Monocalibration
- Calculate
- Save
Initial Settings#
보정 절차를 시작하려면 카메라와 보정 그리드를 선택해야 합니다.
- pylon 3D Viewer의 Tools 메뉴에서 Stereo Calibration Tool을 클릭하여 툴을 시작합니다.
- Stereo Calibration Tool의 File 메뉴에서 Connect Camera를 클릭합니다.
Select Camera 대화 상자가 열립니다. 사용 가능한 카메라가 여기에 자동으로 나열됩니다. - 원하는 카메라를 선택합니다.
- Calibration Grid 드롭다운 목록에서 원하는 보정 그리드를 선택합니다.
- OK를 클릭합니다.

Verify Calibration#
이제 현재 캘리브레이션을 확인할 수 있습니다. 일반적인 캘리브레이션 오차는 0.2 픽셀 미만입니다. 카메라의 오차가 이 범위 내에 있다면 캘리브레이션 절차를 종료할 수 있습니다. 오차가 더 큰 경우, 최적의 카메라 성능을 보장하기 위해 캘리브레이션 절차를 계속 진행해야 합니다.
확인을 수행하려면 양쪽 카메라에 동시에 보이도록 그리드를 카메라 앞에 들고 있습니다. 그리드가 감지되는 즉시 캘리브레이션 오차가 자동으로 계산되어 화면에 표시됩니다.
캘리브레이션을 계속 진행하려면 Calibrate를 클릭하세요.

정보
의미 있는 캘리브레이션 오차를 계산하려면 그리드를 카메라에 최대한 가깝게 들어야 합니다. 그리드가 카메라 이미지의 작은 부분만 차지하는 경우, 그리드가 전체 이미지를 차지할 때보다 캘리브레이션 오차가 항상 더 낮게 나타납니다. 이러한 이유로 현재 그리드 위치에서의 캘리브레이션 오차 외에도 확인 과정 중의 최소 및 최대 캘리브레이션 오차가 함께 표시됩니다.
Calibrate#
캘리브레이션을 시작하기 전에 적절한 Exposure Time을 지정하십시오. 좋은 캘리브레이션 결과를 얻으려면 이미지가 잘 노출되어야 하고 모션 블러를 피해야 합니다. 따라서 Exposure Time은 장면에 대한 적절한 노출을 허용하면서 가능한 한 짧아야 합니다.
전체 캘리브레이션은 각 카메라를 개별적으로 캘리브레이션하고(모노 캘리브레이션) 카메라 간의 관계를 확인하기 위해 스테레오 캘리브레이션을 수행하는 것으로 구성됩니다. 대부분의 경우 각 카메라의 고유 캘리브레이션은 그대로 유지됩니다. 따라서 재캘리브레이션 중에는 기본적으로 모노 캘리브레이션이 건너뛰어지지만, Monocalibration 버튼을 클릭하여 수행할 수 있습니다.
스테레오 캘리브레이션 동안 양쪽 카메라는 상대적인 회전 및 병진을 찾기 위해 서로 캘리브레이션됩니다.
먼저 그리드를 카메라에 최대한 가깝게 들고 매우 정지된 상태로 유지해야 합니다. 양쪽 이미지에 완전히 보여야 하며 카메라는 그리드를 수직으로 바라봐야 합니다. 그리드가 카메라의 시선 방향에 수직이 아닌 경우, 그리드 모서리의 예상 위치를 가리키는 작은 녹색 화살표가 이를 나타냅니다.

그리드는 매우 정지된 상태로 유지해야 합니다. 모션 블러가 발생하면 그리드가 감지되지 않습니다. 이미지에 그려진 모든 그리드 셀은 캘리브레이션 그리드로 덮여야 합니다. 이는 덮인 셀을 녹색으로 채워 시각화됩니다.
모든 그리드 셀이 덮이면 셀들이 사라지고 단일 원거리 셀이 시각화됩니다. 이제 작은 셀이 덮이도록 카메라에서 최대한 멀리 그리드를 들어야 합니다. 그리드가 카메라에 여전히 너무 가까운 경우 화살표가 이를 나타냅니다. 원거리 포즈에서 그리드가 성공적으로 감지되면 셀이 녹색으로 Fill 되며 결과를 계산할 수 있습니다.
스테레오 캘리브레이션 결과 만족스럽지 않은 오차가 발생하는 경우, 먼저 모노 캘리브레이션을 수행한 후 스테레오 캘리브레이션을 반복해야 합니다.
Monocalibration#
모노 캘리브레이션은 각 카메라의 개별적인 고유 캘리브레이션입니다. 고유 캘리브레이션은 일반적으로 유지되므로, 스테레오 캘리브레이션 결과가 만족스럽지 않은 경우에만 모노 캘리브레이션을 수행하면 됩니다.
모노 캘리브레이션을 위해 그리드를 카메라 앞에 특정 포즈로 들어야 합니다. 모든 그리드 모서리가 녹색 영역 안에 배치되어야 함을 나타내는, 그리드 모서리의 화살표가 녹색 영역을 가리킵니다. 녹색 영역은 민감 영역(sensitive areas)이라고 합니다. Size of Sensitive Area 슬라이더를 사용하여 크기를 조절함으로써 캘리브레이션을 쉽게 할 수 있습니다. 단, 크기를 너무 늘리면 캘리브레이션 정확도가 약간 떨어질 수 있으므로 유의하십시오.

모노 캘리브레이션 프로세스에는 각 카메라마다 다섯 가지 포즈가 포함됩니다. 그리드의 모서리나 측면이 민감 영역 위에 놓인 후, 프로세스에서 필요한 다음 포즈가 자동으로 표시됩니다. 왼쪽 카메라에 대한 프로세스가 완료되면 오른쪽 카메라에 대해서도 동일한 절차가 반복됩니다.
Calculate#
Calculate 버튼을 클릭하면 프로세스가 완료되고 최종 결과가 표시됩니다. 표시된 결과는 모든 캘리브레이션 포인트의 평균 재투영 오차입니다. 픽셀 단위로 제공되며 대개 0.2 미만의 값입니다.

Save#
지금 Save를 클릭하여 캘리브레이션을 적용하고 Stereo ace 장치에 저장하세요.