기타

이 장에서는 VisualApplets 를 사용하는 데 도움이 되는 유용한 정보들을 모아두었습니다.

명령줄 옵션

VisualApplets VisualApplets 를, 예를 들어 배치 스크립트에서 사용하거나, 프로그램을 시스템 환경에 통합하기 위해 사용할 수 있도록 몇 가지 명령줄 인수를 제공합니다.

구문은 다음의 구조를 따릅니다:

<VISUALAPPLETSINSTALLDIR>\VisualApplets <-COMMAND> <ARGUMENTS>

명령어와 해당 명령어에 필요한 인수는 다음 표에 정리되어 있습니다:

명령줄 논증과 의미

-파일

지정된 Tcl 스크립트에 저장된 명령을 실행합니다.

인수:

  • Tcl 스크립트 파일 이름 (*.tcl)

-컴파일

지정된 파일을 불러와 애플릿을 생성합니다. 디자인은 디자인 규칙에 따라 검토됩니다.

인수:

  • VisualApplets 디자인 파일(*.va)의 파일 이름

  • 생성된 애플릿 파일의 파일명 (*.hap)

-병합

microEnable IV 애플릿 파일과 PixelPlant 애플릿 파일을 병합합니다. 두 소스 애플릿 파일의 호환성 여부에 대한 검사가 수행됩니다.

인수:

  • 마더보드 애플릿의 파일 이름 (*.hap)

  • PixelPlant 애플릿의 파일 이름 (*.hap)

  • 생성된 애플릿 파일의 파일 이름

-sdk

Framegrabber SDK 와 함께 애플릿을 사용하기 위한 SDK 예제(C 소스 코드)를 생성합니다. 설계는 설계 규칙에 따라 검토됩니다.

인수:

  • VisualApplets 디자인 파일(*.va)의 파일 이름

  • PixelPlant 애플릿 파일의 파일 이름 (*.hap)

-KeepSyntheseTraceFiles

하드웨어 애플릿 생성 시의 추가 옵션. 빌드 완료 후 추적 목적으로 (빌드 과정에서 생성된) 중간 파일을 보존합니다.

<VAFilename>

지정된 VisualApplets 설계 파일을 불러옵니다.

예를 들어, 탐색기 내에서 *.va 파일을 더블 클릭하여 열도록 지정할 때 사용됩니다.

인수:

  • VisualApplets 디자인 파일(*.va)의 파일 이름

표 14. 명령줄 옵션 및 해당 인수


키보드 단축키

아래에는 ‘ VisualApplets ’에서 사용할 수 있는 모든 단축키 목록이 나와 있습니다.

Main Program Window

바로가기 메뉴 항목
Ctrl+N 파일 → 새 프로젝트
Ctrl+O 파일 → 프로젝트 열기
Ctrl+S 파일 → 프로젝트 저장
Ctrl+P 파일 → 표시된 다이어그램 인쇄
Ctrl+Q 파일 → 응용 프로그램 종료
Ctrl+Z 편집 → 실행 취소
Ctrl+Shift+Z 편집 → 다시 실행
Ctrl+Z 편집 → 실행 취소
Ctrl+X 편집 → 잘라내기
Ctrl+C 편집 → 복사
Ctrl+V 편집 → 붙여넣기
Del 편집 → 삭제
F2 편집 → 모듈 이름 변경
Ctrl+I 디자인 → 연산자 추가
마우스 3+ 디자인 → 연산자 추가
Ctrl+F 디자인 → 검색 모듈
F9 분석 → 시뮬레이션 시작
Ctrl+F7 분석 → 설계 규칙 검사 레벨 1
Ctrl+F8 분석 → 설계 규칙 검사 레벨 2
F7 만들기 → 빌드
F5 빌드 → microDisplay 시작
F11 보기 → 전체 화면
Ctrl++ 보기 → 도면 확대
Ctrl+- 보기 → 도면 축소
Ctrl+마우스 휠 위로 돌리기 보기 → 도면 확대
Ctrl+마우스 휠 아래로 돌리기 보기 → 도면 축소
Ctrl+Return 보기 → 확대/축소 초기화
Backspace 보기 → 창 위로
Ctrl+Space 보기 → 손/선택 도구 전환
Ctrl+오른쪽 화살표 창 → 다음 다이어그램
Ctrl+왼쪽 화살표 창 → 이전 다이어그램
드래그 앤드롭 프로젝트 파일을 메인 창에 드래그 앤 드롭할 수 있습니다.

표 15. 메인 프로그램 창의 단축키 목록


Simulation Viewer

바로가기 메뉴 항목
Ctrl+Q 파일 → 시뮬레이션 뷰어 종료
Ctrl+C 편집 → 이미지를 클립보드에 복사
Del 편집 → 선택한 이미지 삭제
Ctrl+Del 편집 → 모든 이미지 제거
왼쪽 화살표 탐색 → 이전 이미지
오른쪽 화살표 탐색 → 다음 이미지
Ctrl++ 보기 → 확대
Ctrl+마우스 휠 위로 돌리기 보기 → 확대
Ctrl+- 보기 → 축소
Ctrl+마우스 휠 아래로 돌리기 보기 → 축소
Ctrl+마우스 3 보기 → 일반 크기 1:1
F11 보기 → 전체 화면
Ctrl+F 보기 → 창 크기에 맞추기
Ctrl+T 보기 → 매핑된 썸네일
Ctrl+R 보기 → 매개변수 초기화
드래그 앤드롭 이미지는 시뮬레이션 뷰어(소스)나 시뮬레이션 소스 모듈에 직접 드래그 앤 드롭할 수 있습니다.

표 16. 시뮬레이션 뷰어 단축키 목록


오류 보고

아무리 완벽하게 개발되고 테스트를 거친 소프트웨어라도 때때로 오류가 발생할 수 있습니다. Basler가 VisualApplets 을 개선하는 데 도움을 주시고 싶으시다면, 오작동 사항이 있을 경우 당사 지원팀에 신고해 주시고 해당 상황을 자세히 설명해 주시기 바랍니다.

VisualApplets 설계 파일(*.va)과 같은 추가 데이터나, 운영 체제 및 PC 하드웨어와 같은 시스템 환경 설명, 또는 귀하의 특정 VisualApplets 시스템 설정 정보는 오류로 인한 이상 현상을 수정하는 데 큰 도움이 됩니다.

In case of system crashes, a trace file will be generated. This file allows us at Basler to restore the exact situation that led to the crash. This trace file is stored inside a zip-archive which you will find in the installation directory of VisualApplets: <INSTDIR>\bin\bugs\bug*.zip. Please decide if you want to send this supplementary information to Basler or not. Please note that the trace file contains only information that has been entered into VisualApplets. It does not contain any information regarding the computer system VisualApplets was running on.