사용자 라이브러리(user libraries)에서는 둘 이상 필요로 하는 모듈 조합을 캡슐화하여 나중에 재사용할 수 있도록 저장할 수 있습니다.
사용자 라이브러리는 원하는 만큼 정의할 수 있습니다. 각 사용자 라이브러리에는 원하는 만큼의 사용자 라이브러리 요소를 포함할 수 있습니다.
사용자 라이브러리 요소(user library element)에는 모듈과 링크의 특정 조합이 포함됩니다. 생성된 라이브러리 요소는 라이브러리 패널(User Library 탭)에서 사용할 수 있으며 연산자처럼 사용할 수 있습니다.
사용자 라이브러리 요소는 계층형 박스(hierarchical box)와 거의 동일합니다('Hierarchical Boxes' 참조). 차이점은 사용자 라이브러리 요소가 (사용자 정의) 사용자 라이브러리에 저장되며, 연산자 라이브러리의 연산자처럼 서로 다른 디자인과 프로젝트에 삽입할 수 있다는 점입니다.
사용자 라이브러리 요소의 인스턴스들은 서로 독립적입니다. 즉, 인스턴스 중 하나를 변경해도 동일한 사용자 라이브러리의 다른 인스턴스에는 영향을 미치지 않습니다.
사용자 라이브러리는 다음 형식으로 저장됩니다: *.val 또는 *.vl
파일. 이 파일들은 특정 프로젝트에 속하지 않으므로 다른 프로젝트에서도 사용할 수 있습니다.
다음 파라미터 블록에서 시스템 설정 VisualApplets에서 파일이 저장될 위치를 지정할 수 있습니다( *.val 또는 *.vl 시스템의 파일 저장 위치 참조(참조: 'System Settings').
디자인에 사용자 라이브러리 요소의 인스턴스를 삽입한 후에는 프로젝트 로드나 *.val 또는 *.vl 앱릿 빌드(*.hap 파일)를 위해 파일이 필요하지 않습니다.
새 사용자 라이브러리를 만들려면 다음과 같이 진행하십시오:
-
라이브러리 패널에서 User Library 탭을 클릭합니다.
-
사용자 라이브러리 창을 마우스 우클릭합니다.
-
컨텍스트 메뉴에서 를 선택합니다.
(또는 메인 메뉴 → 를 사용할 수도 있습니다.)
-
대화 상자가 열립니다:

-
새 사용자 라이브러리의 이름을 지정합니다.
-
기본적으로 새 사용자 라이브러리는 다음 형식으로 저장됩니다.
*.val파일 형식. 이 라이브러리를 VisualApplets 버전 3.3.2 이하에서 열려면 다음을 선택하십시오. . 이전 버전의 사용자 라이브러리인 경우 참고하세요.*.vl파일 형식에 보호된 사용자 라이브러리 요소가 포함되어 있는 경우, 이 요소는 저장되지 않으며 이전 버전의 파일 형식으로 열 수 없습니다. -
클릭
이제 (컨테이너 역할을 하는) 빈 사용자 라이브러리가 생성되었으며, 이제 사용자 라이브러리 요소로 채울 수 있습니다.
사용자 라이브러리 이름 위에 마우스를 올리면 라이브러리가 저장된 위치를 보여주는 툴팁이 표시됩니다. *.vl 구형 파일 형식:

새로운 사용자 라이브러리 요소를 만드는 방법에는 두 가지가 있습니다. 다음 중 하나를 선택할 수 있습니다.
-
계층형 박스를 사용자 라이브러리 요소로 저장하거나(계층형 박스에 대한 일반적인 정보는 'Hierarchical Boxes' 참조),
-
처음부터 사용자 라이브러리 요소를 생성합니다('Creating a New User Library Element from Scratch' 참조).
-
계층형 박스를 마우스 우클릭하여 모듈의 컨텍스트 메뉴를 엽니다.
-
를 선택합니다.
Save 대화상자가 나타납니다.
-
새 요소를 저장할 사용자 라이브러리를 선택합니다(또는 New User Library를 클릭하여 새 라이브러리를 정의할 수도 있습니다).
-
새 사용자 라이브러리 요소의 이름을 (Element Type 아래에) 입력합니다.
-
선택 사항: 요소에 대한 정보(버전 번호, 간략한 설명, 개별 GUI 아이콘, HTML 도움말 파일 형태의 문서)를 추가하려면:
-
를 클릭합니다. 새 대화상자가 열립니다.
-
원하는 경우 라이브러리 요소의 버전 번호를 입력합니다.
-
원하는 경우 라이브러리 요소의 간략한 설명을 입력합니다.
-
VisualApplets GUI에서 라이브러리 요소와 함께 표시될 특정 아이콘을 지정하려면, 필드에 PNG 파일의 경로를 지정하거나 필드 오른쪽에 있는 탐색 버튼을 사용합니다.
-
사용자 라이브러리 요소를 설명하는 문서를 추가하려면 아래의 더보기 버튼을 클릭하고 문서 텍스트가 포함된 HTML 파일로 이동합니다.
여러 개의 HTML 및 이미지 파일을 지정할 수 있습니다. 여러 개의 HTML 파일을 추가하는 경우 목록의 첫 번째 HTML 파일이 문서의 시작 페이지가 됩니다. 시작 페이지는 사용자 라이브러리 요소의 문서로 표시됩니다(정보 패널의 Help 탭). 추가 파일에는 시작 페이지에서 링크된 이미지나 추가 HTML 파일이 포함될 수 있습니다.
![[참고]](../common/images/admon/note.png)
도움말 파일의 명명 및 저장 When you save your user library element later on, all the files you specify here will be copied to the VisualApplets installation directory, sub-directory . The starting page of your documentation (first HTML file in the list) will be renamed and will have the name of the user library element:<elementname>.html
라이브러리 요소에서 HTML 파일의 연결을 해제하려면 해당 파일을 선택하고 삭제 버튼을 클릭합니다. HTML 파일의 연결은 해제되지만 파일 시스템에는 유지됩니다.
-
를 눌러 새 사용자 라이브러리 요소의 세부 정보 사양을 확인합니다.
-
-
사용자 라이브러리 요소를 보호하려면 Protection 옵션을 선택합니다. 이렇게 하면 사용자 라이브러리 요소가 “블랙박스”로 변환됩니다. (요소 보호에 대한 자세한 내용은 'Protecting User Library Elements'를 참조하십시오.)
-
클릭 를 클릭하세요.
선택 사항인 PNG 및 HTML 파일은 VisualApplets 설치 디렉토리의 하위 디렉토리에 복사됩니다.
Protection 옵션을 활성화한 경우, Protect User Library Element 대화상자가 추가로 나타납니다.
모든 User 라이브러리와 해당 콘텐츠는 라이브러리 패널에서 사용할 수 있습니다(The User Interface of VisualApplets 참조). User Library 탭을 클릭하여 User Library 창을 표시합니다.
선택한 아이콘이 라이브러리 요소와 함께 표시됩니다.
개별 요소에 대한 상세 정보는 툴팁에 표시됩니다.
새 User Library 요소를 선택하면 해당 도움말 정보가 Help 탭 아래의 정보 패널에 표시됩니다.
디자인 창의 표기가 변경됩니다. "HierarchicalBox" 대신 User Library 요소의 이름이 표시됩니다. 계층형 상자(Hierarchical Box) 아이콘이 라이브러리 요소에 대해 선택한 아이콘으로 대체됩니다. 디자인 내 인스턴스의 이름(아이콘 아래)은 동일하게 유지됩니다.
나중에 언제든지 User Library 요소를 변경할 수 있습니다('User Library 요소 편집' 섹션 'Editing User Library Elements' 참조). 그러나 이러한 변경 사항은 요소의 인스턴스에 반영되지 않습니다. 필요한 경우 User Library 요소의 인스턴스를 업데이트하기 위한 다양한 옵션을 사용할 수 있습니다('업데이트된 User Library 요소 업데이트' 섹션 'Updating Instantiated User Library Elements' 참조).
![]() |
User Library 요소 분석 |
|---|---|
|
Design Rules Check Level 1을 수행할 수 있습니다. 리소스 분석, 빌드 및 시뮬레이션은 수행할 수 없습니다. |
또는 처음부터 새로운 User Library 요소를 생성할 수도 있습니다. User Library 요소를 정의 및/또는 변경하려면 User Library Editor를 사용합니다.
처음부터 새로운 User Library 요소를 정의하려면:
-
기본 메뉴에서 → → 를 선택합니다.
이제 디자인 편집기가 닫힙니다. 디자인 편집기와 함께 작업 중이던 디자인도 닫힙니다.
User Library 편집기가 열립니다. User Library 편집기는 일반 디자인 편집기와 동일하게 작동합니다.
-
새 User Library 요소의 이름을 정의합니다.
-
대상 하드웨어 플랫폼을 선택합니다.
(단, 해당 플랫폼은 카메라 오퍼레이터와 같이 하드웨어 문제에 종속된 오퍼레이터를 요소에 포함하는 경우에만 유효합니다.)
-
를 클릭합니다.
-
를 클릭하면 요소의 입력 및 출력 포트 개수를 지정해야 하는 대화 상자가 열립니다. 이 개수는 나중에 변경할 수 없으므로 올바른 수의 입력 및 출력 링크를 지정했는지 확인하십시오.
-
필요한 입력 포트 개수를 지정합니다.
-
필요한 출력 포트 개수를 지정합니다.
![[주의]](../common/images/admon/caution.png)
필요한 링크 개수 정의 나중에 이 개수를 변경할 수 없으므로 올바른 수의 입력 및 출력 링크를 지정했는지 확인하십시오.
-
-
OK를 눌러 포트 정의를 확인합니다.
방금 지정한 입력 및 출력 포트만 포함된 빈 요소 디자인으로 사용자 라이브러리 편집기가 열립니다.
-
원하는 대로 사용자 라이브러리 요소의 디자인을 편집합니다.
-
작업이 완료되면 주 메뉴에서 → 를 선택하여 요소를 저장합니다.
-
새 요소를 저장할 사용자 라이브러리를 선택합니다(또는 New User Library를 클릭하여 새 라이브러리를 정의할 수도 있습니다).
-
선택 사항: 요소에 대한 정보(버전 번호, 간단한 설명, 개별 GUI 아이콘, HTML 도움말 파일 형태의 문서)를 추가하려면:
-
를 클릭합니다. 새 대화 상자가 열립니다.
-
필요한 경우 라이브러리 요소의 버전 번호를 입력합니다.
-
필요한 경우 라이브러리 요소의 간단한 설명을 입력합니다.
-
VisualApplets GUI에서 라이브러리 요소와 함께 표시될 특정 아이콘을 지정하려면 필드에 PNG 파일의 경로를 입력하거나 필드 오른쪽에 있는 탐색 버튼을 사용합니다.
-
사용자 라이브러리 요소를 설명하는 문서를 추가하려면 아래의 더보기 버튼을 클릭하고 문서 텍스트가 포함된 HTML 파일로 이동합니다.
여러 개의 HTML 및 이미지 파일을 지정할 수 있습니다. 여러 개의 HTML 파일을 추가하는 경우 목록의 첫 번째 HTML 파일이 문서의 시작 페이지가 됩니다. 시작 페이지는 사용자 라이브러리 요소의 문서로 표시됩니다(정보 패널의 Help 탭). 추가 파일에는 시작 페이지에서 링크하는 이미지나 추가 HTML 파일이 포함될 수 있습니다.
![[참고]](../common/images/admon/note.png)
도움말 파일의 명명 및 저장 When you save your user library element later on, all the files you specify here will be copied to the VisualApplets installation directory, sub-directory . The starting page of your documentation (first HTML file in the list) will be renamed and will have the name of the user library element:<elementname>.html
라이브러리 요소에서 HTML 파일의 연결을 해제하려면 해당 요소를 선택하고 삭제 버튼을 클릭합니다. HTML 파일의 연결이 해제되지만 파일 시스템에는 유지됩니다.
-
를 사용하여 새 사용자 라이브러리 요소의 세부 정보 지정을 확인합니다.
-
-
사용자 라이브러리 요소를 보호하려면 Protection 옵션을 선택하십시오. 이렇게 하면 사용자 라이브러리 요소가 "블랙박스"가 됩니다. (요소 보호에 대한 자세한 내용은 'Protecting User Library Elements'를 참조하십시오.)
![[참고]](../common/images/admon/note.png)
보호된 요소는 레거시 파일 형식으로 저장할 수 없습니다. 사용자 라이브러리를 다음 형식으로 저장하는 경우,
*.vl레거시 파일 형식에서는 보호된 요소를 저장할 수 없습니다. 이 경우 보호 기능을 해제하거나 보다 최신의 권장되는*.val파일 형식으로 저장하십시오.레거시 파일 형식을 사용하면 VisualApplets 버전 3.3.2 이하에서 사용자 라이브러리를 열 수 있습니다.
-
클릭 를 클릭하세요.
선택 사항인 PNG 및 HTML 파일은 VisualApplets 설치 디렉토리의 하위 디렉토리인 에 복사됩니다.
Protection 옵션을 활성화한 경우 Protect User Library Element 대화 상자가 추가로 나타납니다.
모든 사용자 라이브러리 및 해당 콘텐츠는 라이브러리 패널에서 사용할 수 있습니다(The User Interface of VisualApplets 참조). User Library 탭을 클릭하여 사용자 라이브러리 창을 표시합니다.
선택한 아이콘이 라이브러리 요소와 함께 표시됩니다.
개별 요소에 대한 자세한 정보는 툴팁에 표시됩니다.
새 사용자 라이브러리 요소를 선택하면 해당 도움말 정보가 Help 탭 아래의 정보 패널에 표시됩니다.
-
디자인 작업을 계속 진행하려면 사용자 라이브러리 요소 디자인 및 사용자 라이브러리 편집기를 닫습니다. 메인 메뉴에서 → 를 선택합니다.
![[주의]](../common/images/admon/caution.png)
File->Close를 통해 요소 디자인 닫기 디자인 탭을 닫는 것만으로는 요소 디자인을 닫기에 충분하지 않습니다. 사용자 라이브러리 편집기도 닫아야 합니다.
둘 다 닫으려면 → 를 클릭합니다. 이러한 방식으로 사용자 라이브러리 요소 디자인(및 결과적으로 라이브러리 편집기)을 닫은 후에야 일반 디자인 편집기를 다시 열어 전체 앱릿 디자인을 계속할 수 있습니다.
-
디자인 작업을 계속하려면 디자인을 엽니다.
나중에 언제든지 User Library 요소를 변경할 수 있습니다('User Library 요소 편집' 섹션 'Editing User Library Elements' 참조). 그러나 이러한 변경 사항은 요소의 인스턴스에 반영되지 않습니다. 필요한 경우 User Library 요소의 인스턴스를 업데이트하기 위한 다양한 옵션을 사용할 수 있습니다('업데이트된 User Library 요소 업데이트' 섹션 'Updating Instantiated User Library Elements' 참조).
![]() |
User Library 요소 분석 |
|---|---|
|
Design Rules Check Level 1을 수행할 수 있습니다. 리소스 분석, 빌드 및 시뮬레이션은 수행할 수 없습니다. |
(연산자와 마찬가지로) 디자인에 간단히 끌어서 놓는 방식으로 요소의 인스턴스를 생성할 수 있습니다.
인스턴스화된 모듈은 계층적 상자처럼 작동하지만 사용자 라이브러리에서 파생되었음을 인식합니다.
전체 디자인에 맞게 사용자 라이브러리 요소의 인스턴스를 조정할 수 있습니다. 다음 작업을 수행해야 할 수 있습니다.
-
개별 연산자 파라미터 수정
-
레이아웃 수정(연산자 및 링크 추가 및 삭제)
![]() |
링크 속성 변경 |
|---|---|
|
변경된 링크 속성은 라이브러리 요소 인스턴스의 구현을 변경하지 않습니다. 예: 라이브러리 요소가 4의 Parallelism으로 저장되었지만 해당 인스턴스가 8의 Parallelism에 연결된 경우, 이는 당연히 인스턴스 내부의 링크에 영향을 미칩니다. 그러나 링크 속성 변경으로 인해 연산자 파라미터가 영향을 받지 않으므로 이는 인스턴스의 구현 변경이 아닙니다. |
개별 연산자 파라미터를 수정하거나 레이아웃(연산자 및 링크 추가 및 삭제)을 수정하여 사용자 라이브러리 요소의 인스턴스를 변경한 후에는 해당 인스턴스가 더 이상 단순한 사용자 라이브러리 요소의 복사본이 아닙니다.
어떤 인스턴스에 변경 사항이 포함되어 있는지 쉽게 확인할 수 있도록, 수정된 사용자 라이브러리 엘리먼트 인스턴스에는 다음과 같이 표시가 지정됩니다.
사용자 라이브러리 엘리먼트의 인스턴스를 업데이트하면('인스턴스화된 사용자 라이브러리 엘리먼트 업데이트' 섹션 참조) 인스턴스에 적용했던 변경 사항이 덮어쓰여지므로 이 점을 숙지하는 것이 매우 중요합니다. 변경 사항이 포함된 인스턴스에 대해 자동 업데이트를 선택하기 전에 항상 장단점을 신중하게 고려해야 합니다.
사용자 라이브러리 엘리먼트는 보호할 수 있습니다. 보호 기능이 활성화되면 사용자 라이브러리 엘리먼트는 "블랙박스"가 됩니다. 그러나 동적 파라미터가 포함되어 있거나 Parameters 라이브러리의 오퍼레이터에서 참조되는 파라미터가 포함된 보호된 엘리먼트는 런타임에서도 계속 표시됩니다.
![]() |
보호된 요소는 레거시 파일 형식으로 저장할 수 없습니다. |
|---|---|
|
사용자 라이브러리를 다음 형식으로 저장하는 경우, 레거시 파일 형식을 사용하면 VisualApplets 버전 3.3.2 이하에서 사용자 라이브러리를 열 수 있습니다. |
사용자 라이브러리 엘리먼트를 보호하는 방법에는 두 가지가 있습니다.
-
비밀번호를 통한 보호: 이후 비밀번호를 사용하여 사용자 라이브러리 엘리먼트를 열고 편집할 수 있습니다. 비밀번호가 없는 사용자는 사용자 라이브러리 엘리먼트에 어떤 오퍼레이터가 사용되었는지조차 확인할 수 없습니다(블랙박스).
-
복구 불가능한 보호: 사용자 라이브러리 엘리먼트가 영구적으로 블랙박스가 되며 본인을 포함하여 다시 열 수 없습니다.
비밀번호로 사용자 라이브러리 엘리먼트를 보호하려면 다음과 같이 하십시오.
-
해당 엘리먼트를 마우스 우클릭합니다.
-
상단 메뉴에서 를 선택합니다.
-
보호 모드 가 활성화되어 있는지 확인합니다.
-
비밀번호를 입력합니다.
-
를 클릭합니다.
![]() |
"일방향(One-Way)" 보호(복구 불가능) |
|---|---|
|
보호 모드로 Password 대신 One Way를 선택하면 사용자 라이브러리 엘리먼트를 본인을 포함하여 다시 열 수 없습니다. 나중에 엘리먼트를 개선할 계획이라면 반드시 보호 모드를 선택하십시오. 또는 이 보호 모드를 활성화하기 전에 엘리먼트의 복사본을(계층형 박스 또는 보호되지 않은 오퍼레이터로) 저장해 둘 수 있습니다. |
사용자 라이브러리 엘리먼트는 다음과 같은 방법으로 변경할 수 있습니다.
-
라이브러리 편집기에서 라이브러리 엘리먼트 자체를 편집하거나,
-
변경되거나 인스턴스화된 엘리먼트 또는 계층형 박스로 덮어씁니다.
그러나 이러한 변경 사항은 자동으로 반영되지 않습니다. 라이브러리 엘리먼트의 변경 사항을 인스턴스에 반영하려면 인스턴스를 업데이트해야 합니다(섹션 '인스턴스화된 사용자 라이브러리 엘리먼트 업데이트' 참조).
사용자 라이브러리 편집기에서 사용자 라이브러리 엘리먼트를 편집할 수 있습니다. 사용자 라이브러리 편집기를 열려면 다음과 같이 하십시오.
-
현재 작업 중인 디자인을 저장합니다.
-
라이브러리 창에서 User Library 탭으로 이동합니다.
-
편집하려는 요소를 마우스 우클릭합니다.
-
요소의 컨텍스트 메뉴에서 을 선택합니다.
이제 디자인 편집기가 닫힙니다. 디자인 편집기가 닫힘과 동시에 작업 중이던 디자인도 함께 닫힙니다.
User Library Editor가 열립니다. User Library Editor는 일반 디자인 편집기와 동일하게 작동합니다.
-
변경 사항을 적용합니다.
-
변경 사항을 저장합니다.
요소 설명과 버전 번호를 편집하려면:
-
메인 메뉴에서 → 를 선택합니다.
-
편집된 요소를 저장합니다.
User Library 요소 분석: Design Rules Check Level 1을 수행할 수 있습니다. 그러나 대역폭 분석, 리소스 분석, 빌드 및 시뮬레이션은 수행할 수 없습니다.
![]() |
인스턴스 업데이트 |
|---|---|
|
User Library 요소를 변경하더라도 디자인에 인스턴스화된 요소에는 이러한 변경 사항이 반영되지 않습니다. 라이브러리 요소에 대한 변경 사항을 라이브러리 요소의 인스턴스에 반영하려면 인스턴스를 업데이트해야 합니다('Updating Instantiated User Library Elements' 섹션 참조). |
또는 User Library 요소를 덮어쓰는 방식으로 간단히 편집할 수도 있습니다. 방법은 다음과 같습니다.
-
계층 구조 박스 또는 인스턴스화된 User Library 요소를 이미 존재하는 User Library 요소의 이름으로 저장합니다('Saving a Hierarchical Box as a User Library Element'에 설명된 대로).
![]() |
인스턴스 업데이트 |
|---|---|
|
User Library 요소를 변경하더라도 디자인에 인스턴스화된 요소에는 이러한 변경 사항이 반영되지 않습니다. 라이브러리 요소에 대한 변경 사항을 라이브러리 요소의 인스턴스에 반영하려면 인스턴스를 업데이트해야 합니다('Updating Instantiated User Library Elements' 섹션 참조). |
다음 섹션에서는 인스턴스화된 User Library 요소를 업데이트하는 방법에 대한 정보를 제공합니다.
일반적인 작업 흐름에서는 User Library 요소를 업데이트해야 하는 상황이 발생합니다. 그러나 요소에 적용한 변경 사항은 해당 요소의 인스턴스에 영향을 주지 않습니다. 디자인 내 요소의 인스턴스를 업데이트하려면 변경 사항을 수동으로 추가하거나 VisualApplets에서 제공하는 두 가지 업데이트 메커니즘 중 하나를 사용할 수 있습니다(아래 참조).
변경된 요소의 인스턴스를 수동으로 업데이트하기로 결정한 경우, 디자인에서 요소의 여러 인스턴스를 선택하고 한 번에 동시에 변경할 수 있습니다.
![]() |
계층 구조 업데이트 없음 |
|---|---|
|
User Library 요소의 계층 구조 업데이트는 지원되지 않습니다. 업데이트할 계층 구조의 모듈을 둘 이상 선택한 경우, 계층 구조의 가장 상위 모듈만 업데이트됩니다. |
Quick Update 기능을 통해 디자인 내 User Library 요소의 인스턴스를 업데이트할 수 있습니다.
![]() |
업데이트 시 인스턴스 내 변경 사항 덮어쓰기 |
|---|---|
|
User Library 요소의 인스턴스를 업데이트하면 인스턴스에 적용했던 모든 변경 사항(매개변수 설정 또는 연산자 추가/삭제)이 덮어씌워집니다. 변경 사항이 포함된 인스턴스에 대해 자동 업데이트를 선택하기 전에 장단점을 신중하게 고려해야 합니다. To keep you informed which instance contains changes, modified instances of a library element are marked: ![]()
|
Quick Update를 통해 라이브러리 요소의 인스턴스를 업데이트하려면:
-
업데이트할 인스턴스를 선택합니다.
-
메인 메뉴에서 → 를 선택합니다.
선택한 요소의 인스턴스가 라이브러리에서 수정한 내용이 반영된 새로운 인스턴스로 교체됩니다.
Quick Update는 업데이트하려는 인스턴스가 편집된 사용자 라이브러리 요소와 동일한 수의 입력 및 출력 포트를 가지고 있는 경우에만 가능합니다. A 유형의 사용자 라이브러리 요소 인스턴스를 B 유형의 사용자 라이브러리 요소 인스턴스로 교체하는 데 Quick Update를 사용할 수는 없습니다.
Quick Update를 사용하면 여러 요소 인스턴스를 한 번에 업데이트할 수 있습니다.
-
Ctrl 키를 누른 상태에서 업데이트할 모든 인스턴스를 선택합니다.
-
메인 메뉴에서 → 를 선택합니다.
선택한 요소의 모든 인스턴스가 새로운 인스턴스로 교체됩니다.
이 옵션을 선택하면 교체하려는 인스턴스가 업데이트할 라이브러리 요소와 반드시 같은 유형일 필요는 없습니다. 따라서 이 옵션을 사용하여 사용자 라이브러리 요소 또는 계층형 상자의 인스턴스를 다른 사용자 라이브러리 요소의 인스턴스로 교체할 수 있습니다. 예를 들어 ("Quick Update" 옵션과 달리) A 유형의 사용자 라이브러리 요소 인스턴스를 B 유형의 사용자 라이브러리 요소 인스턴스로 교체할 수 있습니다. 그럼에도 불구하고 역시 교체하려는 인스턴스가 교체 대상인 사용자 라이브러리 요소와 동일한 수의 입력 및 출력 포트를 가지고 있는 경우에만 가능합니다.
요소의 하나 이상의 인스턴스를 다른 사용자 라이브러리 요소의 인스턴스로 교체하려면:
-
(Ctrl 키를 누른 상태에서) 교체할 모듈을 선택합니다.
-
메인 메뉴에서 → 를 선택합니다.
Update User Library Elements 대화 상자가 열립니다. 왼쪽 패널에는 업데이트하기 위해 선택한 모듈이 표시되고, 오른쪽 패널에는 사용자 라이브러리가 표시됩니다.
-
오른쪽 패널에서 필요한 사용자 라이브러리 요소를 선택합니다. 왼쪽 패널에서는 원하는 대로 교체할 수 있는 모든 모듈이 녹색으로 강조 표시됩니다(그렇지 않은 경우 입력 및 출력 개수가 일치하는지 확인하세요).
-
를 클릭합니다.
노드 수가 일치하는 나열된 모든 모듈이 새로운 사용자 라이브러리 요소의 인스턴스로 즉시 교체됩니다.
위의 예시: 두 가지 경우에서 입력 및 출력 개수가 일치하지 않습니다. Module 28에는 1개의 입력 및 1개의 출력 포트만 있는 반면, USRLibraryELement5에는 3개의 입력과 3개의 출력이 있습니다. Module 32, 31, 33은 USRLibraryELement5와 정확히 동일한 수의 입력 및 출력 포트를 가지고 있으므로 USRLibraryELement5로 교체할 수 있습니다.
상황에 따라 요소 인스턴스를 사용자 라이브러리에서 연결 해제하는 것이 유용할 수 있습니다. 이를 위해 사용자 라이브러리 요소의 인스턴스를 계층형 상자로 변환할 수 있습니다.
-
디자인에서 변환할 모듈을 선택합니다. (둘 이상의 모듈을 변환하려면 Ctrl 키를 누른 상태에서 변환할 모든 모듈을 선택합니다.)
-
메인 메뉴에서 → 를 선택합니다.
선택한 모든 모듈이 완전히 독립된 계층형 상자로 즉시 변환됩니다.
VisualApplets는 다음과 같은 두 개의 사용자 라이브러리를 제공합니다.

제공된 사용자 라이브러리가 표시되지 않으면 User Library 패널을 마우스 우클릭하고 열리는 컨텍스트 메뉴에서 를 선택하세요.

그러면 VisualApplets에서 → → 에 지정된 디렉터리에 있는 라이브러리를 엽니다.
JPEG_Color 사용자 라이브러리에는 다음 요소가 포함되어 있습니다.

-
JPEGEncoder_Color_800MPs_VCX: 이 사용자 라이브러리 요소를 사용하여 8비트 컬러 이미지를 JPEG 이미지로 변환할 수 있습니다. JPEG_Encoder_Color_800MPs_VCX는 CXPx2 프레임 보드용이며 160 MHz의 클록 레이트에서 800 MP/s의 대역폭을 제공합니다. 입력 Parallelism은 8입니다.
-
JPEGEncoder_Color_1500MPs_VCX: 이 사용자 라이브러리 요소를 사용하여 8비트 컬러 이미지를 JPEG 이미지로 변환할 수 있습니다. JPEG_Encoder_Color_1500MPs_VCX는 CXPx2 프레임 보드용이며 160 MHz의 클록 레이트에서 1200 MP/s의 대역폭을 제공합니다. 입력 Parallelism은 8입니다.
-
JPEGEncoder_Color_2500MPs_VCX: 이 사용자 라이브러리 요소를 사용하여 8비트 컬러 이미지를 JPEG 이미지로 변환할 수 있습니다. JPEG_Encoder_Color_2500MPs_VCX는 CXPx4 프레임 보드용이며 160 MHz의 클록 레이트에서 2400 MP/s의 대역폭을 제공합니다. 입력 Parallelism은 16입니다.
-
JPEGEncoder_Color_300MPs_VCL: 이 사용자 라이브러리 요소를 사용하여 8비트 컬러 이미지를 JPEG 이미지로 변환할 수 있습니다. JPEG_Encoder_Color_300MPs_VCL은 Camera Link (CL) 프레임 보드용이며 300 MP/s의 대역폭을 제공합니다. 입력 Parallelism은 4입니다.
-
JPEGEncoder_Color_600MPs_VCL: 이 사용자 라이브러리 요소를 사용하여 8비트 컬러 이미지를 JPEG 이미지로 변환할 수 있습니다. JPEG_Encoder_Color_600MPs_VCL은 Camera Link (CL) 프레임 보드용이며 155 MHz의 클록 레이트에서 600 MP/s의 대역폭을 제공합니다. 입력 Parallelism은 4입니다.
-
JPEGEncoder_Color_850MPs_VCL: 이 사용자 라이브러리 요소를 사용하여 8비트 컬러 이미지를 JPEG 이미지로 변환할 수 있습니다. JPEG_Encoder_Color_850MPs_VCL은 Camera Link (CL) 프레임 보드용이며 170 MHz의 클록 레이트에서 850 MP/s의 대역폭을 제공합니다. 입력 Parallelism은 8입니다.
사용자 라이브러리 요소에 대한 자세한 문서는 VisualApplets 설치 경로의 Help 패널에서 확인할 수 있습니다.
![]() |
imaFlex_CXP12_Tools_Advanced User Library 사용 권장 |
|---|---|
|
imaFlex_CXP12_Tools 사용자 라이브러리는 하위 호환성을 위해서만 제공됩니다. 가능하면 대신 imaFlex_CXP12_Tools_Advanced 사용자 라이브러리를 사용하십시오. |
imaFlex_CXP12_Tools 사용자 라이브러리에는 다음 요소가 포함되어 있습니다.

-
ImageBufferMultiRoI: 이 연산자는 각 버퍼링된 이미지에 대해 여러 관심 영역(ROI)을 지원합니다. imaFlex 플랫폼의 툴 요소인 사용자 라이브러리 요소 ImageBufferMultiRoI는 imaFlex 플랫폼에서 지원되지 않는 VisualApplets 표준 연산자 ImageBufferMultiRoI와 동일한 기능을 제공합니다.
-
ImageBufferMultiRoIDyn: 이 연산자는 각 버퍼링된 이미지에 대해 여러 동적 관심 영역(ROI)을 지원합니다. imaFlex 플랫폼의 툴 요소인 사용자 라이브러리 요소 ImageBufferMultiRoIDyn은 imaFlex 플랫폼에서 지원되지 않는 VisualApplets 표준 연산자 ImageBufferMultiRoIDyn과 동일한 기능을 제공합니다.
imaFlex_CXP12_Tools_Advanced 사용자 라이브러리에는 다음 요소가 포함되어 있습니다.
-
FrameBufferMultiRoi: 이 연산자는 각 버퍼링된 이미지에 대해 여러 관심 영역(ROI)을 지원합니다. imaFlex 플랫폼의 툴 요소인 사용자 라이브러리 요소 FrameBufferMultiRoi는 imaFlex CXP-12 플랫폼에서 지원되지 않는 VisualApplets 표준 연산자 ImageBufferMultiRoI와 동일한 기능을 제공합니다.
-
JPEG_Encoder_Color_iF_Penta: JPEG_Encoder_Color_iF_Penta를 사용하면 8비트 컬러 이미지를 JPEG 이미지로 변환할 수 있습니다.
-
JPEG_Encoder_Color_iF: JPEG_Encoder_Color_iF를 사용하면 8비트 컬러 이미지를 JPEG 이미지로 변환할 수 있습니다.
사용자 라이브러리 요소에 대한 자세한 설명은 설치된 ‘ VisualApplets ’의도움말 패널에서 확인할 수 있습니다. 또한, 사용자 라이브러리 요소 사용 방법을 보여주는 예제도 제공되니, ‘CoaXPress 12 imaFlex 프레임 그래버용 카메라 기본 획득 예제’를 참조하십시오 .








![[팁]](../common/images/admon/tip.png)




![[중요]](../common/images/admon/important.png)

이전

