Main Program Window

VisualApplets 애플릿 설계를 위한 그래픽 사용자 인터페이스를 제공합니다. 스크립트 작성이나 프로그래밍 코드 편집이 필요하지 않습니다. 사용자 인터페이스는 매우 간단하며, 사용자가 쉽게 익힐 수 있도록 특별히 설계되었습니다. 프로그래밍에 대한 기술적 지식이 필요하지 않습니다.

VisualApplets 의 메인 프로그램 창은 여러 개의 막대와 패널로 구성되어 있습니다:

Main Program Window

그림 11. 메인 프로그램 창


메인 메뉴 바를 통해 프로그램의 각 기능에 바로 접근할 수 있습니다. 중요한 기능을 빠르게 사용하려면 도구 모음 버튼을 이용하세요. 도구 모음 아이콘의 크기는 설정 → 시스템 설정 → 일반:

세 개의 패널은 각기 다른 정보와 가능성을 제공합니다:

  • 디자인 패널: 디자인 패널에는 ‘ VisualApplets ’ 프로젝트가 표시됩니다. 항상 하나의 메인 디자인 창이 표시되지만, 프로젝트 구조에 따라 여러 개의 하위 창을 추가로 사용할 수도 있습니다. 에서 창 메뉴에서 여러 보기 방식(타일, 계단식, 탭 보기)을 선택할 수 있습니다. [메뉴]에서 찾을 수 있는 메뉴 항목을 사용하여 창 → 다이어그램메뉴에서 여러 뷰를 선택할 수 있습니다(타일, 캐스케이드, 탭 뷰). Windows ( Ctrl+F8 ), 현재 작업하고 싶은 설계 다이어그램 창을 쉽게 선택할 수 있습니다.

  • 정보 패널: 메인 프로그램 창의 기본 설정에서는 정보 패널이 항상 표시됩니다. 이 패널은 탭 형식으로 다양한 정보 창을 제공합니다:

    • Project Info

    • Module Info

    • Parameter Info

    • DRC Log

    • Build Log

    • Help

    (각 정보 창에 대한 자세한 내용은 아래를 참조하십시오.)

  • 라이브러리 패널: 메인 프로그램 창의 기본 설정에서는 라이브러리 패널이 항상 표시됩니다. 이 패널은 탭 형식으로 세 개의 라이브러리 창을 제공합니다:

    • 연산자 라이브러리: 연산자 라이브러리는 VisualApplets 연산자, 즉 개별 이미지 처리 함수들을 포함하는 하위 라이브러리들의 모음입니다.

    • 사용자 라이브러리: 사용자 라이브러리에는 사용자가 정의한 연산자 조합(계층적 상자)이 포함된 사용자 정의 라이브러리를 포함할 수 있습니다. 자세한 내용은 ‘사용자 라이브러리’를 참조하십시오 .

    • 사용자 정의 라이브러리: 연산자를 사용자 정의 라이브러리로 가져오려면 다음 중 하나가 필요합니다. Expert 라이선스나 VisualApplets 4 라이선스가 필요합니다.

[팁] 특정 연산자

연산자 라이브러리에 표시된 일부 연산자는 현재 설계 중인 플랫폼에서 사용할 수 없을 수도 있습니다. 선택한 플랫폼에서 사용할 수 없는 경우, 해당 연산자는 회색으로 표시됩니다.

현재 선택된 대상 하드웨어 플랫폼에 대해 운영자가 없습니다.

그림 12. 현재 선택된 대상 하드웨어 플랫폼에 사용할 수 있는 연산자가 없습니다.


정보 패널의 창

Project Info

'프로젝트 정보' 창에는 현재 프로젝트에 대한 정보가 요약되어 있습니다.

Project Info

그림 13. 프로젝트 정보


다음과 같은 정보가 제공됩니다:

  • 이름: 프로젝트 이름 (=파일 이름)

  • 생성 날짜: 생성된 날짜

  • 최종 수정일: 마지막 수정 날짜

  • 버전: 프로젝트의 버전 번호입니다. 이 항목은 디자인 → 프로젝트 세부 정보 메뉴에서 ( ‘프로젝트 속성’ 참조)

  • 설명: 프로젝트에 대한 서술적 설명; 이 항목은 디자인 → 프로젝트 세부 정보 메뉴에서 ( ‘프로젝트 속성’ 참조)

  • 유형: 대상 하드웨어에서 현재 사용 중인 FPGA 유형을 표시합니다. ( ‘대상 하드웨어 포팅’ 참조)

  • 목표 실행 시간: 목표 실행 시간을 표시합니다( ‘목표 실행 시간’ 참조).

  • 설계 규칙 검사 레벨 1: 발견된 오류 또는 성공적인 수행 여부를 나타냅니다. ( ‘설계 규칙 검사’ 참조)

  • 하드웨어 애플릿: 하드웨어 애플릿의 존재 여부를 나타냅니다. 이 항목은 VisualApplets 에서 이전에 해당 프로젝트의 HAP 파일을 생성한 경우 선택됩니다.

  • 리소스: 리소스 추정 결과를 표시합니다. ‘FPGA 리소스 추정’ 항목도 참조하십시오 .

  • 시스템: 탐지된 XILINX 버전, 사용 가능한 Framegrabber SDK 버전 및 Framegrabber SDK 설치 디렉터리를 표시합니다. 이 정보는 VisualApplets 에서 HAP를 빌드하고 최종 HAP 출력을 생성하는 데 사용됩니다. 자세한 내용은 ‘빌드’를 참조하십시오.

Module Info

'모듈 정보' 창에는 프로젝트에서 사용 중인 모든 모듈의 목록이 표시됩니다(단, 창의 입력란이 비어 있는 경우에 한함). 이 목록은 프로젝트의 계층 구조에 따라 정리되어 있습니다.

모듈 검색

그림 14. 모듈 검색


'모듈 정보' 창에서는 특정 모듈이나 모듈 유형을 쉽게 검색할 수 있습니다. 이는 대규모 설계 작업을 할 때 매우 유용합니다. 검색을 시작하기 전에 필터 설정을 정의해야 합니다:

  • 모듈에 직접 지정한 이름을 검색하려면 “이름”을 활성화하세요.

  • 모듈 유형(현재 검색 중인 인스턴스의 연산자 이름)을 검색하려면, “유형”을 활성화하세요.

모듈 검색

그림 15. 모듈 검색


이제 검색어를 입력할 수 있습니다. 이름의 일부만 입력해도 충분합니다. ‘모듈 정보’ 창에 나열된 모듈 중 하나를 클릭하면 해당 디자인 창이 (디자인 패널에서) 활성화되며, 해당 모듈이 선택되어 강조 표시됩니다.

Parameter Info

‘매개변수 정보’ 보기에는 현재 활성화된 설계의 모든 매개변수와 해당 연산자가 표시됩니다. 또한 ‘매개변수 정보’ 보기에서 매개변수를 편집할 수도 있습니다.

Parameter Info

그림 16. 매개변수 정보


‘매개변수 정보’ 보기에는 매개변수, 매개변수 값 또는 연산자 이름을 검색할 수 있는 검색 기능이 제공됩니다. ‘런타임 매개변수만’ 필터를 사용하면 런타임 중에 편집할 수 있는 매개변수, 즉 동적 매개변수만 표시할 수 있습니다.

DRC Log

DRC 로그 창에는 마지막 설계 규칙 검사(Design Rules Check) 결과가 표시됩니다. 경고/오류 메시지 아래에 나열된 모듈 이름 중 하나를 클릭하면 해당 설계 창이 (설계 패널에서) 초점으로 이동하며, 해당 모듈이 선택되어 강조 표시됩니다.

DRC 로그 정보

그림 17. DRC 로그 정보


Build Log

'빌드 로그' 창에는 마지막 빌드의 결과가 표시됩니다.

제작 기록 정보

그림 18. 빌드 로그 정보


Help

'도움말' 창에서는 개별 연산자에 대한 상황에 맞는 도움말을 제공합니다.

상황에 맞는 도움말을 열려면 다음 방법 중 하나를 사용할 수 있습니다:

  1. 디자인에서 정보를 확인하려는 연산자를 직접 선택한 다음 F1 키를 눌러 도움말 창에서 해당 정보를 열어서 표시하십시오.

  2. ‘연산자 라이브러리’ 창에서 연산자를 하나 선택하십시오. ‘도움말’ 창에는 항상 현재 선택된 항목에 대한 도움말이 표시됩니다.

예: MergeKernel 연산자에 대한 정보 표시

그림 19. 예시: MergeKernel 연산자에 대한 정보 표시


만약 F1 키를 누르거나 도움말 버튼을 클릭하면, 현재 선택된 창이나 함수에 대한 상황에 맞는 사용자 설명서 도움말이 열립니다. 물론, 이 사용자 설명서에서 직접 연산자 도움말을 확인할 수도 있습니다. ‘연산자 참조’를 참조하십시오.

라이브러리 패널의 창

라이브러리 패널에는 ‘연산자 라이브러리’ 창, ‘사용자 라이브러리’ 창 및 ‘사용자 정의 라이브러리’ 창이 탭 형식으로 표시됩니다.

모든 라이브러리(연산자 라이브러리, 사용자 라이브러리, 그리고 모든 하위 라이브러리를 포함하는 사용자 정의 라이브러리)는 트리 구조로 구성되어 있습니다. 각 라이브러리에는 연산자가 포함되어 있습니다.

“트리”, “목록” 또는 “아이콘” 보기 중 하나를 선택하여 구조의 표시 방식을 변경할 수 있습니다.

‘Operator Library’가 전시된 도서관 패널

그림 20. 운영자 라이브러리가 표시된 라이브러리 패널


검색 필드에 검색어를 입력하면 목록에서 필요한 운영자만 필터링할 수 있습니다. 예를 들어 '카메라' 예를 들어 ‘camera’를 입력하면 camera 가 포함된 모든 오퍼레이터가 나열됩니다.

Operator Library

Operator 라이브러리는 ‘ VisualApplets ’ 연산자, 즉 개별 이미지 처리 함수들을 포함하는 하위 라이브러리들의 모음입니다.

‘연산자 라이브러리’ 창에서 연산자 이름을 클릭한 다음, 정보 패널의 ‘도움말’ 탭을 클릭하면 각 연산자에 대한 자세한 정보를 확인할 수 있습니다.

‘Operator Library’가 전시된 도서관 패널

그림 21. 운영자 라이브러리가 표시된 라이브러리 패널


다이어그램에 새로운 연산자를 추가하는 방법은 ‘연산자 삽입’을 참조하십시오. 모든 연산자에 대한 자세한 설명은 ‘연산자 참조’에 나와 있습니다.

User Library

사용자 라이브러리에는 사용자가 정의한 연산자 조합(계층적 상자)이 포함된 사용자 정의 라이브러리를 추가할 수 있습니다. 자세한 내용은 ‘사용자 라이브러리’를 참조하십시오.

Custom Library

연산자를 사용자 정의 라이브러리로 가져오려면 다음 중 하나가 필요합니다. Expert 라이선스나 VisualApplets 4 라이선스가 필요합니다.

메인 프로그램 창 조정

VisualApplets 의 메인 프로그램 창을 개인 취향에 맞게 조정할 수 있는 다양한 옵션이 있습니다:

도구 모음 사용자 지정

도구 모음은 드래그 앤 드롭으로 재배치하거나 마우스 오른쪽 버튼을 클릭하여 추가하거나 제거할 수 있습니다.

메인 프로그램 창의 기본 설정 복원

실수로 창이나 도구 모음을 원치 않는 방식으로 배열한 경우, 다음 방법을 통해 기본 설정으로 복원할 수 있습니다. 창 → 도크 초기화 Windows ( Ctrl+O ) 또는 해당 아이콘을 클릭하여 '보기' 도구 모음에서.

File -> Recent Designs 아래의 파일 수

아래 파일 → 최근 디자인 VisualApplets 에서는 최근에 열었던 ‘ VisualApplets ’ 파일(*.va) 목록을 제공합니다. 표시되는 파일의 수를 설정할 수 있습니다.

최근에 연 파일 중 몇 개를 표시할지 설정하려면:

  1. 메뉴로 이동 설정 → 시스템 설정 로 이동하여 카테고리 일반를 선택합니다.

  2. 아래 최근 디자인에서 표시할 파일 수를 지정하세요(최대 24개).

  3. 다음과 확인하십시오 확인.

표시되는 최근 디자인 수 설정하기

그림 22. 표시될 최근 디자인 수 설정