사용자 라이브러리

사용자 라이브러리에서는 자주 사용하는 모ジュール 조합을 캡슐화하여 나중에 재사용할 수 있도록 저장할 수 있습니다.

원하는 만큼 사용자 라이브러리를 정의할 수 있습니다. 각 사용자 라이브러리에는 원하는 만큼의 사용자 라이브러리 요소를 포함할 수 있습니다.

A user library element는 특정 모ジュール과 링크 조합을 포함합니다. 생성된 라이브러리 요소는 라이브러리 패널(User Library 탭)에서 사용할 수 있으며 오퍼레이터처럼 사용할 수 있습니다.

사용자 라이브러리 요소는 계층형 박스와 거의 동일합니다('Hierarchical Boxes' 참조). 차이점은 사용자 라이브러리 요소가 (사용자 정의) 사용자 라이브러리에 저장되며, 오퍼레이터 라이브러리의 오퍼레이터처럼 다른 디자인과 프로젝트에 삽입할 수 있다는 점입니다.

라이브러리 패널의 요소가 포함된 사용자 라이브러리

그림 169. 라이브러리 패널의 요소가 포함된 사용자 라이브러리


사용자 라이브러리 요소의 인스턴스는 서로 독립적입니다. 즉, 하나의 인스턴스를 변경하더라도 동일한 사용자 라이브러리의 다른 인스턴스에는 영향을 미치지 않습니다.

사용자 라이브러리는 다음 형식으로 저장됩니다. *.val 또는 *.vl 파일. 이러한 파일은 특정 프로젝트의 일부가 아니므로 다른 프로젝트에서도 사용할 수 있습니다.

다음에서 시스템 설정 VisualApplets의 에서 시스템 내에서 파일이 저장될 위치를 지정할 수 있습니다( *.val 또는 *.vl 파일이 저장될 위치를 시스템에서 지정할 수 있습니다(참조: 'System Settings').

디자인에 사용자 라이브러리 요소의 인스턴스를 삽입한 후에는 프로젝트를 로드하거나 앱릿(*.hap 파일)을 빌드하기 위해 *.val 또는 *.vl 파일이 필요하지 않습니다.

새 사용자 라이브러리 만들기

새 사용자 라이브러리를 생성하려면 다음과 같이 진행합니다.

  1. 라이브러리 패널에서 User Library 탭을 클릭합니다.

  2. 사용자 라이브러리 창을 마우스 우클릭합니다.

  3. 컨텍스트 메뉴에서 Create New User Library를 선택합니다.

    (또는 메인 메뉴 Library → Create New User Library를 사용할 수도 있습니다.)

  4. 다음 '새 사용자 라이브러리 만들기' 대화 상자가 열립니다:

  5. 새 사용자 라이브러리에 이름을 지정하세요.

  6. 기본적으로 새 사용자 라이브러리는 *.val 파일 형식. 이 라이브러리를 VisualApplet 버전 3.3.2 또는 그 이전 버전에서 열려면 다음을 선택하십시오. 구형 라이브러리 형식 (.vl). 다음 점에 유의하십시오. 만약 다음 위치에 있는 레거시 사용자 라이브러리가 *.vl 파일 형식에 보호된 사용자 라이브러리 요소가 포함되어 있으므로 이 요소는 저장되지 않으며 이전 파일 형식으로 열 수 없습니다.

  7. OK를 클릭하십시오.

이제 사용자 라이브러리 요소로 채울 수 있는 빈 사용자 라이브러리(컨테이너 역할)가 생성되었습니다.

사용자 라이브러리 이름 위에 마우스를 가져가면 라이브러리가 다음 형식으로 저장되었는지 여부를 보여주는 툴팁이 표시됩니다. *.vl 이전 파일 형식:

사용자 라이브러리 요소 만들기

새 사용자 라이브러리 요소를 만드는 방법에는 두 가지가 있습니다. 다음 중 하나를 수행할 수 있습니다.

계층형 상자를 사용자 라이브러리 요소로 저장

  1. 계층형 박스를 마우스 우클릭하여 모듈의 컨텍스트 메뉴를 엽니다.

  2. Save to User Library를 선택합니다.

    Save 대화상자가 나타납니다.

    계층형 상자를 사용자 라이브러리 요소로 저장

    그림 170. 계층형 박스를 사용자 라이브러리 요소로 저장


  3. 새 요소를 저장할 사용자 라이브러리를 선택합니다(또는 New User Library를 클릭하여 새 라이브러리를 정의할 수도 있습니다).

  4. 새 사용자 라이브러리 요소의 이름을 입력합니다(Element Type 아래).

  5. 선택 사항: 요소에 대한 정보(버전 번호, 간략한 설명, 개별 GUI Icon, HTML 도움말 파일 형식의 문서)를 추가하려면:

    1. Details를 클릭하십시오. 새 대화상자가 열립니다.

      문서, 버전 번호, 간략한 설명 및/또는 개별 GUI Icon 추가

      그림 171. 문서, 버전 번호, 간략한 설명 및/또는 개별 GUI Icon 추가


    2. 원하는 경우 라이브러리 요소의 버전 번호를 입력합니다.

    3. 원하는 경우 라이브러리 요소의 간략한 설명을 입력합니다.

    4. VisualApplets GUI에서 라이브러리 요소와 함께 표시될 특정 아이콘을 지정하려면 Icon File 필드에 PNG 파일의 경로를 지정하거나 필드 오른쪽에 있는 탐색 버튼을 사용하십시오.

    5. 사용자 라이브러리 요소를 설명하는 문서를 추가하려면 HTML Help Files 아래의 더하기 버튼을 클릭하고 문서 텍스트가 포함된 HTML 파일로 이동하십시오.

      여러 개의 HTML 및 이미지 파일을 지정할 수 있습니다. 여러 개의 HTML 파일을 추가하는 경우 목록의 첫 번째 HTML 파일이 문서의 시작 페이지가 됩니다. 시작 페이지는 사용자 라이브러리 요소의 문서로 표시됩니다(정보 패널의 Help 탭). 추가 파일에는 시작 페이지에서 링크하는 이미지나 추가 HTML 파일이 포함될 수 있습니다.

      [참고] 도움말 파일 이름 지정 및 저장

      When you save your user library element later on, all the files you specify here will be copied to the VisualApplets installation directory, sub-directory LibraryCache. The starting page of your documentation (first HTML file in the list) will be renamed and will have the name of the user library element:<elementname>.html

      라이브러리 요소에서 HTML 파일의 연결을 해제하려면 해당 파일을 선택하고 삭제 버튼을 클릭하십시오. HTML 파일의 연결은 해제되지만 파일 시스템에는 유지됩니다.

    6. OK(으)로 새 사용자 라이브러리 요소의 세부 사양을 확인합니다.

  6. 사용자 라이브러리 요소를 보호하려면 Protection 옵션을 선택하십시오. 이렇게 하면 사용자 라이브러리 요소가 "블랙 박스"로 처리됩니다. (요소 보호에 대한 자세한 내용은 'Protecting User Library Elements'를 참조하십시오.)

  7. Save를 클릭합니다.

    선택 사항인 PNG 및 HTML 파일이 VisualApplets 설치 디렉토리의 하위 디렉토리인 LibraryCache로 복사됩니다.

    Protection 옵션을 활성화한 경우, Protect User Library Element 추가 대화 상자가 나타납니다.

    1. 보호 모드 Password가 활성화되어 있는지 확인하십시오.

    2. 비밀번호를 입력하고 OK를 클릭합니다.

      라이브러리 요소에 비밀번호 지정하기

      그림 172. 라이브러리 요소에 비밀번호 지정하기


    모든 User 라이브러리 및 해당 콘텐츠는 라이브러리 패널에서 사용할 수 있습니다(The User Interface of VisualApplets 참조). User Library 창을 표시하려면 User Library 탭을 클릭하십시오.

    선택한 아이콘이 라이브러리 요소와 함께 표시됩니다.

    개별 요소에 대한 자세한 정보가 툴팁에 표시됩니다.

    사용자 라이브러리 요소에 대한 툴팁 정보

    그림 173. 사용자 라이브러리 요소에 대한 툴팁 정보


    새 사용자 라이브러리 요소를 선택하면, 해당 도움말 정보가 Help 탭 아래의 정보 패널에 표시됩니다.

    디자인 창 내의 디스플레이가 변경되었습니다. "HierarchicalBox" 대신 사용자 라이브러리 요소의 이름이 표시됩니다. 계층적 상자(Hierarchical boxes)용 아이콘이 라이브러리 요소에 대해 선택한 아이콘으로 대체되었습니다. 디자인 내 인스턴스의 이름(아이콘 아래)은 그대로 유지되었습니다.

    디자인에 표시된 라이브러리 요소

    그림 174. 디자인에 표시된 라이브러리 요소


나중에 언제든지 사용자 라이브러리 요소를 변경할 수 있습니다(섹션 'Editing User Library Elements' 참조). 그러나 이러한 변경 사항은 해당 요소의 인스턴스에 반영되지 않습니다. 원하는 경우 사용자 라이브러리 요소의 인스턴스를 업데이트하기 위한 다양한 옵션을 사용할 수 있습니다(섹션 'Updating Instantiated User Library Elements' 참조).

[참고] 사용자 라이브러리 요소 분석

Design Rules Check Level 1을 사용할 수 있습니다.

리소스 분석, 빌드 및 시뮬레이션은 사용할 수 없습니다.

처음부터 새 사용자 라이브러리 요소 만들기

또는 처음부터 새로운 사용자 라이브러리 요소를 생성할 수 있습니다. 사용자 라이브러리 요소를 정의 및/또는 변경하려면 User Library Editor를 사용합니다.

처음부터 새로운 사용자 라이브러리 요소를 정의하려면:

  1. 메인 메뉴에서 Library → Edit User Library → New User Library Element를 선택합니다.

    이제 디자인 편집기가 닫힙니다. 디자인 편집기와 함께 작업 중이던 디자인도 닫힙니다.

    유저 라이브러리 편집기가 열립니다. 유저 라이브러리 편집기는 일반 디자인 편집기와 동일하게 작동합니다.

  2. 새 유저 라이브러리 엘리먼트의 이름을 지정합니다.

  3. 대상 하드웨어 플랫폼을 선택합니다.

    (단, 이 플랫폼은 카메라 operator와 같이 하드웨어 문제에 종속된 operator를 엘리먼트에 포함하는 경우에만 유효합니다.)

  4. OK를 클릭합니다.

  5. OK를 클릭하면 엘리먼트의 입력 및 출력 포트 수를 지정해야 하는 대화 상자가 열립니다. 나중에 이 개수를 변경할 수 없으므로 입력 및 출력 링크 수를 올바르게 지정해야 합니다.

    1. 필요한 입력 포트 수를 지정합니다.

    2. 필요한 출력 포트 수를 지정합니다.

    [주의] 필요한 링크 수 정의

    나중에 이 개수를 변경할 수 없으므로 입력 및 출력 링크 수를 올바르게 지정해야 합니다.

  6. OK를 눌러 포트 정의를 확인합니다.

    방금 지정한 입력 및 출력 포트만 포함된 빈 엘리먼트 디자인과 함께 유저 라이브러리 편집기가 열립니다.

  7. 원하는 대로 유저 라이브러리 엘리먼트의 디자인을 편집합니다.

  8. 작업이 끝나면 메인 메뉴에서 File → Save As를 선택하여 엘리먼트를 저장합니다.

    새 유저 라이브러리 엘리먼트 저장

    그림 175. 새 유저 라이브러리 엘리먼트 저장


  9. 새 엘리먼트를 저장할 유저 라이브러리를 선택합니다(또는 New User Library를 클릭하여 새 라이브러리를 정의할 수도 있습니다).

  10. 선택 사항: 엘리먼트에 대한 정보(버전 번호, 간략한 설명, 개별 GUI 아이콘, HTML 도움말 파일 형태의 문서)를 추가하려면:

    1. Details를 클릭합니다. 새 대화 상자가 열립니다.

      문서, 버전 번호, 간략한 설명 및/또는 개별 GUI Icon 추가

      그림 176. 문서, 버전 정보, 간략한 설명 및/또는 개별 GUI 아이콘 추가


    2. 필요한 경우 라이브러리 엘리먼트의 버전 번호를 입력합니다.

    3. 필요한 경우 라이브러리 엘리먼트의 간략한 설명을 입력합니다.

    4. VisualApplets GUI에서 라이브러리 엘리먼트와 함께 표시될 특정 아이콘을 지정하려면 Icon File 필드에 PNG 파일의 경로를 지정하거나 필드 오른쪽에 있는 탐색 버튼을 사용합니다.

    5. 유저 라이브러리 엘리먼트를 설명하는 문서를 추가하려면 HTML Help Files 아래의 더하기 버튼을 클릭하고 문서 텍스트가 포함된 HTML 파일로 이동합니다.

      여러 개의 HTML 및 이미지 파일을 지정할 수 있습니다. 여러 개의 HTML 파일을 추가하는 경우 목록의 첫 번째 HTML 파일이 문서의 시작 페이지가 됩니다. 시작 페이지는 유저 라이브러리 엘리먼트의 문서로 정보 패널의 Help 탭에 표시됩니다. 추가 파일에는 시작 페이지에서 링크하는 이미지나 추가 HTML 파일이 포함될 수 있습니다.

      [참고] 도움말 파일 이름 지정 및 저장

      When you save your user library element later on, all the files you specify here will be copied to the VisualApplets installation directory, sub-directory LibraryCache. The starting page of your documentation (first HTML file in the list) will be renamed and will have the name of the user library element:<elementname>.html

      라이브러리 요소에서 HTML 파일 연결을 해제하려면, 해당 요소를 선택하고 삭제 버튼을 클릭하십시오. HTML 파일의 연결은 해제되지만 파일 시스템에는 유지됩니다.

    6. OK를 클릭하여 새 사용자 라이브러리 요소의 세부 사상을 확인하십시오.

  11. 사용자 라이브러리 요소를 보호하려면 Protection 옵션을 선택하십시오. 이렇게 하면 사용자 라이브러리 요소가 "블랙 박스"로 처리됩니다. (요소 보호에 대한 자세한 내용은 'Protecting User Library Elements'를 참조하십시오.)

    [참고] 보호된 요소는 레거시 파일 형식으로 저장할 수 없습니다.

    사용자 라이브러리를 *.vl 레거시 파일 형식으로 저장하는 경우, 보호된 요소는 저장할 수 없습니다. 이 경우 보호를 해제하거나 사용자 라이브러리를 더 최신의 권장되는 *.val 파일 형식으로 저장하십시오.

    레거시 파일 형식을 사용하면 VisualApplets 버전 3.3.2 이하에서 사용자 라이브러리를 열 수 있습니다.

  12. Save를 클릭합니다.

    선택 사항인 PNG 및 HTML 파일은 VisualApplets 설치 디렉토리의 하위 디렉토리인 LibraryCache에 복사됩니다.

    Protection 옵션을 활성화한 경우, Protect User Library Element 추가 대화상자가 나타납니다.

    1. 보호 모드 Password가 활성화되어 있는지 확인하십시오.

    2. 비밀번호를 입력하고 OK를 클릭합니다.

      라이브러리 요소에 비밀번호 지정하기

      그림 177. 라이브러리 요소에 대한 비밀번호 제공


    모든 사용자 라이브러리와 그 콘텐츠는 라이브러리 패널에서 사용할 수 있습니다(The User Interface of VisualApplets 참조). User Library 탭을 클릭하여 사용자 라이브러리 창을 표시하십시오.

    선택한 아이콘이 라이브러리 요소와 함께 표시됩니다.

    개별 요소에 대한 자세한 정보가 툴팁에 표시됩니다.

    사용자 라이브러리 요소에 대한 툴팁 정보

    그림 178. 사용자 라이브러리 요소 툴팁 정보


    새 사용자 라이브러리 요소를 선택하면, 해당 도움말 정보가 Help 탭 아래의 정보 패널에 표시됩니다.

  13. 설계 작업을 계속 진행하려면 사용자 라이브러리 요소 설계와 사용자 라이브러리 편집기를 닫으십시오. 메인 메뉴에서 File → Close를 선택하십시오.

    [주의] File->Close를 통해 요소 설계 닫기

    설계 탭을 닫는 것만으로는 요소 설계를 닫기에 충분하지 않습니다. 사용자 라이브러리 편집기도 함께 닫아야 합니다.

    둘 다 닫으려면 File → Close를 클릭하십시오. 이 방법으로 사용자 라이브러리 요소의 설계(및 라이브러리 편집기)를 닫은 후에야 일반 설계 편집기 및 전체 앱렛 설정을 다시 열 수 있습니다.

  14. 설계 작업을 계속하려면 설계를 여십시오.

나중에 언제든지 사용자 라이브러리 요소를 변경할 수 있습니다(섹션 'Editing User Library Elements' 참조). 그러나 이러한 변경 사항은 해당 요소의 인스턴스에 반영되지 않습니다. 원하는 경우 사용자 라이브러리 요소의 인스턴스를 업데이트하기 위한 다양한 옵션을 사용할 수 있습니다(섹션 'Updating Instantiated User Library Elements' 참조).

[참고] 사용자 라이브러리 요소 분석

Design Rules Check Level 1을 사용할 수 있습니다.

리소스 분석, 빌드 및 시뮬레이션은 사용할 수 없습니다.

사용자 라이브러리 사용

설정에 사용자 라이브러리 요소 삽입

설계로 간단히 드래그 앤 드롭하여 요소의 인스턴스를 생성할 수 있습니다(오퍼레이터의 경우와 마찬가지임).

인스턴스화된 모듈은 계층적 상자처럼 작동하지만, 사용자 라이브러리에서 파생되었음을 인식합니다.

설정에 맞게 요소 인스턴스 조정

전체 설계에 맞게 사용자 라이브러리 요소의 인스턴스를 조정할 수 있습니다. 다음을 수행해야 할 수 있습니다.

  • 개별 오퍼레이터 파라미터 수정

  • 레이아웃 수정(연산자 및 링크 추가 및 삭제)

[팁] 링크 Property 변경

변경된 링크 Property는 라이브러리 요소 인스턴스의 구현을 변경하지 않습니다. 예: 라이브러리 요소가 Parallelism 4로 저장되었지만 해당 인스턴스가 Parallelism 8에 연결된 경우, 이는 인스턴스 내의 링크에 당연히 영향을 미칩니다. 그러나 링크 Property의 변경으로 인해 영향을 받는 연산자 파라미터가 없으므로 이는 인스턴스 구현의 변경이 아닙니다.

개별 연산자 파라미터 수정 또는 레이아웃 수정(연산자 및 링크 추가 및 삭제)을 통해 사용자 라이브러리 요소의 인스턴스를 수정한 후에는 해당 인스턴스가 더 이상 사용자 라이브러리 요소의 단순한 복사본이 아닙니다.

어떤 인스턴스에 변경 사항이 포함되어 있는지 확인할 수 있도록, 수정된 사용자 라이브러리 요소 인스턴스에 표시가 나타납니다.

그림 179.


사용자 라이브러리 요소 인스턴스를 업데이트('인스턴스화된 사용자 라이브러리 요소 업데이트' 섹션 참조)하면 인스턴스에 적용한 변경 사항이 덮어쓰여지므로 이는 매우 중요한 정보입니다. 변경 사항이 포함된 인스턴스에 대해 자동 업데이트를 선택하기 전에 항상 장단점을 신중하게 고려해야 합니다.

사용자 라이브러리 요소 보호

사용자 라이브러리 요소를 보호할 수 있습니다. 보호가 활성화되면 사용자 라이브러리 요소는 “블랙박스”가 됩니다. 단, 동적 파라미터나 Parameters 라이브러리의 연산자에서 참조하는 파라미터가 포함된 보호된 요소는 런타임에서도 여전히 표시됩니다.

[참고] 보호된 요소는 레거시 파일 형식으로 저장할 수 없습니다.

사용자 라이브러리를 *.vl 레거시 파일 형식에서는 보호된 요소를 저장할 수 없습니다. 이 경우 보호를 해제하거나 더 최신의 권장되는 *.val 파일 형식으로 사용자 라이브러리를 저장하세요.

레거시 파일 형식을 사용하면 VisualApplets 버전 3.3.2 이하에서 사용자 라이브러리를 열 수 있습니다.

사용자 라이브러리 요소를 보호하는 방법에는 두 가지가 있습니다.

  • 비밀번호를 통한 보호: 이후 비밀번호를 통해 사용자 라이브러리 요소를 열고 편집할 수 있습니다. 비밀번호가 없는 사용자는 사용자 라이브러리 요소에 어떤 연산자가 사용되었는지조차 확인할 수 없습니다(블랙박스).

  • 영구 보호: 사용자 라이브러리 요소가 영구적으로 블랙박스가 되며, 본인을 포함하여 다시는 열 수 없습니다.

비밀번호로 사용자 라이브러리 요소를 보호하려면 다음과 같이 하세요.

  1. 해당 요소에서 마우스 우클릭을 합니다.

  2. 컨텍스트 메뉴에서 Protect User Library Element를 선택합니다.

    사용자 라이브러리 요소 보호

    그림 180. 사용자 라이브러리 요소 보호


  3. 보호 모드가 Password로 활성화되어 있는지 확인합니다.

  4. 비밀번호를 입력합니다.

    보호된 사용자 라이브러리 요소의 비밀번호 입력

    그림 181. 보호된 사용자 라이브러리 요소의 비밀번호 입력


  5. OK를 클릭합니다.

[주의] 단방향(One-Way) 영구 보호

보호 모드로 Password 대신 One Way를 선택하면, 본인을 포함하여 사용자 라이브러리 요소를 다시는 열 수 없습니다. 나중에 요소를 개선할 계획이라면 반드시 Password 보호 모드를 선택하세요. 또는 이 보호 모드를 활성화하기 전에 해당 요소의 복사본(계층형 박스 또는 비보호 연산자 형태)을 저장해 둘 수 있습니다.

사용자 라이브러리 요소 편집

사용자 라이브러리 요소를 변경할 수 있습니다. 방법은 다음과 같습니다.

  • 라이브러리 편집기에서 라이브러리 요소 자체를 편집하거나,

  • 변경되거나 계층형 박스인 인스턴스로 해당 요소를 덮어씁니다.

그러나 이러한 변경 사항은 자동으로 반영되지 않습니다. 라이브러리 요소의 인스턴스에 요소의 변경 사항을 반영하려면 인스턴스를 업데이트해야 합니다('Updating Instantiated User Library Elements' 섹션 참조).

사용자 라이브러리 편집기에서 사용자 라이브러리 요소 편집

사용자 라이브러리 편집기에서 사용자 라이브러리 요소를 편집할 수 있습니다. 사용자 라이브러리 편집기를 여는 방법:

  1. 현재 작업 중인 디자인을 저장합니다.

  2. 라이브러리 창에서 User Library 탭으로 이동합니다.

  3. 편집하려는 요소를 마우스 오른쪽 버튼으로 클릭합니다.

  4. 요소의 컨텍스트 메뉴에서 Edit을 선택합니다.

    사용자 라이브러리 편집기 열기

    그림 182. 사용자 라이브러리 편집기 열기


이제 디자인 편집기가 닫힙니다. 디자인 편집기와 함께 작업 중이던 디자인도 닫힙니다.

사용자 라이브러리 편집기가 열립니다. 사용자 라이브러리 편집기는 일반 디자인 편집기와 동일하게 작동합니다.

  1. 변경 작업을 수행합니다.

  2. 변경 사항을 저장합니다.

요소 설명과 버전 번호를 편집하려면:

  1. 메인 메뉴에서 Library → Element Details를 선택합니다.

  2. 편집된 요소를 저장합니다.

Analysis of User Library Elements: 디자인 규칙 검사(Design Rules Check) 레벨 1을 수행할 수 있습니다. 그러나 대역폭 분석, 리소스 분석, 빌드 및 시뮬레이션은 수행할 수 없습니다.

[중요] 인스턴스 업데이트

사용자 라이브러리 요소를 변경해도 디자인에 인스턴스화된 요소에는 이러한 변경 사항이 반영되지 않습니다. 라이브러리 요소의 인스턴스에 요소의 변경 사항을 반영하려면 인스턴스를 업데이트해야 합니다('Updating Instantiated User Library Elements' 섹션 참조).

덮어쓰기를 통해 사용자 라이브러리 요소 편집

또는 사용자 라이브러리 요소를 간단히 덮어쓰는 방식으로 편집할 수 있습니다. 방법은 다음과 같습니다.

  1. 기존 사용자 라이브러리 요소의 이름으로 계층형 박스 또는 인스턴스화된 사용자 라이브러리 요소를 저장합니다('Saving a Hierarchical Box as a User Library Element'에 설명된 대로).

[중요] 인스턴스 업데이트

사용자 라이브러리 요소를 변경해도 디자인에 인스턴스화된 요소에는 이러한 변경 사항이 반영되지 않습니다. 라이브러리 요소의 인스턴스에 요소의 변경 사항을 반영하려면 인스턴스를 업데이트해야 합니다('Updating Instantiated User Library Elements' 섹션 참조).

다음 섹션에서는 인스턴스화된 사용자 라이브러리 요소를 업데이트하는 방법에 대한 정보를 제공합니다.

인스턴스화된 사용자 라이브러리 요소 업데이트

일반적인 작업 흐름에서는 사용자 라이브러리 요소를 업데이트해야 하는 경우가 발생합니다. 하지만 요소에 적용한 변경 사항은 해당 요소의 인스턴스에 영향을 주지 않습니다. 디자인 내 요소의 인스턴스를 업데이트하려면 변경 사항을 수동으로 추가하거나 VisualApplets에서 제공하는 두 가지 업데이트 메커니즘 중 하나를 사용할 수 있습니다(아래 참조).

수동으로 업데이트

변경된 엘리먼트의 인스턴스를 수동으로 업데이트하기로 결정한 경우, 디자인에서 엘리먼트의 여러 인스턴스를 선택하여 한 번에 동시에 변경할 수 있습니다.

[주의] 계층 구조 업데이트 없음

사용자 라이브러리 엘리먼트의 계층 구조 업데이트는 지원되지 않습니다. 업데이트를 위해 계층 구조의 모듈을 둘 이상 선택한 경우, 계층 구조의 가장 상위 모듈만 업데이트됩니다.

빠른 업데이트를 통한 모듈 교체

Quick Update 기능을 통해 디자인 내 사용자 라이브러리 엘리먼트의 인스턴스를 업데이트할 수 있습니다.

[주의] 업데이트 시 인스턴스 내 변경 사항 덮어쓰기

사용자 라이브러리 엘리먼트의 인스턴스를 업데이트하면 인스턴스에 적용했던 모든 변경 사항(파라미터 설정 또는 오퍼레이터 추가/삭제)이 덮어씌워집니다. 변경 사항이 포함된 인스턴스에 대해 자동 업데이트를 선택하기 전에 장단점을 신중히 고려해야 합니다.

어떤 인스턴스에 변경 사항이 포함되어 있는지 확인할 수 있도록, 라이브러리 엘리먼트의 수정된 인스턴스에는 다음과 같이 표시가 지정됩니다.

Quick Update를 통해 라이브러리 엘리먼트의 인스턴스를 업데이트하려면:

  1. 업데이트할 인스턴스를 선택합니다.

  2. 기본 메뉴에서 Library → Quick Update from User Library를 선택합니다.

선택한 엘리먼트 인스턴스는 라이브러리에서 엘리먼트에 적용한 변경 사항이 반영된 새 인스턴스로 교체됩니다.

Quick Update는 업데이트하려는 인스턴스가 편집된 사용자 라이브러리 엘리먼트와 동일한 수의 입력 및 출력 포트를 가진 경우에만 가능합니다. 사용자 라이브러리 엘리먼트 타입 A의 인스턴스를 사용자 라이브러리 엘리먼트 타입 B의 인스턴스로 교체하는 데는 Quick Update를 사용할 수 없습니다.

Quick Update를 사용하면 엘리먼트의 여러 인스턴스를 한 번에 업데이트할 수 있습니다.

  1. Ctrl 키를 누른 상태에서 업데이트할 모든 인스턴스를 선택합니다.

  2. 기본 메뉴에서 Library → Quick Update from User Library를 선택합니다.

    선택한 엘리먼트의 모든 인스턴스가 새로운 인스턴스로 교체됩니다.

Update from User Library를 통한 인스턴스 교체

이 옵션을 선택할 경우, 교체하려는 인스턴스가 업데이트할 라이브러리 엘리먼트와 동일한 타입일 필요가 없습니다. 따라서 이 옵션을 사용하여 사용자 라이브러리 엘리먼트 또는 계층 구조 박스의 인스턴스를 다른 사용자 라이브러리 엘리먼트의 인스턴스로 교체할 수 있습니다. 예를 들어, ("Quick Update" 옵션과 달리) 사용자 라이브러리 엘리먼트 타입 A의 인스턴스를 사용자 라이브러리 엘리먼트 타입 B의 인스턴스로 교체할 수 있습니다. 그럼에도 불구하고 Update from User Library 역시 교체하려는 인스턴스가 교체 대상인 사용자 라이브러리 엘리먼트와 동일한 수의 입력 및 출력 포트를 가진 경우에만 가능합니다.

엘리먼트의 하나 이상의 인스턴스를 다른 사용자 라이브러리 엘리먼트의 인스턴스로 교체하려면:

  1. (Ctrl 키를 누른 채로) 교체할 모듈을 선택합니다.

  2. 기본 메뉴에서 Library → Update from User Library를 선택합니다.

    Update User Library Elements 대화 상자 창이 열립니다. 왼쪽 패널에는 업데이트하기 위해 선택한 모듈이 표시됩니다. 오른쪽 패널에는 사용자 라이브러리가 표시됩니다.

    인스턴스 교체

    그림 183. 인스턴스 교체


  3. 오른쪽 패널에서 필요한 사용자 라이브러리 엘리먼트를 선택합니다. 왼쪽 패널에서 원하는 대로 교체할 수 있는 모든 모듈은 녹색으로 강조 표시됩니다(그렇지 않은 경우 입력 및 출력 수가 일치하는지 확인하세요).

  4. Replace Modules를 클릭합니다.

    노드 수가 일치하는 나열된 모든 모듈이 즉시 새 사용자 라이브러리 요소의 인스턴스로 교체됩니다.

위의 예시: 두 경우 모두 입력 및 출력 수가 일치하지 않습니다. 모듈 28에는 1개의 입력 포트와 1개의 출력 포트만 있는 반면, USRLibraryELement5에는 3개의 입력 포트와 3개의 출력 포트가 있습니다. 모듈 32, 31, 33은 USRLibraryELement5와 정확히 동일한 수의 입력 및 출력 포트를 가지고 있으므로 USRLibraryELement5로 교체할 수 있습니다.

사용자 라이브러리 모듈을 계층형 상자로 변환

경우에 따라 요소 인스턴스를 사용자 라이브러리에서 연결 해제하는 것이 유용할 수 있습니다. 이렇게 하려면 사용자 라이브러리 요소의 인스턴스를 계층적 상자(Hierarchical Box)로 변환할 수 있습니다.

  1. 디자인에서 변환하려는 모듈을 선택합니다. (둘 이상의 모듈을 변환하려면 Ctrl 키를 누른 채 변환할 모든 모듈을 선택합니다.)

  2. 메인 메뉴에서 Library → Change to Hierarchical Box를 선택합니다.

선택한 모든 모듈이 완전히 독립적인 계층적 상자로 즉시 변환됩니다.

제공된 사용자 라이브러리

VisualApplets 배포판에는 두 개의 사용자 라이브러리가 포함되어 있습니다.

  • JPEG_Color

  • imaFlex_CXP12_Tools

  • imaFlex_CXP12_Tools_Advanced

제공된 이러한 사용자 라이브러리가 표시되지 않으면 User Library 패널을 마우스 우클릭하고 열리는 콘텍스트 메뉴에서 Rescan User Library Directory를 선택하십시오.

그러면 VisualApplets가 System Settings → Path Settings → Libraries/Path for storage of user libraries에 지정된 디렉터리에 있는 라이브러리를 엽니다.

JPEG_Color User Library

JPEG_Color 사용자 라이브러리에는 다음 요소가 포함되어 있습니다.

  • JPEGEncoder_Color_800MPs_VCX: 이 사용자 라이브러리 요소를 사용하면 8비트 컬러 이미지를 JPEG 이미지로 변환할 수 있습니다. JPEG_Encoder_Color_800MPs_VCX는 CXPx2 프레임 그래버용이며 160 MHz의 클록 레이트에서 800 MP/s의 대역폭을 제공합니다. 입력 Parallelism은 8입니다.

  • JPEGEncoder_Color_1500MPs_VCX: 이 사용자 라이브러리 요소를 사용하면 8비트 컬러 이미지를 JPEG 이미지로 변환할 수 있습니다. JPEG_Encoder_Color_1500MPs_VCX는 CXPx2 프레임 그래버용이며 160 MHz의 클록 레이트에서 1200 MP/s의 대역폭을 제공합니다. 입력 Parallelism은 8입니다.

  • JPEGEncoder_Color_2500MPs_VCX: 이 사용자 라이브러리 요소를 사용하면 8비트 컬러 이미지를 JPEG 이미지로 변환할 수 있습니다. JPEG_Encoder_Color_2500MPs_VCX는 CXPx4 프레임 그래버용이며 160 MHz의 클록 레이트에서 2400 MP/s의 대역폭을 제공합니다. 입력 Parallelism은 16입니다.

  • JPEGEncoder_Color_300MPs_VCL: 이 사용자 라이브러리 요소를 사용하면 8비트 컬러 이미지를 JPEG 이미지로 변환할 수 있습니다. JPEG_Encoder_Color_300MPs_VCL은 Camera Link (CL) 프레임 그래버용이며 300 MP/s의 대역폭을 제공합니다. 입력 Parallelism은 4입니다.

  • JPEGEncoder_Color_600MPs_VCL: 이 사용자 라이브러리 요소를 사용하면 8비트 컬러 이미지를 JPEG 이미지로 변환할 수 있습니다. JPEG_Encoder_Color_600MPs_VCL은 Camera Link (CL) 프레임 그래버용이며 155 MHz의 클록 레이트에서 600 MP/s의 대역폭을 제공합니다. 입력 Parallelism은 4입니다.

  • JPEGEncoder_Color_850MPs_VCL: 이 사용자 라이브러리 요소를 사용하면 8비트 컬러 이미지를 JPEG 이미지로 변환할 수 있습니다. JPEG_Encoder_Color_850MPs_VCL은 Camera Link (CL) 프레임 그래버용이며 170 MHz의 클록 레이트에서 850 MP/s의 대역폭을 제공합니다. 입력 Parallelism은 8입니다.

사용자 라이브러리 요소에 대한 자세한 설명서는 VisualApplets 설치의 Help 패널에서 확인할 수 있습니다.

imaFlex_CXP12_Tools User Library

[참고] imaFlex_CXP12_Tools_Advanced User Library 사용 권장

imaFlex_CXP12_Tools 사용자 라이브러리는 하위 호환성 유지를 위해서만 제공됩니다. 가능한 경우 대신 imaFlex_CXP12_Tools_Advanced 사용자 라이브러리를 사용하십시오.

imaFlex_CXP12_Tools 사용자 라이브러리에는 다음 요소가 포함되어 있습니다.

  • ImageBufferMultiRoI: 이 오퍼레이터는 버퍼링된 각 이미지에 대해 여러 관심 영역(ROI)을 지원합니다. imaFlex 플랫폼용 툴 요소인 사용자 라이브러리 요소 ImageBufferMultiRoI는 imaFlex 플랫폼에서 지원되지 않는 VisualApplets 표준 오퍼레이터 ImageBufferMultiRoI와 동일한 기능을 제공합니다.

  • ImageBufferMultiRoIDyn: 이 오퍼레이터는 버퍼링된 각 이미지에 대해 여러 동적 관심 영역(ROI)을 지원합니다. imaFlex 플랫폼용 툴 요소인 사용자 라이브러리 요소 ImageBufferMultiRoIDyn은 imaFlex 플랫폼에서 지원되지 않는 VisualApplets 표준 오퍼레이터 ImageBufferMultiRoIDyn과 동일한 기능을 제공합니다.

imaFlex_CXP12_Tools_Advanced User Library

imaFlex_CXP12_Tools_Advanced 사용자 라이브러리에는 다음 요소가 포함되어 있습니다.

  • FrameBufferMultiRoi: 이 오퍼레이터는 버퍼링된 각 이미지에 대해 여러 관심 영역(ROI)을 지원합니다. imaFlex 플랫폼용 툴 요소인 사용자 라이브러리 요소 FrameBufferMultiRoi는 imaFlex CXP-12 플랫폼에서 지원되지 않는 VisualApplets 표준 오퍼레이터 ImageBufferMultiRoI와 동일한 기능을 제공합니다.

  • JPEG_Encoder_Color_iF_Penta: JPEG_Encoder_Color_iF_Penta를 사용하면 8비트 컬러 이미지를 JPEG 이미지로 변환할 수 있습니다.

  • JPEG_Encoder_Color_iF: JPEG_Encoder_Color_iF를 사용하면 8비트 컬러 이미지를 JPEG 이미지로 변환할 수 있습니다.

사용자 라이브러리 요소에 대한 자세한 설명서는 VisualApplets 설치의 Help 패널에서 확인할 수 있습니다. 또한 사용자 라이브러리 요소 사용법을 보여주는 예제도 제공되므로 'Basic Acquisition Examples for Cameras for CoaXPress 12 imaFlex Frame Grabber'를 참조하십시오.