pylon 3D Viewer 개요#
다음 스크린샷은 ‘ pylon 3D Viewer ’의 다양한 구성 요소를 보여줍니다.

이 애플리케이션의 레이아웃은 다음과 같은 주요 영역으로 구성되어 있습니다:
- 메뉴 막대
- 여러 개의 도구 모음
- 좌우 양쪽에 배치 가능한 패널
- 2D 및 3D 하위 창이 포함된 이미지 창 영역
- 하단에 있는 상태 표시줄
메뉴#
File 메뉴#
File 메뉴에서는 다음과 같은 명령을 제공합니다:
- 깊이 및 이미지 데이터 저장 (Ctrl+S): 깊이 및 이미지 데이터와 카메라 설정을 파일에 저장합니다. 다양한 형식을 선택할 수 있습니다. 자세한 내용은 ‘깊이 및 이미지 데이터 저장’을 참조하십시오.
- 종료 (Ctrl+Q종료 (Ctrl+Q): ‘ pylon 3D Viewer ’를 닫습니다.
보기 메뉴#
‘보기’ 메뉴를 사용하여 UI 요소를 표시하거나 숨길 수 있습니다. 이 메뉴는 동적으로 생성되며, 다음 항목에 대한 토글 기능이 포함되어 있습니다:
- 도구 모음 (예: 카메라 선택기, 파일, 카메라 제어, 포인트 선택)
- 패널 (예: 카메라 기능, 픽셀 정보, 설명서, 메시지 로그, 깊이 히스토그램, 깊이 선 그래프)
Camera 메뉴#
Camera 메뉴에서는 다음과 같은 명령을 제공합니다:
- 다시 스캔: 사용 가능한 카메라 목록을 새로 고칩니다.
- 열기 (Ctrl+O): 선택한 카메라를 엽니다.
- 닫기 (Ctrl+L): 활성 카메라를 닫습니다.
- 연속 촬영 (F7): 연속 촬영을 시작합니다.
- 중지 (F8): 이미지 캡처를 중지합니다.
- 자동 이미지 조정: 카메라 매개변수를 자동으로 설정하고 심도 범위를 조정합니다. 이 기능은 지원되는 카메라 모델 및 기능에서만 사용할 수 있습니다.
- 기능 저장: 현재 카메라 기능 설정을 .pfs 파일로 저장합니다. 저장하기 전에 이미지 획득을 중지해야 합니다.
- 기능 불러오기: 이전에 저장된 .pfs 파일에서 카메라 기능 설정을 불러옵니다.
Tools 메뉴#
'도구' 메뉴를 통해 다음 명령을 사용할 수 있습니다. 카메라 모델 및 설치 환경에 따라 일부 항목은 사용할 수 없을 수도 있습니다.
- pylon IP Configurator: GigE 장치용 외부 IP 구성 도구를 시작합니다.
- pylon GigE Optimizer: GigE Vision 카메라용 네트워크 최적화 대화 상자를 엽니다.
- 스테레오 보정 도구: 외부 스테레오 보정 도구를 실행합니다.
- 선택 모드 전환 (Alt+P): 단일 지점 및 이중 지점 선택 모드 간에 전환합니다.
Window 메뉴#
‘창’ 메뉴를 사용하여 이미지 창을 만들고 배열할 수 있습니다.
메뉴에는 일반적으로 다음과 같은 항목들이 포함됩니다:
- 2D 뷰
- 3D 뷰
- 창 배치 및 탐색
사용 가능한 명령어는 다음과 같습니다:
- 새로운 깊이 맵 보기
- 새로운 신뢰도 지도 보기
- 새로운 강도 이미지 보기
- 새로운 포인트 클라우드 보기
- Close
- 모두 닫기
- 타일
- 캐스케이드
- 다음
- 이전
구분선 아래에는 현재 열려 있는 하위 창들의 번호가 매겨진 목록이 메뉴에 표시됩니다. 활성 상태인 하위 창은 표시되어 있습니다.
도움말 메뉴#
‘도움말’ 메뉴를 통해 설명서 및 지원 기능을 이용할 수 있습니다. 카메라 모델에 따라 일부 항목은 사용할 수 없을 수도 있습니다.
- pylon 3D Viewer 도움말 (F1): 뷰어 설명서를 엽니다. 기능이 선택된 경우, 도움말은 해당 기능에 대한 상황에 맞는 내용을 표시합니다.
- Basler 제품 설명서: 연결된 카메라의 제품 설명서를 엽니다.
- 프로그래머 가이드: 연결된 카메라 모델에 대한 프로그래머 가이드를 엽니다.
- 샘플 디렉터리 열기: 프로그래밍 샘플이 들어 있는 폴더를 엽니다.
- 소프트웨어 업데이트 확인: 소프트웨어 업데이트를 위한 Basler 다운로드 페이지를 엽니다.
- 펌웨어 업데이트 확인: 펌웨어 업데이트를 위한 Basler 다운로드 페이지를 엽니다.
- 카메라 펌웨어 업데이트: 브라우저에서 카메라 펌웨어 업데이트 페이지를 엽니다(지원되는 모델에 한함).
- DiagnosticInfo.tar.gz 다운로드: 카메라에서 진단 패키지를 다운로드합니다(지원되는 모델에 한함).
- 릴리스 노트 보기: 사용 가능한 경우 로컬 릴리스 노트를 엽니다.
- pylon 3D Viewer 정보: 버전 및 라이선스 정보가 포함된 대화 상자를 엽니다.
도구 모음#
카메라 선택 도구 모음#
현재 감지된 모든 기기가 표시된 카메라 선택 드롭다운 메뉴가 포함되어 있습니다.
파일 도구 모음#
깊이 및 이미지 데이터를 저장할 수 있는 ‘저장’ 버튼이 있습니다.
카메라 제어 도구 모음#
카메라 명령에 빠르게 접근할 수 있게 해줍니다:
- Open
- Close
- 연속 촬영
- Stop
- 자동 이미지 조정
점 선택 도구 모음#
단일 지점 피킹과 이중 지점 피킹을 전환할 수 있는 ‘피킹 모드 전환’ 기능이 포함되어 있습니다.
창(Panes)#
카메라 기능#
‘카메라 기능’ 창에는 선택한 카메라의 ‘ GenICam ’ 기능 트리가 표시됩니다.
일반적인 사용법:
- 기능 카테고리를 펼치거나 접기.
- 문서 패널에 관련 문서를 표시하려면 기능을 선택하세요.
- 특정 기능에 대한 도움말을 보려면 ++F1++을 누르십시오.
- 읽기 및 편집 기능 (데이터 수집 중에는 편집이 제한될 수 있습니다).
Pixel Information#
‘픽셀 정보’ 창에는 선택된 점의 위치 및 깊이와 관련된 값이 표시됩니다.
단일 지점 모드에서는 이 창에 선택된 하나의 지점에 대한 값이 표시됩니다.
듀얼 포인트 모드에서는 창에 두 지점 간의 차이값이 추가로 표시됩니다(예를 들어, dX, dY, dZ) 및 유클리드 거리.
자세한 내용은 이미지 Windows 을 참조하십시오.
문서#
‘문서’ 창에는 ‘카메라 기능’ 창에서 선택한 기능에 대한 상황에 맞는 정보가 표시됩니다.
Message Log#
'메시지 로그' 창에는 심각도 및 시간 정보가 포함된 애플리케이션 메시지가 표시됩니다. 예를 들면 다음과 같습니다.
- 정보
- 경고
- 중요
이는 연결, 데이터 수집 및 구성 관련 문제를 해결하는 데 유용합니다.
깊이 히스토그램#
‘깊이 히스토그램 ’ 창에는 활성 장면의 현재 깊이 값 분포(히스토그램)가 표시됩니다.
심도 선 그래프#
‘수심 선 그래프’ 창은 선택한 두 지점(이중 지점 모드)을 연결하는 선을 따라 수심 분포를 시각화합니다.
사용자가 선호하는 표시 방식에 따라 ‘깊이 축 반전’ 설정을 선택적으로 사용할 수 있습니다.
Image Window Area#
이미지 창 영역에는 2D 및 3D 하위 창이 포함되어 있습니다. 기본적으로 뷰어는 표준 창 세트를 엽니다.
일반적인 기본 보기는 다음과 같습니다:
- 강도 이미지 보기
- 심도 맵 보기
- 포인트 클라우드 보기
창 레이아웃은 카메라 유형별로 저장됩니다. 동일한 카메라 제품군을 다시 연결하면 이전 레이아웃이 복원됩니다.
모든 창은 ‘보기’ 메뉴를 통해 도킹, 도킹 해제, 숨기기 및 복원할 수 있습니다.
조회수#
포인트 클라우드 보기 (3D)#
깊이 데이터를 3D 포인트 클라우드로 표시합니다.
일반적인 옵션:
- 색상 적용 모드
- 축 표시
카메라 모델 및 데이터에 따라 다음과 같은 색상 처리 옵션이 제공됩니다:
- White
- 강도
- 거리
- Z축
- 자신감의 색
- 채도 색상
깊이 맵 보기 (2D)#
범위/깊이 맵을 2D 이미지로 표시합니다.
일반적인 옵션:
- 색상 복원
- 심도 범위 슬라이더
일반적인 채색 예시:
- 회색
- 무지개
신뢰도 지도 보기 (2D)#
신뢰 구간을 그레이스케일 이미지로 표시합니다.
강도 이미지 보기 (2D)#
카메라의 영상 또는 적외선 이미지 채널을 표시합니다. 사용 가능한 채널은 카메라 모델에 따라 다릅니다.
대표적인 채널로는 다음과 같은 것들이 있습니다:
- 강도 (왼쪽)
- 강도: 오른쪽
- 강도 합산
- 적외선 왼쪽
- 적외선 우측
기타 뷰어 기능#
포인트 선정#
이 뷰어는 2D 및 3D 뷰에서 점 선택 기능을 지원합니다.
- 단일 지점 모드: 검사할 값을 확인하기 위해 하나의 지점을 선택합니다.
- 이중 점 모드: 두 지점을 선택하여 값과 거리를 비교합니다.
바로가기:
- Alt+P: 단일 지점/이중 지점 모드 전환.
- AltAlt+C: 선택한 지점을 지웁니다.
자동 이미지 조정#
자동 이미지 조정 현재 상황을 분석하여 적절한 깊이 범위를 자동으로 설정합니다 (DepthMin, DepthMax) 연결된 카메라에서 지원하는 경우.
상태 표시줄#
상태 표시줄에는 다음과 같은 실행 시 정보가 표시됩니다:
- 현재 FPS
- 지연 시간 (모델에 따라 다름)
- 프레임 ID
- 연결 품질 지표
레이아웃 유지#
뷰어는 창 레이아웃을 저장하고 복원합니다.
- 창의 위치 및 표시 상태
- 2D/3D 뷰 열기 및 배열
- 보기별 설정
레이아웃은 카메라 유형별로 저장되므로, 서로 다른 카메라 제품군 간에 빠르게 전환할 수 있습니다.