콘텐츠로 바로 가기
STAGING SERVER
DEVELOPMENT SERVER

pylon Event Logger#

pylon Event Logger를 사용하면 pylon SDK 또는 Framegrabber SDK를 기반으로 빌드된 소스 애플리케이션의 이벤트 메시지를 캡처하여 문제 해결 및 성능 향상에 활용할 수 있습니다.

현재 Event Logger는 Windows 10/11 64비트 및 Linux Ubuntu 22.04 64비트 운영 체제를 지원합니다. GigE, USB 3.0, CoaXPress 카메라에서 기록한 이벤트를 캡처할 수 있지만, CoaXPress 카메라에 최적화되어 있습니다.

Event Logger는 pylon과 함께 사용하는 보조 패키지로 제공되거나 Framegrabber SDK 설치 프로그램에 통합되어 있습니다. 두 패키지 모두 Basler 웹사이트에서 다운로드할 수 있습니다.

pylon Event Logger 메인 창

사용자 인터페이스 개요#

애플리케이션 메뉴#

다음 명령을 사용할 수 있습니다:

  • Settings: Settings 대화상자를 엽니다.
  • 작업 표시줄 트레이로 최소화: Event Logger를 최소화할 수 있습니다. Event Logger가 계속 실행 중임을 나타내는 아래 아이콘이 정보 트레이에 표시됩니다. 아이콘을 클릭하면 Event Logger가 원래 크기로 복원됩니다.
    pylon Event Logger 정보 트레이 아이콘
  • Quit: Event Logger를 닫습니다.
Settings 대화상자#

pylon Event Logger Settings 메뉴

Settings 대화상자에서 Event Logger의 일반 설정을 구성할 수 있습니다:

  • 메시지 뷰: 이 설정은 새 세션에서만 변경할 수 있습니다.
    • Max. number of messages in view: 메시지 뷰에 표시될 최대 메시지 수를 지정합니다.
  • 파일 설정: 이 설정은 새 세션에서만 변경할 수 있습니다.
    • 파일 이름 접두사: 세션 동안 생성되는 세션 폴더 및 로그 파일의 접두사입니다. 원하는 파일 이름 접두사를 지정하거나 기본 접두사를 그대로 사용할 수 있습니다.
    • 파일 수 및 크기 한도 도달 시 중지: 이 옵션을 활성화하면 지정된 파일 수 및 크기 한도에 도달했을 때 캡처가 중지됩니다. 그렇지 않으면 한도에 도달했을 때 파일이 덮어쓰여집니다. 이로 인해 이전 데이터가 손실될 수 있습니다.
    • 최대 기록 파일 크기 [MB]: 로그 파일의 최대 크기를 메가바이트 단위로 지정합니다.
    • 최대 지원 활성 파일 수: 최대 파일 수를 지정합니다.
  • 로깅 소스: 이 설정은 캡처가 일시 중지되거나 완료된 후에만 변경할 수 있습니다. Event Logger는 EltAppender를 통해 소스 애플리케이션에서 이벤트 메시지를 캡처하며, EltAppender는 네트워크 연결을 사용하여 로그 데이터를 Event Logger로 전송합니다. EltAppender는 다음을 통해 구성할 수 있습니다. properties 파일.
    여기서 변경한 내용은 캡처를 시작할 때 적용됩니다.
    • 포트: 소스 애플리케이션에 연결하는 데 사용되는 네트워크 포트입니다. 기본값은 12320입니다. 소스 애플리케이션의 properties 파일에 정의된 것과 동일한 포트여야 합니다.
    • 호스트 이름 / IP 주소: 이벤트 메시지를 캡처할 소스 애플리케이션을 실행 중인 호스트의 호스트 이름 / IP 주소입니다. 기본값은 localhost입니다.
    • 실행 프로필: 소스 애플리케이션에서 생성되고 pylon Event Logger로 캡처할 수 있는 이벤트 메시지를 결정합니다. 다양한 실행 프로필에 대한 자세한 내용은 다음 섹션을 참조하세요.
실행 프로필#

알림 – 실행 프로필 설정은 소스 애플리케이션의 성능에 영향을 미칠 수 있습니다.

properties 파일 구성에 따라 Event Logger가 대량의 데이터를 캡처하여 성능 저하를 유발하거나 소스 애플리케이션의 응답 시간에 부정적인 영향을 미칠 수 있습니다.

특히 Factory 등 일부 로그 레벨만 캡처하는 프로필에서 Analysis 프로필과 같이 더 많은 로그 레벨을 캡처하는 프로필로 전환할 때 성능 저하가 발생할 수 있습니다.

각 실행 프로필의 뒤에는 로그 레벨과 관련된 기본 설정이 서로 다른 properties 파일이 있습니다. 로그 레벨은 소스 애플리케이션에서 pylon Event Logger로 전송되는 메시지를 정의합니다.

Open Properties File 버튼을 클릭하면 선택한 실행 프로필에 해당하는 properties 파일로 이동합니다.

다음 실행 프로필을 사용할 수 있습니다.

  • User: 이 프로필의 경우 사용자가 직접 properties 파일을 제공해야 합니다. 로깅이 예상대로 작동하도록 하려면 PYLON_LOG_CONFIG 환경 변수를 유효하고 올바르게 구성된 properties 파일로 설정해야 합니다.
  • Default: 충분한 정보 세트를 수신하면서도 양호한 성능을 유지하려면 이 실행 프로필을 사용하는 것이 좋습니다.
  • Analysis: 대부분의 로그 레벨을 캡처합니다. 소스 애플리케이션에 대한 포괄적인 정보를 수신하려는 경우 이 실행 프로필을 선택하세요. 이로 인해 성능에 영향이 미칠 수 있음에 유의하십시오.
  • Factory: FATAL, ERROR 및 WARN 메시지를 기록합니다. 우수한 성능을 보장하려면 이 시작 프로필을 선택하십시오. 단, NOTICE, INFO 또는 DEBUG 로그 레벨에 대한 정보는 제공되지 않습니다.
  • Custom1: 원하는 대로 로그 레벨을 사용자 지정할 수 있습니다.
  • Custom2: 원하는 대로 로그 레벨을 사용자 지정할 수 있습니다.

캡처 메뉴#

다음 명령을 사용할 수 있습니다:

  • Start: 실행 중인 소스 응용 프로그램에서 로그 메시지 캡처를 시작합니다.
  • Start and Launch Logging Source: 이벤트 메시지를 캡처하려는 소스 응용 프로그램을 열고 현재 선택된 launch profile로 캡처를 시작할 수 있습니다. 소스 응용 프로그램은 pylon Event Logger와 동일한 컴퓨터에 설치되어 있어야 합니다.
  • Pause: 이벤트 메시지 캡처를 일시 중지합니다.
  • Open: 저장된 이벤트 메시지가 포함된 파일을 열 수 있습니다. 세션 파일(.pel) 또는 레거시 파일(.log 또는 .txt)일 수 있습니다.
  • Save: 필터 설정 파일 및 세션과 함께 텍스트 파일로 캡처한 이벤트 메시지를 원하는 위치에 저장할 수 있습니다. 기본 폴더 이름은 message file name_current date-current time입니다. 자세한 내용은 Saving Session Data 섹션을 참조하십시오.
  • Clear: 세션을 지웁니다. 즉, 현재 message view에 표시된 모든 이벤트 메시지가 삭제됩니다.

보기 메뉴#

다음 명령을 사용할 수 있습니다:

Navigation View

navigation view를 사용하면 대용량 데이터 세트 중 어떤 섹션을 message view에 로드할지 지정할 수 있습니다.

이 뷰는 주로 message view의 제한(500,000개 메시지)을 초과하는 매우 큰 데이터 세트가 있는 세션에 필요하며, 또는 Event Logger가 그보다 더 많은 메시지를 캡처하고 있지만 더 적은 메시지를 표시하도록 message view를 구성한 경우에 필요합니다.

또한 이 뷰는 전체 데이터 세트를 다루는 global text search를 제공합니다. 이는 message view에 현재 로드된 메시지만 검색할 수 있는 search feature와 대조됩니다.

검색 결과가 발견되면 해당 이진 위치가 뷰에 파란색으로 표시되며, navigation view의 주황색 검색 바를 해당 섹션으로 이동할 수 있습니다.

이를 통해 대용량 데이터 세트에서 분석할 만한 관심 지점을 식별할 수 있습니다.

다음 항목 사용 Scroll to End 버튼을 사용하여 데이터 세트의 메시지 끝으로 이동할 수 있습니다.
Scroll to End 버튼

Activity View#

Activity View

activity view는 message view에 표시된 모든 이벤트 메시지를 선택한 타임베이스의 그래프로 보여줍니다. 기본적으로 WARN, ERROR 및 UNKNOWN 로그 레벨이 표시됩니다.

필요에 따라 표시할 로그 레벨을 선택하거나 선택 해제할 수 있습니다. 모든 레벨의 모든 항목을 보려면 ALL 확인란을 선택하십시오. 로그 레벨은 UNKNOWN(가장 높은 우선순위)에서 DEBUG(가장 낮은 우선순위) 순으로 정렬됩니다.

각 메시지의 델타 타임을 기반으로, 타임베이스는 캡처된 이벤트 메시지가 activity view에 그룹화되는 방식을 결정합니다. 델타 타임은 밀리초 단위입니다. activity view에는 최대 1000개의 항목만 표시할 수 있으므로 Timebase 드롭다운 상자의 일부 옵션은 사용하지 못할 수 있습니다.

Example: 타임베이스를 1초로 설정하고 1000초 동안 캡처한 경우, 즉 델타 타임이 1000입니다. activity view에는 캡처한 매초마다 눈금이 표시됩니다. 계속 캡처하면 1000개 눈금 제한을 초과하게 되며 타임베이스가 다음으로 높은 옵션(여기서는 15초)으로 자동 전환됩니다. 동시에 1초 옵션은 사용할 수 없게 됩니다.

Count 값이 0보다 큰 그래프 항목을 클릭하여 메시지 뷰 항목으로 이동할 수 있습니다. 특정 항목에 둘 이상의 로그 레벨이 적용되고 둘 이상의 로그 레벨이 표시되는 경우, 해당 항목을 클릭하면 메시지 뷰에서 우선순위가 가장 높은 메시지 항목으로 이동합니다.

선택한 타임베이스에 따라 여러 이벤트 메시지가 동일한 그래프 항목에 속할 수 있습니다. 이 경우 그래프 항목을 클릭하면 가장 나중에 발생한 메시지로 이동합니다.

도움말 메뉴#

Event Logger에 대한 일반 정보를 확인하고 Basler Product Documentation에 액세스할 수 있습니다.

도구 모음 버튼#

아이콘 기능
Start Capturing 이벤트 메시지 캡처를 시작합니다.
Pause Capturing 이벤트 메시지 캡처를 일시 중지합니다. 캡처가 일시 중지된 동안 소스 응용 프로그램에서 전송된 모든 메시지는 손실됩니다.
Open File 로그 파일을 열 수 있습니다.
Save File 모든 이벤트 메시지, 강조 표시 및 디스플레이 필터 설정을 포함한 세션 데이터를 세션 폴더에 저장합니다.
Clear Session 메시지 뷰의 모든 메시지를 지웁니다.
Navigation View navigation view를 엽니다/닫습니다.
Activity View activity view를 엽니다/닫습니다.
Settings Settings dialog를 엽니다.
Get Help 설명서를 엽니다.

메시지 보기#

메시지 뷰는 이벤트 메시지가 표시되는 Event Logger의 중심 영역입니다. 각 메시지에 대해 다음 세부 정보를 사용할 수 있습니다.

  • Timestamp
  • Delta Time
  • Thread ID
  • Source
  • Log Level
  • Message Info

Settings dialog에서 5000에서 500000 사이의 범위로 표시할 메시지 수를 구성할 수 있습니다. 항목 수가 더 많은 데이터 세트의 경우 navigation view's orange search bar를 사용하여 메시지를 로드할 데이터 세트의 상대적 위치를 결정할 수 있습니다.

바로 가기 메뉴에서 현재 선택된 행에 대한 다음 옵션을 제공합니다.

  • Set Time Reference: 현재 선택된 메시지를 기준으로 지정할 수 있습니다. 다른 모든 메시지의 델타 타임(delta time)은 이 기준을 바탕으로 계산됩니다.
  • 복사: 현재 선택된 행의 콘텐츠를 복사합니다. 메시지의 일부분만 복사하려면 다음을 클릭하여 텍스트 선택을 활성화하세요. 텍스트 선택 버튼:
    텍스트 선택 버튼
  • Add Display Filter: 마우스 오른쪽 버튼을 클릭한 테이블 셀(Timestamp 또는 Log Level 등)을 기반으로 디스플레이 필터를 생성합니다.
  • Add Highlight Filter: 마우스 오른쪽 버튼을 클릭한 테이블 셀(Timestamp 또는 Log Level 등)을 기반으로 하이라이트 필터를 생성합니다.
  • Show in Activity View: 활동 뷰에서 이벤트 메시지가 발생한 시점을 선택합니다.

메시지 뷰에는 메시지 항목을 관리하는 여러 도구를 제공하는 사이드바가 있습니다.

아이콘 기능
필터 막대 디스플레이 및 하이라이트 필터용 필터 막대를 열거나 닫습니다.
디스플레이 필터 Display Filter 대화 상자를 엽니다.
하이라이트 필터 Highlight Filter 대화 상자를 엽니다.
검색 메시지 뷰 검색을 열거나 닫습니다.
이전 결과로 이동 이전 검색 결과로 이동할 수 있습니다.
다음 결과로 이동 다음 검색 결과로 이동할 수 있습니다.
행으로 이동 메시지 뷰의 특정 행으로 이동할 수 있습니다.
텍스트 줄 바꿈 Message Info 열의 텍스트 줄바꿈을 설정합니다.
끝으로 자동 스크롤 마지막 메시지로 바로 이동할 수 있습니다. 자동 스크롤을 활성화한 상태에서 새 이벤트 메시지가 도착하면 메시지 뷰에 항상 최신 메시지가 표시됩니다.
열 너비 자동 맞춤 열 너비를 기본값으로 재설정할 수 있습니다.
텍스트 선택 열 셀의 텍스트를 선택하여 텍스트 조각을 더 쉽게 복사할 수 있습니다.

상태 표시줄#

상태 표시줄에서 다음 정보를 확인할 수 있습니다.

  • Event Logger 상태

    Status 의미
    캡처 중 Event Logger가 현재 메시지를 캡처하고 있습니다.
    일시 중지됨 캡처가 일시 중지되었습니다.
    열림 로그 파일이 로드되었습니다.
    지워짐 이전 세션이 지워졌습니다.
    저장 메시지가 파일에 저장되는 중입니다.
    여는 중 로그 파일이 로드되는 중입니다.
    로드 중 대용량 로그 파일의 다른 섹션이 메시지 뷰로 로드되는 중입니다.
    검색 중 검색이 진행 중입니다.
    필터링 중 메시지가 필터링되는 중입니다.
  • 메시지 수 (필터링됨/전체)

  • 로그 수준이 ERROR인 메시지 수
  • 현재 선택됨 launch profile
    캡처 중에 현재 프로필을 클릭하고 다른 프로필을 선택하여 변경할 수 있습니다.
    캡처 중 Launch Profile 변경

상태 표시줄에서 notifications view를 열 수도 있습니다.

Notification View

정보 아이콘이 파란색이면 읽어야 할 알림이 있는 것입니다. 알림 뷰를 열려면 정보 아이콘을 클릭하십시오.
Info Icon

pylon Event Logger 사용#

Event Logger가 실행 중인 컴퓨터 또는 네트워크의 다른 호스트 컴퓨터에서 실행되는 응용 프로그램의 이벤트 메시지를 캡처할 수 있습니다. 이를 위해 Event Logger는 EltAppender를 사용하며, 이 어펜더는 소스 응용 프로그램의 로그 데이터를 네트워크 연결을 통해 Event Logger로 전송합니다. EltAppender는 properties file을 통해 구성할 수 있습니다.

보조 패키지를 다운로드하여 설치한 후, Event Logger는 pylon Viewer의 Tools 메뉴에서 사용할 수 있습니다. 이 기능이 올바르게 작동하려면 PYLON_LOG_CONFIG 환경 변수가 유효한 properties file을 이미 가리키고 있는 환경에서 pylon Viewer를 실행해야 합니다.

Tools 메뉴의 pylon Event Logger

Framegrabber SDK와 함께 pylon Event Logger를 사용하려면 Framegrabber SDK installation 중에 이를 선택하십시오.

이벤트 메시지 캡처#

EltAppender를 구성하고 이벤트 메시지 캡처를 시작하는 방법에는 두 가지가 있습니다.

정보

캡처를 시작하기 전에 도구 모음의 다음 버튼을 사용하여 Clear Session 이전 세션을 지워야 합니다.
Clear Session Button

  • EltAppender의 자동 구성

    1. Capture 메뉴에서 Start and Launch Logging Source를 선택합니다.
    2. Open 대화 상자에서 이벤트 메시지를 캡처할 소스 응용 프로그램의 실행 파일을 선택하고 Run을 클릭합니다.
      응용 프로그램이 열리고 캡처가 즉시 시작됩니다.
  • EltAppender의 수동 구성

    1. 실행하려는 호스트에 소스 응용 프로그램을 배포합니다.
    2. 호스트가 원격 컴퓨터인 경우, 로거 구성이 포함된 properties file을 소스 응용 프로그램이 배포된 원격 컴퓨터에 복사합니다.
      속성 파일은 사용자 디렉토리의 다음 폴더에 있습니다: .pylonEventLogger
      Event Logger와 소스 응용 프로그램이 동일한 컴퓨터에 배포된 경우에는 이 작업을 수행할 필요가 없습니다.
    3. 소스 응용 프로그램을 실행하는 컴퓨터에서 다음 환경 변수를 설정합니다: PYLON_LOG_CONFIG 로거 구성이 포함된 속성 파일을 지정합니다.
    4. 이벤트 메시지를 수신할 컴퓨터에서 Event Logger를 시작합니다.
    5. 호스트가 원격 컴퓨터인 경우 Settings 대화 상자를 열고 Port 및 Host name / IP address 설정을 소스 응용 프로그램을 호스팅하는 원격 컴퓨터의 세부 정보로 변경합니다.
      Event Logger와 소스 응용 프로그램이 동일한 컴퓨터에 배포된 경우에는 이 작업을 수행할 필요가 없습니다.
    6. Capture > Start를 클릭하여 캡처를 시작합니다.
    7. 첫 번째 단계에서 배포한 소스 응용 프로그램을 시작합니다.
      Event Logger가 소스 응용 프로그램에 연결되어 이벤트 메시지 캡처를 시작합니다.

캡처를 시작한 후 Event Logger는 사용자 디렉터리에 .pylonEventLogger라는 폴더를 생성합니다. Event Logger는 캡처 세션마다 이 위치에 폴더를 생성하고 해당 세션에서 캡처된 모든 이벤트 메시지가 포함된 로그 파일을 저장합니다. 기본 폴더 이름은 FileNamePrefix_current date-current time입니다. Settings 대화 상자에서 파일 및 폴더 이름 접두사 및 기타 일반 설정을 구성할 수 있습니다.

세션 데이터 저장#

나중에 사용하거나 다른 사람과 공유하기 위해 세션 정보를 보존하려면 세션을 저장할 수 있습니다.

세션을 저장하려면 다음과 같이 하세요.

  1. 다음 항목을 클릭합니다. Save 이전 세션을 지워야 합니다.
    파일 저장 버튼
  2. 세션을 저장할 폴더를 선택합니다.
    이름이 FileNamePrefix_current date-current time인 폴더가 생성됩니다. 여기에는 다음 파일이 포함되어 있습니다.

    • FileNamePrefix[n].txt: 캡처된 모든 이벤트 메시지가 포함된 로그 파일 n
    • displayFilterData.json: 디스플레이 필터 설정이 포함되어 있습니다.
    • highlightFilterData.json: 강조 표시 필터 설정이 포함되어 있습니다.
    • FileNamePrefix.pel: 사용된 필터 목록, 생성된 로그 파일 및 버전 호환성 정보가 포함된 세션 파일

폴더에서 .pel 파일을 열면 필터 및 캡처된 모든 메시지와 함께 세션을 다시 불러올 수 있습니다. 세션을 공유하려면 폴더와 해당 내용을 원하는 수신자에게 보내기만 하면 됩니다.

정보

또한 .txt 및 .log 확장자를 가진 이전 pylon 또는 Framegrabber SDK 버전의 로그 파일도 열 수 있습니다. 이 레거시 모드에서는 구문 분석할 수 없는 메시지가 소스로 "anytext"와 함께 표시됩니다.

이벤트 메시지 필터링#

다양한 필터 기준을 사용하여 표시되는 이벤트 메시지 수를 줄이거나 이벤트 메시지를 강조 표시하여 시인성을 높일 수 있습니다.

구성된 모든 필터는 필터 막대에 표시되며 여기에서 켜고 끌 수 있습니다.

필터 막대

필터 구성#

필터를 생성하고 구성하는 가장 쉬운 방법은 메시지 뷰의 셀을 마우스 우클릭하고 원하는 필터 유형을 선택하는 것입니다. 필터 키, 작업 및 필터 값은 클릭한 셀에서 자동으로 가져옵니다.

예시: 특정 시점에 캡처된 메시지만 보려면 Timestamp를 마우스 우클릭합니다. 바로 가기 메뉴에서 Add Display Filter를 선택합니다. 모든 정보가 이미 입력된 상태로 Display Filter 대화 상자가 열립니다. 이제 확인란을 선택하여 필터를 활성화하기만 하면 됩니다. 결과는 다음과 같습니다.

바로 가기 메뉴에서 생성된 디스플레이 필터

필요한 경우 하위 항목과 논리 연산자를 추가하여 필터를 편집할 수 있습니다.

모든 필터 설정은 세션 폴더의 .json 파일에 저장됩니다. 세션 폴더로 이동하지 않고 필터 설정만 유지하려면 Display Filter 또는 Highlight Filter 대화 상자에서 Export를 클릭하여 내보낼 수도 있습니다. 설정을 가져올 때는 올바른 유형의 .json 파일을 선택해야 합니다. 강조 표시 필터 설정은 Highlight Filter 대화 상자에서만 가져올 수 있으며 디스플레이 필터 설정은 Display Filter 대화 상자에서만 가져올 수 있습니다.

필터를 수동으로 구성하려면 다음과 같이 하세요.

  1. 사이드바에서 Display Filter 또는 Highlight Filter 버튼을 클릭합니다.
    필터 구성 대화상자가 열립니다.
  2. 필터 키, 연산 및 필터 값을 지정하여 첫 번째 필터 조건을 구성합니다.
    필터 값을 입력하려면 텍스트 필드를 클릭합니다. 필터 값은 대소문자를 구분합니다.
  3. Highlight Filter를 구성하는 경우 필터의 색상을 선택합니다.
    기본 색상을 변경하려면 색상 견본을 클릭하고 색상 대화상자에서 색상을 선택합니다.
  4. 원하는 경우 다음 위치를 클릭하여 하위 항목을 추가합니다. Add Child 조건 옆의 버튼입니다.
    Add Child 버튼
    그러면 첫 번째 조건이 이미 추가된 필터 그룹이 생성됩니다. 그룹 이름을 클릭하여 그룹 이름을 변경할 수 있습니다.
    1. 다음 위치를 클릭하여 다른 필터 조건을 추가합니다. Add Item 그런 다음 필터 키, 연산 및 필터 값을 지정합니다.
      Add Filter Item Button
    2. 원하는 연산자를 선택합니다.
  5. 해당 확인란을 선택하여 필터를 활성화합니다.

다음 스크린샷은 INFO 및 NOTICE 로그 레벨의 이벤트 메시지를 강조 표시하는 Highlight Filter 그룹을 보여줍니다.

INFO 및 NOTICE 이벤트 메시지를 강조 표시하는 Highlight Filter

검색 기능#

검색 기능을 사용하면 일반 텍스트 및 쿼리 기반 검색을 실행할 수 있습니다. 검색 문자열이 포함된 이벤트 메시지는 굵게 표시됩니다.

검색 기능

사이드바의 화살표 버튼을 사용하여 현재 선택된 행을 기준으로 다음/이전 검색 결과로 이동할 수 있습니다. 검색 필드에 포커스가 있는 경우 F3/Shift+F3을 사용하여 결과를 탐색할 수도 있습니다.

최근 10개의 검색 기록이 저장되며, 검색 기록에서 다시 실행할 수 있습니다.

검색 결과의 총 개수와 현재 결과의 인덱스가 검색창의 맨 오른쪽에 표시됩니다.

검색 기능은 여러 키워드에 대한 자동완성을 제공합니다. 대소문자 구분 없는 검색 모드를 선택했는지 여부와 관계없이 키워드는 대소문자를 구분합니다.

사용 가능한 키워드: NOTICE, INFO, WARN, DEBUG, ERROR, Timestamp, ThreadID, Source, LogLevel, MessageInfo, Entity, side_down, related_to

쿼리 기반 검색#

쿼리 기반 검색에서는 논리, 수치 및 문자열 기반 연산을 사용하여 메시지 보기의 모든 열에서 검색할 수 있습니다.

텍스트 입력이 백슬래시(\)로 시작하면 쿼리 검색이 자동으로 활성화됩니다. 모든 텍스트 입력에 대해 유효성 검사기는 입력을 구문 분석할 수 있는지 확인합니다. 입력을 구문 분석할 수 있는 경우 검색 텍스트가 녹색으로 바뀝니다. 그렇지 않으면 텍스트에 빨간색 밑줄이 표시됩니다. 유효한 입력 식이 완성되면 Enter 키를 눌러 검색을 시작합니다.

설명 Operator
Equals ==
And &&
Or ||
Not !
Greater >
Greater equal >=
Less <
Less equal <=
Contains ?
Starts With ^
Ends With $
Group Start (
Group End )
Literal Start/End "
Escape for " \"
Entity Relation side_down
Entity Relation related_to
예제#

로그 수준이 DEBUG이거나 스레드 ID가 12가 아닌 이벤트 메시지를 검색하려면:

\(LogLevel == Debug) || (ThreadId != "12")

로그 수준에 "de" 문자가 포함되어 있고 스레드 ID가 1로 시작하며 2로 끝나는 이벤트 메시지를 검색하려면:

\(LogLevel ? de) && (ThreadId ^ 1) && (ThreadId $ 2)

고급 사용법#

속성 파일#

캡처를 시작한 후 Event Logger는 사용자 디렉터리에 .pylonEventLogger라는 폴더를 생성합니다. 이 폴더에는 다음과 같은 속성 파일이 포함되어 있습니다.

  • profileAnalysis.x.x.x.properties
  • profileCustom1.x.x.x.properties
  • profileCustom2.x.x.x.properties
  • profileDefault.x.x.x.properties
  • profileFactory.x.x.x.properties

x.x.x는 Event Logger의 버전을 나타냅니다.

이 파일들을 사용하여 소스 애플리케이션의 동작을 변경할 수 있습니다. 파일에는 변경할 수 있는 설정에 대한 설명이 포함되어 있습니다. 예를 들어, 소스 애플리케이션이 메시지를 전송하는 로그 레벨을 지정할 수 있습니다. 이를 통해 Event Logger가 관련 없는 이벤트 메시지로 가득 차는 것을 방지할 수 있습니다.

명령줄 인터페이스#

Event Logger의 GUI 도구를 사용하는 것 외에도 다음과 같은 명령줄 옵션을 사용할 수 있습니다.

인수 동작
-h, --help 명령줄 옵션에 대한 도움말을 표시합니다.
-m, --minimize 최소화된 모드로 애플리케이션을 시작합니다. 이 기능은 트레이 모드를 지원하는 운영 체제에서만 사용할 수 있습니다.
-l, --load 시작 시 로드할 로그 파일을 결정합니다(확장자가 .pel인 세션 파일 및 확장자가 .txt 또는 .log인 레거시 파일).
-c, --capture 캡처 모드로 애플리케이션을 시작합니다.
-w, --write_properties 속성 파일을 작성하고 애플리케이션을 종료합니다. 기존 속성 파일은 덮어쓰지 않습니다.