콘텐츠로 건너뛰기
STAGING SERVER
DEVELOPMENT SERVER

pylon Viewer 개요#

pylon Viewer는 그래픽 사용자 인터페이스를 사용하여 대부분의 카메라 파라미터 설정을 확인하고 변경할 수 있는 애플리케이션입니다.

pylon Viewer는 Basler pylon Software Suite의 일부입니다. Windows, Linux 및 macOS에서 사용할 수 있습니다.

메인 창#

pylon Viewer 메인 창

File 메뉴#

File 메뉴를 사용하여 pylon Viewer를 종료하고 현재 이미지를 저장할 수 있습니다. 이미지는 다음 형식으로 저장할 수 있습니다:

  • Bitmap
  • Tiff
  • jpg
  • png
  • raw
  • dng

View 메뉴#

View 메뉴에서는 다음과 같은 명령을 제공합니다:

  • Zoom In: 이미지 크기를 확대합니다.
  • Zoom Out: 이미지의 축소 비율을 조절합니다.
  • Zoom to Fit: 이미지를 디스플레이 영역에 맞게 조절합니다.
  • Zoom 100%: 이미지를 원래 크기로 복원합니다.
  • Full Screen: 이미지를 전체 화면 모드로 표시합니다.
  • Tile: 탭 형태의 이미지 창 레이아웃을 타일 보기로 전환할 수 있습니다.
  • Clear Message Log: Message Log 창의 모든 메시지를 지웁니다.
  • Show/Hide Crosshair: 이미지 디스플레이 영역에 십자선(crosshair)을 표시하거나 숨깁니다.
  • Show/Hide Grid: 이미지 디스플레이 영역에 격자(grid)를 표시하거나 숨깁니다.

Camera 메뉴#

Camera 메뉴에서는 카메라를 작동하고, 카메라 설정을 조작하거나, 자동으로 감지되지 않은 GigE 카메라를 추가하는 명령을 제공합니다.

  • Open Device: 장치를 엽니다. 즉, 장치를 사용할 수 있는 상태로 만듭니다.
  • Close Device: 장치를 닫습니다.
  • Single Shot: 단일 이미지를 캡처합니다.
  • Continuous Shot: 카메라가 연속으로 이미지를 캡처하도록 합니다.
  • Stop: 이미지 캡처 또는 녹화를 중지합니다.
  • Pause: 녹화를 일시 중지합니다.
  • Record: 동영상을 녹화합니다. 녹화는 현재 설정으로 시작됩니다. 설정을 변경하려면 Window 메뉴를 통해 Recording Settings 창을 엽니다.
  • Save Features: 현재 카메라 기능 설정을 .pfs 파일에 저장합니다. ".pfs" 확장자는 "pylon feature stream"을 의미합니다.
  • Load Features: 이전에 저장된 카메라 기능 설정이 포함된 .pfs 파일을 불러옵니다. ".pfs" 확장자는 "pylon feature stream"을 의미합니다.
  • File Access: 예를 들어 User Sets을 업로드하거나 다운로드하기 위해 카메라의 파일 시스템에 대한 액세스를 제공합니다.
  • Copy Camera Features: 모든 카메라 기능의 현재 설정을 클립보드에 복사합니다. 이를 통해 다른 컨텍스트에서 사용할 수 있습니다.
  • Add Remote GigE Camera: IP 주소를 입력하여 GigE 카메라를 추가합니다. 이는 네트워크에 없어서 자동으로 감지되지 않는 카메라를 추가하려는 경우에 유용합니다.
  • Automatic Image Adjustment: 자동 이미지 조정을 수행합니다.
  • Static Defect Pixel Correction: 결함 픽셀을 보정합니다.
  • Vignetting Correction: 이미지에서 비네팅 아티팩트를 제거합니다.

Tools 메뉴#

Tools 메뉴를 통해 다양한 도구와 Options 대화 상자에 액세스할 수 있습니다.

도구

옵션

  • General: pylon Viewer를 사용자 정의하고 온라인 도움말과 오프라인 도움말 중 사용할 버전을 선택할 수 있습니다.
  • Language: pylon Viewer, pylon IP Configurator 및 pylon USB Configurator의 언어를 변경할 수 있습니다. 사용 가능한 언어는 간체 중국어, 영어, 일본어, 한국어입니다.
  • Camera Emulation: pylon Viewer에서 사용할 수 있는 카메라 에뮬레이션 장치의 수를 지정할 수 있습니다.
  • Crosshair: 십자선의 외형을 수정할 수 있습니다.
  • Grid: 격자의 외형을 수정할 수 있습니다.

Workbench 메뉴#

Workbench 메뉴를 사용하면 이미지 처리 디자인을 생성하기 위한 레시피를 만들고 저장할 수 있습니다.

Window 메뉴#

Window 메뉴를 사용하여 Devices 창이나 Histogram 창 등 표시할 창을 선택하거나 선택 해제할 수 있습니다.

Help 메뉴#

Help 메뉴를 사용하여 pylon 애플리케이션에 대한 피드백을 제출하고, Basler 지원팀에 문의하며, 버전 및 데이터 개인정보 보호 정보 등 pylon Viewer에 대한 일반 정보를 볼 수 있습니다. 또한 Basler Product Documentation, pylon Deployment Guide, pylon SDK Samples Manual, pylon API documentation, C++ Data Processing Programmer's Guide 및 vTool Licensing 정보 개요에 액세스할 수 있습니다.

툴바 버튼#

아이콘 기능
Open Device 아이콘 현재 선택된 장치를 열거나 닫습니다.
Save 아이콘 현재 이미지를 저장합니다.
Single Shot 아이콘 단일 이미지를 캡처합니다.
Continuous Shot 아이콘 연속해서 이미지를 캡처합니다.
Stop 아이콘 이미지 캡처를 중지하거나 녹화를 중지합니다.
Pause 아이콘 녹화를 일시 중지합니다.
Record 아이콘 현재 설정으로 녹화를 시작합니다. 설정을 변경하려면 Window 메뉴에서 Recording Settings 창을 엽니다.
Zoom In 아이콘 이미지를 확대합니다.
Zoom Out 아이콘 이미지를 축소합니다.
Zoom to Fit 아이콘 이미지가 이미지 표시 영역에 맞도록 조절합니다.
Zoom 100% 아이콘 이미지를 원래 크기로 복원합니다.
Full Screen 아이콘 이미지를 전체 화면 모드로 표시합니다.
Tile Mode 아이콘 탭 형식의 이미지 창 레이아웃을 타일 보기로 전환할 수 있습니다.
Crosshair 아이콘 이미지 표시 영역에서 십자선을 표시하거나 숨깁니다.
Grid 아이콘 이미지 표시 영역에서 격자를 표시하거나 숨깁니다.
Histogram 아이콘 Histogram 창을 열거나 닫습니다.
Sharpness Indicator 아이콘 Sharpness Indicator 창을 열거나 닫습니다.
Automatic Image Adjustment 아이콘 현재 조건에서 양질의 이미지를 얻는 데 필요한 모든 설정을 카메라가 자동으로 수행하도록 합니다.
Workbench 아이콘 Workbench 창을 엽니다/닫습니다.

창#

pylon Viewer는 장치 작업, 장치 및 기능에 대한 정보 제공, pylon Workbench를 사용한 이미지 처리 디자인 생성을 위한 다양한 창을 제공합니다. pylon Viewer의 기본 레이아웃에 포함된 창은 아래에 나열되어 있습니다. Workbench 관련 창에 대한 설명은 Overview of the Workbench를 참조하십시오.

장치 창#

Devices pane에는 컴퓨터에 연결된 모든 카메라가 인터페이스 유형별로 그룹화되어 나열되는 장치 트리가 표시됩니다. 표시되는 인터페이스는 pylon Software Suite 설치 중에 선택한 옵션에 따라 다릅니다. 예를 들어 Basler boost, ace, pulse, ace 카메라와 camera emulation 장치가 위 스크린샷에 표시되어 있습니다. Show Cameras Only 옵션을 사용하면 인터페이스 정보 없이 카메라만 표시할 수 있습니다.

이 창에서는 최근에 연결된 장치를 정기적으로 자동 스캔할지 여부도 선택할 수 있습니다. 또는 Refresh 버튼을 클릭하여 장치 트리를 수동으로 새로 고칠 수 있습니다.

새로 고침 아이콘

기능 창#

Features pane에는 Devices pane에서 선택한 카메라의 기능이 표시됩니다. 기본적으로 두 개의 탭이 포함되어 있습니다.

  • Features – All: 이 창에는 현재 선택한 카메라에서 사용할 수 있는 모든 기능이 나열됩니다. 여기에서는 자주 필요하거나 특정 작업에 필요한 기능을 그룹화하는 옵션도 제공됩니다. 수행 방법에 대한 지침은 아래의 To group features를 참조하십시오.
  • Features – Basic: 이 탭에는 카메라를 빠르게 설정할 수 있는 간소화된 기능 세트가 포함되어 있습니다.

기능을 그룹화하려면:

  1. Edit Feature Tabs 버튼을 클릭합니다.
  2. Edit Feature Tabs 대화상자에 새 탭의 이름을 입력합니다.
  3. Features pane에서 원하는 기능을 드래그하여 Edit Feature Tabs 대화상자에 놓습니다.
  4. 기능 추가가 완료되면 OK를 클릭합니다.

새 기능 탭이 pylon Viewer에 표시됩니다. 다른 탭처럼 도킹하거나 플로팅 상태로 둘 수 있습니다. 새 탭은 Window 메뉴에도 추가됩니다.

이 사용자 지정 탭은 모든 카메라 모델에 사용할 수 있습니다. 즉, ace 카메라용 탭을 만들어 ace 카메라로 작업할 때 사용할 수 있습니다. 이러한 카메라 모델의 기능 세트는 서로 다르므로, ace 모델을 사용할 때는 ace 카메라에서 사용할 수 있는 기능이 표시되지 않습니다. 이러한 사용할 수 없는 기능을 보려면 Show Unavailable Features 확인란을 선택하십시오.

사용자가 만든 기능 탭은 변경할 수 있습니다. 기능을 추가하거나 삭제하고 탭의 이름을 변경할 수 있습니다. Features – All 및 Features – Basic 탭은 편집할 수 없습니다.

기능 탭을 편집하려면:

  1. Edit Feature Tabs 버튼을 클릭합니다.
  2. Edit Feature Tabs 대화상자에서 편집하려는 탭을 선택합니다.
  3. 원하는 대로 변경합니다.
  4. OK를 클릭합니다.

Features – All 탭의 또 다른 기능은 Common Tasks 드롭다운 목록입니다. 해상도 변경이나 이미지 품질 최적화 등 다양한 일반적인 작업을 신속하게 완료할 수 있도록 설계되었습니다. 작업 중 하나를 선택하면 기능 트리에서 관련 기능이 강조 표시됩니다.

Polling 옵션을 사용하면 일정한 간격으로 카메라를 자동으로 폴링할 수 있습니다. 또는 Refresh 버튼을 클릭하여 기능 목록을 수동으로 새로 고칠 수 있습니다.

새로 고침 아이콘

이미지 표시 영역#

카메라로 촬영한 이미지와 비디오가 여기에 표시됩니다. 현재 열려 있는 각 카메라마다 하나의 이미지 창 탭이 있습니다. 하단에는 캡처 중인 이미지나 녹화 중인 비디오에 대한 정보를 제공하는 상태 표시줄이 있습니다. 카메라를 배치할 때 시각적 보조 도구로 십자선 및 격자를 표시할 수 있습니다.

도구 모음에서 Full Screen 버튼을 클릭하면 이미지를 전체 화면 모드로 표시할 수 있습니다.

전체 화면 버튼

전체 화면 이미지를 두 번째 화면으로 이동하려면 이미지 내부를 마우스 우클릭한 다음 Screen #2를 클릭하세요. 그러면 이미지가 두 번째 화면으로 이동합니다.

기능 문서 창#

Feature Documentation 창에는 Features 창에서 현재 선택한 기능에 대한 정보가 표시됩니다. 기능 설명은 다양한 언어로 제공됩니다. Language 드롭다운 목록에서 원하는 언어를 선택하세요.

기능 Property 창#

Feature Properties 창에는 Features 창에서 현재 선택한 파라미터에 대한 정보가 표시됩니다. 처음에는 최소화된 상태로 pylon Viewer의 오른쪽에 도킹되어 표시됩니다.

메시지 로그 창#

Message Log 창에는 카메라 열기 및 닫기, 녹화 시작 등 pylon Viewer에서 수행된 작업에 대한 정보가 표시됩니다. 메시지 수준에는 Information, Warning, Critical이 있습니다. 처음에는 최소화된 상태로 pylon Viewer의 오른쪽에 도킹되어 표시됩니다.

창 추가 및 제거#

Window 메뉴를 통해 표시할 창을 더 선택할 수 있습니다. 기본적으로 일부 창은 pylon Viewer의 오른쪽에 도킹되며, 나머지는 플로팅 상태로 표시됩니다.

창을 닫으려면 제목 표시줄을 우클릭하고 Close를 클릭하세요.

창 재배치#

창의 도킹을 해제하려면:

  1. 창의 제목 표시줄을 클릭하여 원하는 위치로 드래그하거나 플로팅 상태로 두세요.

창을 도킹하려면:

  1. 창 드래그를 시작합니다.
    위치 지정 도구가 나타납니다.
    위치 지정 도구
  2. 마우스 커서로 창을 놓을 위치를 가리킵니다.
    원하는 창 영역이 파란색으로 강조 표시됩니다.
  3. 창을 놓습니다.

다음 애니메이션은 이를 보여줍니다.

창 재배치 방법 애니메이션

이와 같이 pylon Viewer 창을 완전히 사용자 지정하고 원하는 대로 창을 재배치할 수 있습니다.

창을 닫으려면 Window 메뉴에서 해당 창의 선택을 해제하세요.