콘텐츠로 바로 가기
STAGING SERVER
DEVELOPMENT SERVER

pylon Viewer 개요#

pylon Viewer는 그래픽 사용자 인터페이스를 사용하여 대부분의 카메라 매개변수 설정을 확인하고 변경할 수 있는 응용 프로그램입니다.

pylon Viewer는 Basler pylon Software Suite의 일부입니다. Windows, Linux 및 macOS에서 사용할 수 있습니다.

Main Window#

pylon Viewer 기본 창

File 메뉴#

File 메뉴를 사용하여 pylon Viewer를 종료하고 현재 이미지를 저장할 수 있습니다. 이미지는 다음 형식으로 저장할 수 있습니다.

  • Bitmap
  • Tiff
  • jpg
  • png
  • raw
  • dng

보기 메뉴#

View 메뉴에서는 다음과 같은 명령을 제공합니다.

  • Zoom In: 이미지의 확대 비율을 높입니다.
  • Zoom Out: 이미지의 확대 비율을 낮춥니다.
  • Zoom to Fit: 이미지를 이미지 표시 영역에 맞게 조절합니다.
  • Zoom 100%: 이미지 크기를 원래 크기로 복원합니다.
  • 전체 화면: 이미지를 전체 화면 모드로 표시합니다.
  • 바둑판식 배열: 탭으로 정렬된 이미지 창 레이아웃을 바둑판식 보기로 전환할 수 있습니다.
  • 메시지 로그 지우기: Message Log 창의 모든 메시지를 지웁니다.
  • 십자선 표시/숨기기: 이미지 표시 영역에서 십자선을 표시하거나 숨깁니다.
  • 격자 표시/숨기기: 이미지 표시 영역에서 격자를 표시하거나 숨깁니다.

Camera 메뉴#

Camera 메뉴를 통해 카메라를 작동하고, 카메라 설정을 조작하거나, 자동으로 감지되지 않은 GigE 카메라를 추가하는 명령을 사용할 수 있습니다.

  • Open Device: 장치를 엽니다. 즉, 장치를 사용할 수 있는 상태로 만듭니다.
  • Close Device: 장치를 닫습니다.
  • Single Shot: 단일 이미지를 캡처합니다.
  • Continuous Shot: 카메라가 이미지를 연속적으로 캡처하도록 합니다.
  • Stop: 이미지 캡처 또는 녹화를 중지합니다.
  • Pause: 녹화를 일시 정지합니다.
  • Record: 비디오를 녹화합니다. 녹화는 현재 설정으로 시작됩니다. 설정을 변경하려면 Window 메뉴를 통해 Recording Settings 창을 엽니다.
  • Save Features: 카메라 기능의 현재설정을 .pfs 파일에 저장합니다. ".pfs" 확장명은 "pylon feature stream"을 의미합니다.
  • Load Features: 이전에 저장된 카메라 기능 설정이 포함된 .pfs 파일을 로드합니다. ".pfs" 확장명은 "pylon feature stream"을 의미합니다.
  • File Access: 예를 들어 user sets을(를) 업로드하거나 다운로드하기 위해 카메라의 파일 시스템에 대한 액세스를 제공합니다.
  • Copy Camera Features: 모든 카메라 기능의 현재 설정을 클립보드에 복사합니다. 이를 통해 다른 컨텍스트에서 해당 설정을 사용할 수 있습니다.
  • Add Remote GigE Camera: IP 주소를 입력하여 GigE 카메라를 추가합니다. 네트워크에 없어서 자동으로 감지되지 않는 카메라를 추가하려는 경우에 유용합니다.
  • Automatic Image Adjustment: 자동 이미지 조정을 수행합니다.
  • Static Defect Pixel Correction: 결함 픽셀을 보정합니다.
  • Vignetting Correction: 이미지에서 비네팅 아티팩트를 제거합니다.

Tools 메뉴#

Tools 메뉴를 통해 다양한 도구와 Options 대화 상자에 액세스할 수 있습니다.

도구

Options

  • General: pylon Viewer를 사용자 지정하고 도움말의 온라인 버전 또는 오프라인 버전 중 사용할 버전을 선택할 수 있습니다.
  • Language: pylon Viewer, pylon IP Configurator 및 pylon USB Configurator의 언어를 변경할 수 있습니다. 사용 가능한 언어는 간체 중국어, 영어, 일본어, 한국어입니다.
  • Camera Emulation: pylon Viewer에서 사용할 수 있는 camera emulation devices의 개수를 지정할 수 있습니다.
  • Crosshair: crosshair의 모양을 수정할 수 있습니다.
  • Grid: grid의 모양을 수정할 수 있습니다.

Workbench 메뉴#

Workbench 메뉴에서는 creating image processing designs을 위한 recipes를 생성하고 저장할 수 있습니다.

Window 메뉴#

Window 메뉴를 사용하면 Devices 창이나 Histogram 창 등 표시할 panes를 선택하거나 선택 해제할 수 있습니다.

도움말 메뉴#

Help 메뉴를 사용하여 pylon 애플리케이션에 대한 피드백을 제출하고, Basler 지원팀에 문의하며, 버전 및 데이터 개인 정보 보호 정보와 같은 pylon Viewer에 대한 일반 정보를 볼 수 있습니다. 또한 Basler Product Documentation, pylon Deployment Guide, pylon SDK Samples Manual, pylon API documentation, C++ Data Processing Programmer's Guide 및 vTool Licensing 정보 개요에 액세스할 수 있습니다.

도구 모음 버튼#

아이콘 기능
Open Device 아이콘 현재 선택된 장치를 Opens/closes합니다.
저장 아이콘 현재 이미지를 저장합니다.
단일 이미지 캡처 아이콘 단일 이미지를 캡처합니다.
Continuous Shot 아이콘 영상을 연속으로 캡처합니다.
정지 아이콘 이미지 캡처를 중지하거나 녹화를 중지합니다.
일시 중지 아이콘 recording을 일시 중지합니다.
Record 아이콘 현재 설정으로 recording을 시작합니다. 설정을 변경하려면 Window 메뉴를 통해 Recording Settings 창을 엽니다.
확대 아이콘 이미지를 확대합니다.
축소 아이콘 이미지를 축소합니다.
화면에 맞추기 아이콘 이미지가 이미지 표시 영역에 맞도록 조정합니다.
100% 확대 아이콘 이미지를 원래 크기로 복원합니다.
전체 화면 아이콘 이미지를 전체 화면 모드로 표시합니다.
타일 모드 아이콘 이미지 창의 탭 형식을 타일 보기로 전환할 수 있습니다.
조준선 아이콘 이미지 표시 영역에서 십자선을 표시하거나 숨깁니다.
격자 아이콘 이미지 표시 영역에 격자를 표시하거나 숨깁니다.
히스토그램 아이콘 히스토그램 창을 열거나 닫습니다.
Sharpness Indicator 아이콘 선명도 표시기 창을 열거나 닫습니다.
Automatic Image Adjustment 아이콘 카메라가 현재 환경에서 선명한 이미지를 얻기 위해 필요한 모든 설정을 자동으로 조정합니다.
Workbench 아이콘 다음 Workbench 패널을 엽니다/닫습니다.

창(Panes)#

pylon Viewer 는 pylon Workbench 을 사용하여 장치를 관리하고, 장치 및 기능에 대한 정보를 확인하며, 이미지 처리 설계를 생성할 수 있는 다양한 패널을 제공합니다. pylon Viewer 의 기본 레이아웃에 포함된 패널은 다음과 같습니다. Workbench 관련 패널에 대한 설명은 Workbench 의 개요를 참조하십시오.

Devices Pane#

‘장치’ 창에는 컴퓨터에 연결된 모든 카메라가 인터페이스 유형별로 그룹화되어 나열된 장치 트리가 표시됩니다. 표시되는 인터페이스는 ‘ pylon Software Suite ’ 설치 과정에서 선택한 옵션에 따라 달라집니다. 예를 들어, 위 스크린샷에는 Basler boost, ace 2, pulse, ace 카메라와 카메라 에뮬레이션 장치가 표시되어 있습니다. ‘카메라만 표시’ 옵션을 사용하면 인터페이스 정보 없이 카메라만 표시할 수 있습니다.

이 창에서는 최근에 연결된 장치를 일정 간격으로 자동 검색할지 여부를 선택할 수도 있습니다. 또는 [ 새로 고침 ] 버튼을 클릭하여 장치 트리를 수동으로 새로 고칠 수도 있습니다:

새로 고침 아이콘

Features Pane#

‘기능’ 창에는 ‘장치’ 창에서 선택한 카메라의 기능이 표시됩니다. 기본적으로 이 창에는 다음 두 개의 탭이 있습니다:

  • 기능 – 전체: 이 창에는 현재 선택된 카메라에서 사용할 수 있는 모든 기능이 나열됩니다. 또한 여기에서 자주 사용하거나 특정 작업에 필요한 기능을 그룹으로 묶을 수도 있습니다. 이에 대한 방법은 아래의 ‘기능 그룹화하기’를 참조하십시오.
  • 기능 – 기본: 이 탭에는 카메라를 빠르게 설정할 수 있도록 핵심 기능만 포함되어 있습니다.

특징을 그룹화하려면:

  1. '기능 탭 편집' 버튼을 클릭합니다.
  2. '피처 탭 편집' 대화 상자에서 새 탭의 이름을 입력합니다.
  3. ‘피처’ 창에서 원하는 피처를 ‘피처 탭 편집’ 대화 상자로 끌어다 놓으십시오.
  4. 기능 추가를 모두 마쳤으면 ‘확인’을 클릭하십시오.

pylon Viewer 에 새로운 기능 탭이 표시됩니다. 이 탭은 다른 탭과 마찬가지로 도킹하거나 떠 있는 상태로 둘 수 있습니다. 또한 이 새로운 탭은 ‘창’ 메뉴에도 추가됩니다.

이 사용자 지정 탭은 모든 카메라 모델에 사용할 수 있습니다. 즉, ace 2 카메라용 탭을 생성한 후 ace 카메라로 작업할 때 이를 사용할 수 있습니다. 각 카메라 모델의 기능 세트가 다르기 때문에, ace 모델을 사용할 때는 ace 2 카메라에서 사용할 수 있는 기능이 표시되지 않습니다. 사용 불가능한 기능을 보려면 ‘사용 불가능한 기능 표시’ 확인란을 선택하십시오.

사용자가 생성한 기능 탭은 변경할 수 있습니다. 기능을 추가하거나, 기능을 삭제하거나, 탭 이름을 변경할 수 있습니다. Features – All 및 Features – Basic 탭은 편집할 수 없습니다.

기능 탭을 편집하려면:

  1. '기능 탭 편집' 버튼을 클릭합니다.
  2. Edit Feature Tabs 대화 상자에서 편집할 탭을 선택합니다.
  3. 원하는 대로 변경합니다.
  4. OK를 클릭합니다.

Features – All 탭의 또 다른 기능은 Common Tasks 드롭다운 목록입니다. 이 기능은 해상도 변경 또는 이미지 Quality 최적화 등 다양한 일반적인 작업을 신속하게 완료할 수 있도록 지원합니다. 작업 중 하나를 선택하면 관련 기능이 기능 트리에서 강조 표시됩니다.

Polling 옵션을 사용하면 정기적인 간격으로 카메라를 자동으로 폴링할 수 있습니다. 또는 Refresh 버튼을 클릭하여 기능 목록을 수동으로 새로 고칠 수도 있습니다.

새로 고침 아이콘

Image Display Area#

카메라로 촬영한 이미지와 비디오가 여기에 표시됩니다. 현재 열려 있는 각 카메라에 대해 하나의 이미지 창 탭이 존재합니다. 하단에는 캡처 중인 이미지나 녹화 중인 비디오에 대한 정보를 제공하는 상태 표시줄이 있습니다. 카메라를 배치할 때 시각적 보조 도구로 십자선 및 그리드를 표시할 수 있습니다.

도구 모음에서 Full Screen 버튼을 클릭하면 이미지를 전체 화면 모드로 표시할 수 있습니다.

전체 화면 버튼

전체 화면 이미지를 두 번째 화면으로 이동하려면 이미지 내부를 마우스 우클릭한 다음 Screen #2를 클릭합니다. 그러면 이미지가 두 번째 화면으로 이동합니다.

Feature Documentation Pane#

Feature Documentation 창에는 Features 창에서 현재 선택한 기능에 대한 정보가 표시됩니다. 기능 설명은 다양한 언어로 제공됩니다. Language 드롭다운 목록에서 원하는 언어를 선택하세요.

Feature Properties Pane#

Feature Properties 창에는 Features 창에서 현재 선택한 매개변수에 대한 정보가 표시됩니다. 초기에는 pylon Viewer의 오른쪽에 최소화된 상태로 도킹되어 나타납니다.

Message Log Pane#

Message Log 창에는 카메라 열기 및 닫기, 녹화 시작 등 pylon Viewer에서 수행된 작업에 대한 정보가 표시됩니다. 메시지 수준은 Information, Warning, Critical 등 다양합니다. 초기에는 pylon Viewer의 오른쪽에 최소화된 상태로 도킹되어 나타납니다.

창 추가 및 제거#

Window 메뉴를 통해 표시할 창을 더 선택할 수 있습니다. 기본적으로 일부 창은 pylon Viewer의 오른쪽에 도킹되고, 다른 창은 플로팅 상태로 표시됩니다.

창을 닫으려면 제목 표시줄을 마우스 우클릭하고 Close를 클릭합니다.

창 재배치#

창의 도킹을 해제하려면:

  1. 창의 제목 표시줄을 클릭하여 원하는 위치로 드래그하거나 플로팅 상태로 둡니다.

창을 도킹하려면:

  1. 창 드래그를 시작합니다.
    위치 지정 보조 도구가 나타납니다.
    위치 지정 보조 도구
  2. 마우스 커서로 창을 놓을 위치를 가리킵니다.
    원하는 창 영역이 파란색으로 강조 표시됩니다.
  3. 창을 놓습니다.

다음 애니메이션은 이를 보여줍니다.

창 재배치 방법 애니메이션

이러한 방식으로 pylon Viewer 창을 완전히 사용자 지정하고 원하는 대로 창을 재배치할 수 있습니다.

창을 닫으려면 Window 메뉴에서 해당 창의 선택을 취소하십시오.