콘텐츠로 건너뛰기
STAGING SERVER
DEVELOPMENT SERVER

pylon 3D Viewer 개요#

이 항목에서는 blaze, Stereo ace, Stereo mini와 같은 Basler 3D 카메라를 지원하는 pylon 3D Viewer의 사용자 인터페이스에 대한 개요를 제공합니다.

다음 스크린샷은 pylon 3D Viewer의 다양한 요소를 보여줍니다.

pylon 3D Viewer 사용자 인터페이스

애플리케이션 레이아웃은 다음과 같은 주요 영역으로 구성됩니다.

  • 메뉴 바
  • 여러 툴바
  • 좌측과 우측의 도킹 가능한 창
  • 2D 및 3D 하위 창이 포함된 이미지 창 영역
  • 하단의 상태 표시줄

File 메뉴#

File 메뉴에서 제공하는 명령:

  • Save Depth and Image Data (Ctrl+S): 깊이 및 이미지 데이터와 카메라 설정을 파일로 저장합니다. 다양한 형식을 사용할 수 있습니다. 자세한 내용은 Saving Depth and Image Data를 참조하세요.
  • Exit (Ctrl+Q): pylon 3D Viewer를 닫습니다.

View 메뉴#

View 메뉴를 사용하여 UI 요소를 표시하거나 숨깁니다. 이 메뉴는 동적으로 생성되며 다음 항목에 대한 전환 항목을 포함합니다.

  • 도구 모음(예: Camera Selector, File, Camera Control, Point Picking)
  • 창(예: Camera Features, Pixel Information, Documentation, Message Log, Depth Histogram, Depth Line Plot)

Camera 메뉴#

Camera 메뉴에서 제공하는 명령:

  • Rescan: 사용 가능한 카메라 목록을 업데이트합니다.
  • Open (Ctrl+O): 선택한 카메라를 엽니다.
  • Close (Ctrl+L): 활성 카메라를 닫습니다.
  • Continuous Shot (F7): 연속 취득을 시작합니다.
  • Stop (F8): 이미지 취득을 중지합니다.
  • Automatic Image Adjustment: 카메라 파라미터를 자동으로 설정하고 깊이 범위를 조정합니다. 이 기능은 지원되는 카메라 모델 및 기능에서만 사용할 수 있습니다.
  • Save Features: 현재 카메라 Property 설정을 .pfs 파일에 저장합니다. 저장하기 전에 이미지 취득을 중지해야 합니다.
  • Load Features: 이전에 저장된 .pfs 파일에서 카메라 Property 설정을 불러옵니다.

Tools 메뉴#

Tools 메뉴를 통해 다음 명령을 사용할 수 있습니다. 카메라 모델 및 설치 상태에 따라 일부 항목은 사용하지 못할 수 있습니다.

  • pylon IP Configurator: GigE 장치용 외부 IP 설정 도구를 시작합니다.
  • pylon GigE Optimizer: GigE Vision 카메라용 네트워크 최적화 대화 상자를 엽니다.
  • Stereo Calibration Tool: 외부 스테레오 캘리브레이션 도구를 시작합니다.
  • Toggle Pick Mode (Alt+P): 단일 포인트와 이중 포인트 픽킹 모드 사이를 전환합니다.

Window 메뉴#

Window 메뉴를 사용하여 이미지 창을 만들고 정렬합니다.

이 메뉴는 일반적으로 다음 섹션을 포함합니다.

  • 2D Views
  • 3D 뷰
  • 창 배치 및 탐색

사용 가능한 명령은 다음과 같습니다.

  • 새 Depth Map View
  • 새 Confidence Map View
  • 새 Intensity Image View
  • 새 Point Cloud View
  • Close
  • 모두 닫기
  • 바둑판식 배열
  • 계단식 배열
  • 다음
  • 이전

구분선 아래에는 현재 열려 있는 하위 창들의 번호 매기기 목록이 표시됩니다. 활성 하위 창에는 표시가 나타납니다.

Help 메뉴#

Help 메뉴를 통해 문서 및 지원 기능에 액세스할 수 있습니다. 카메라 모델에 따라 일부 항목은 지원되지 않을 수 있습니다.

  • pylon 3D Viewer Help (F1): 뷰어 문서를 엽니다. 기능을 선택한 경우 해당 기능에 대한 문맥별(Context-sensitive) 도움말이 열립니다.
  • Basler Product Documentation: 연결된 카메라의 제품 문서를 엽니다.
  • Programmer's Guide: 연결된 카메라 모델의 프로그래머 가이드를 엽니다.
  • Open Samples Directory: 프로그래밍 샘플이 포함된 폴더를 엽니다.
  • Check for Software Updates: 소프트웨어 업데이트를 위한 Basler 다운로드 페이지를 엽니다.
  • Check for Firmware Updates: 펌웨어 업데이트를 위한 Basler 다운로드 페이지를 엽니다.
  • Update Camera Firmware: 브라우저에서 카메라 펌웨어 업데이트 페이지를 엽니다(지원되는 모델에만 해당).
  • Download DiagnosticInfo.tar.gz: 카메라에서 진단 패키지를 다운로드합니다(지원되는 모델에만 해당).
  • Show Release Notes: 사용 가능한 경우 로컬 릴리스 노트를 엽니다.
  • About pylon 3D Viewer: 버전 및 라이선스 정보가 포함된 대화 상자를 엽니다.

Toolbars#

Camera Selector Toolbar#

현재 감지된 모든 장치가 포함된 카메라 선택 드롭다운이 있습니다.

File Toolbar#

깊이 및 이미지 데이터를 저장하기 위한 Save 버튼이 포함되어 있습니다.

Camera Control Toolbar#

카메라 명령에 빠르게 액세스할 수 있습니다:

  • Open
  • Close
  • Continuous Shot
  • Stop
  • 자동 이미지 조정

Point Picking Toolbar#

단일 포인트 피킹과 듀얼 포인트 피킹 간에 전환할 수 있는 Toggle Pick Mode가 포함되어 있습니다.

창#

Camera Features#

Camera Features 창에는 선택한 카메라의 GenICam feature 트리가 표시됩니다.

일반적인 사용법:

  • feature 카테고리를 확장하거나 접습니다.
  • feature를 선택하여 Documentation 창에서 컨텍스트 문서를 확인합니다.
  • feature별 도움말을 보려면 ++F1++을 누르십시오.
  • feature를 읽고 편집합니다(취득 중에는 편집이 제한될 수 있음).

Pixel Information#

Pixel Information 창에는 피킹된 포인트의 위치 및 깊이 관련 값이 표시됩니다.

단일 포인트 모드에서는 선택한 한 포인트의 값이 창에 표시됩니다.

듀얼 포인트 모드에서는 두 포인트 간의 델타 값(예: dX, dY, dZ)과 유클리드 거리가 추가로 표시됩니다.

자세한 내용은 Image Windows를 참조하십시오.

문서#

Documentation 창에는 Camera Features 창에서 선택한 feature에 대한 컨텍스트 인식 정보가 표시됩니다.

Message Log#

Message Log 창에는 심각도 및 시간 정보가 포함된 애플리케이션 메시지가 표시됩니다(예:

  • 정보
  • 경고
  • Critical

이는 연결, 취득 및 구성 문제를 해결하는 데 유용합니다.

Depth Histogram#

Depth Histogram 창에는 활성 씬의 현재 깊이 값 분포(히스토그램)가 표시됩니다.

Depth Line Plot#

Depth Line Plot 창은 두 포인트 사이의 선을 따라 깊이 프로파일을 시각화합니다(듀얼 포인트 모드).

선호하는 표현 방식에 따라 선택적 Invert Depth Axis 설정을 사용할 수 있습니다.

Image Window Area#

이미지 창 영역에는 2D 및 3D 하위 창이 포함되어 있습니다. 기본적으로 뷰어는 표준 창 세트를 엽니다.

일반적인 기본 뷰는 다음과 같습니다:

  • Intensity Image View
  • Depth Map View
  • Point Cloud View

창 레이아웃은 카메라 유형별로 저장됩니다. 동일한 카메라 제품군에 다시 연결하면 이전 레이아웃이 복원됩니다.

모든 창은 View 메뉴를 통해 도킹, 도킹 해제, 숨기기 및 복원할 수 있습니다.

뷰#

Point Cloud View (3D)#

깊이 데이터를 3D 포인트 클라우드로 표시합니다.

공통 옵션:

  • Colorization mode
  • Show Axes

사용 가능한 컬러화 방식은 카메라 모델 및 데이터에 따라 다음과 같습니다.

  • 흰색
  • Intensity
  • Distance
  • Z Axis
  • Confidence Color
  • Intensity Color

Depth Map View (2D)#

거리/깊이 맵을 2D 이미지로 표시합니다.

공통 옵션:

  • Colorization
  • Depth range slider

일반적인 컬러화 방식:

  • Gray
  • Rainbow

Confidence Map View (2D)#

신뢰도 값을 그레이스케일 이미지로 표시합니다.

Intensity Image View (2D)#

카메라의 강도 또는 적외선 이미지 채널을 표시합니다. 사용 가능한 채널은 카메라 모델에 따라 다릅니다.

일반적인 채널은 다음과 같습니다.

  • Intensity Left
  • Intensity Right
  • Intensity Combined
  • 적외선 좌측
  • 적외선 우측

Other Viewer Functions#

Point Picking#

뷰어는 2D 및 3D 뷰에서 포인트 피킹을 지원합니다.

  • 단일 포인트 모드: 값을 검사할 한 포인트를 선택합니다.
  • 듀얼 포인트 모드: 값과 거리를 비교할 두 포인트를 선택합니다.

단축키:

  • Alt+P: 단일 포인트/듀얼 포인트 모드 전환.
  • Alt+C: 선택한 포인트 지우기.

자동 이미지 조정#

자동 이미지 조정 현재 장면을 분석하고 연결된 카메라에서 지원되는 경우 적절한 깊이 범위를 자동으로 설정합니다(DepthMin, DepthMax).

Status Bar#

상태 표시줄에는 다음과 같은 런타임 정보가 표시됩니다.

  • 현재 FPS
  • 지연 시간(모델에 따라 다름)
  • 프레임 ID
  • 연결 Quality 표시기

Layout Persistence#

뷰어는 창 레이아웃을 저장하고 복원합니다.

  • 창의 위치 및 표시 여부
  • 2D/3D 뷰 열기 및 해당 배치
  • 뷰별 설정

레이아웃은 카메라 유형별로 저장되므로 서로 다른 카메라 제품군 간에 빠르게 전환할 수 있습니다.