콘텐츠로 바로 가기
STAGING SERVER
DEVELOPMENT SERVER

Linux에서 어플릿을 로드하려고 할 때 발생하는 오류 -100 "HAP-file not loaded"#

문제#

사용자 A와 사용자 B 두 명이 하나의 applet을 사용하려고 한다고 가정해 보겠습니다. 사용자 A는 아무 문제 없이 모든 applet을 로드하고 실행할 수 있습니다. 그러나 사용자 B가 동일한 applet을 로드하려고 하면 "HAP-file not loaded" 오류 메시지가 발생합니다:

microDiagnostics의 오류 메시지

해결 방법#

사용자 "A"가 applet을 로드하면 hapcache…라는 임시 디렉터리가 /tmp에 생성됩니다. 이 디렉터리의 액세스 권한은 "rwx — —"로 설정되어 있어 해당 디렉터리의 소유자만 데이터를 읽을 수 있습니다. 따라서 사용자 B가 applet을 로드하려고 하면 로딩이 실패합니다.

이 문제를 해결하려면 /tmp/hapcache… 디렉터리를 삭제하거나 이 디렉터리의 액세스 권한을 예를 들어 "rwx rwx r-x" 등으로 변경하세요.

기술 자료로 돌아가기